summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-01 00:57:52 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-01 00:57:52 +0000
commit6ab09b4696c64a7b3f41bbd8523b1a1786cb14f9 (patch)
tree362cc22b5643c9e95636a1377c0c971278156898 /media-gfx/gphoto2
parent1.8.9.1! (diff)
downloadgentoo-2-6ab09b4696c64a7b3f41bbd8523b1a1786cb14f9.tar.gz
gentoo-2-6ab09b4696c64a7b3f41bbd8523b1a1786cb14f9.tar.bz2
gentoo-2-6ab09b4696c64a7b3f41bbd8523b1a1786cb14f9.zip
moving gphoto2 into its own ebuilds
Diffstat (limited to 'media-gfx/gphoto2')
-rw-r--r--media-gfx/gphoto2/files/digest-gphoto2-2.0-r11
-rw-r--r--media-gfx/gphoto2/gphoto2-2.0-r1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-gfx/gphoto2/files/digest-gphoto2-2.0-r1 b/media-gfx/gphoto2/files/digest-gphoto2-2.0-r1
new file mode 100644
index 000000000000..cc8b6c304bbe
--- /dev/null
+++ b/media-gfx/gphoto2/files/digest-gphoto2-2.0-r1
@@ -0,0 +1 @@
+MD5 f958d3c4b7238a8d6f1827da0d708941 gphoto2-2.0.tar.gz 1705979
diff --git a/media-gfx/gphoto2/gphoto2-2.0-r1.ebuild b/media-gfx/gphoto2/gphoto2-2.0-r1.ebuild
new file mode 100644
index 000000000000..23478be5b391
--- /dev/null
+++ b/media-gfx/gphoto2/gphoto2-2.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author AJ Lewis <aj@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto2/gphoto2-2.0-r1.ebuild,v 1.1 2002/04/01 00:57:52 spider Exp $
+
+MY_P="${PN}-`echo ${PV} |sed -e 's:_::'`"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="free, redistributable digital camera software application"
+SRC_URI="http://www.gphoto.net/dist/${MY_P}.tar.gz"
+HOMEPAGE="http://www.gphoto.org/"
+
+DEPEND="virtual/glibc
+ >=dev-libs/libusb-0.1.5
+ >=dev-libs/glib-1.2.10
+ >=sys-libs/zlib-1.1.4"
+
+
+src_compile() {
+
+ #update libtool to fix "relink" bug.
+ libtoolize --copy --force
+ aclocal
+
+ # -pipe does no work
+ env CFLAGS="${CFLAGS/-pipe/}" ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ || die
+
+ cp libgphoto2/Makefile libgphoto2/Makefile.orig
+ sed -e 's:$(prefix)/doc/gphoto2:/usr/share/doc/${PF}:' \
+ libgphoto2/Makefile.orig >libgphoto2/Makefile
+
+ make || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ gphotodocdir=${D}/usr/share/doc/${PF} \
+ HTML_DIR=${D}/usr/share/doc/${PF}/sgml \
+ install || die
+
+ dodoc ChangeLog NEWS* README
+ rm -rf ${D}/usr/share/doc/${PF}/sgml/gphoto2
+}
+