summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-10 15:47:17 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-10 15:47:17 +0000
commitec56e74cb20c1b956d00adf69403ae5ed2a78474 (patch)
tree0cfdd98e39ae40af4886c886384f98de96c72733 /media-gfx/graphviz
parentalpha/arm/ia64/sh/sparc/x86 stable wrt #339723 (diff)
downloadgentoo-2-ec56e74cb20c1b956d00adf69403ae5ed2a78474.tar.gz
gentoo-2-ec56e74cb20c1b956d00adf69403ae5ed2a78474.tar.bz2
gentoo-2-ec56e74cb20c1b956d00adf69403ae5ed2a78474.zip
Use Python 2 (bug #321665).
(Portage version: 2.2_rc91_p7/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/graphviz')
-rw-r--r--media-gfx/graphviz/ChangeLog6
-rw-r--r--media-gfx/graphviz/graphviz-2.26.3-r2.ebuild11
2 files changed, 15 insertions, 2 deletions
diff --git a/media-gfx/graphviz/ChangeLog b/media-gfx/graphviz/ChangeLog
index 5689a54940f7..cc7665f0645a 100644
--- a/media-gfx/graphviz/ChangeLog
+++ b/media-gfx/graphviz/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/graphviz
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.223 2010/09/05 13:38:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.224 2010/10/10 15:47:17 arfrever Exp $
+
+ 10 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ graphviz-2.26.3-r2.ebuild:
+ Use Python 2 (bug #321665).
*graphviz-2.26.3-r2 (05 Sep 2010)
diff --git a/media-gfx/graphviz/graphviz-2.26.3-r2.ebuild b/media-gfx/graphviz/graphviz-2.26.3-r2.ebuild
index 49eeb7c4c812..21bb2c5eb82d 100644
--- a/media-gfx/graphviz/graphviz-2.26.3-r2.ebuild
+++ b/media-gfx/graphviz/graphviz-2.26.3-r2.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.26.3-r2.ebuild,v 1.1 2010/09/05 13:38:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.26.3-r2.ebuild,v 1.2 2010/10/10 15:47:17 arfrever Exp $
EAPI=3
+PYTHON_DEPEND="python? 2"
+
inherit eutils autotools multilib python
DESCRIPTION="Open Source Graph Visualization Software"
@@ -95,6 +97,13 @@ DEPEND="${RDEPEND}
# - dot, dotty, gvpr, lefty, lneato, tools/* :)
# Lefty needs Xaw and X to build
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
src_prepare() {
# ToDo: Do the same thing for examples and/or
# write a patch for a configuration-option