summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2007-07-05 05:05:40 +0000
committerPeter Weller <welp@gentoo.org>2007-07-05 05:05:40 +0000
commitddc35038d26d680b99e39fad27b1b2e4db07da31 (patch)
tree755ce66a77892807885101ce018b8aec6134d82b /media-gfx/grub-splashes/grub-splashes-0.1.ebuild
parentstable on ppc64 (diff)
downloadgentoo-2-ddc35038d26d680b99e39fad27b1b2e4db07da31.tar.gz
gentoo-2-ddc35038d26d680b99e39fad27b1b2e4db07da31.tar.bz2
gentoo-2-ddc35038d26d680b99e39fad27b1b2e4db07da31.zip
Initial import
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'media-gfx/grub-splashes/grub-splashes-0.1.ebuild')
-rw-r--r--media-gfx/grub-splashes/grub-splashes-0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-gfx/grub-splashes/grub-splashes-0.1.ebuild b/media-gfx/grub-splashes/grub-splashes-0.1.ebuild
new file mode 100644
index 000000000000..7244a4226b85
--- /dev/null
+++ b/media-gfx/grub-splashes/grub-splashes-0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/grub-splashes/grub-splashes-0.1.ebuild,v 1.1 2007/07/05 05:05:40 welp Exp $
+
+DESCRIPTION="Collection of grub splashes"
+HOMEPAGE="http://www.gentoo.org/proj/en/desktop/artwork/index.xml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="|| ( sys-boot/grub sys-boot/grub-static )"
+RDEPEND="${RDEPEND}"
+
+src_install() {
+ cd "$S"
+
+ if [[ -d /boot/grub ]]; then
+ insinto /boot/grub
+ doins *.xpm.gz
+ else
+ die "/boot/grub/ does not exist, please make sure you have /boot mounted"
+ fi
+}
+
+pkg_postinst() {
+ elog "Please note that this ebuild makes the assumption that you're"
+ elog "using /boot/grub/ for your grub configuration."
+ elog ""
+ elog "To your new grub splashes edit your /boot/grub/grub.conf"
+ elog "You can see available splash screens by running"
+ elog "\`ls /boot/grub/ | grep xpm\`"
+}