summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2009-04-20 19:16:59 +0000
committerMarkus Meier <maekke@gentoo.org>2009-04-20 19:16:59 +0000
commitecc332580df6c525f2af5bff456463d9060c0325 (patch)
treedebb22daa8979a63a208f33152a25942b59c2674 /media-gfx/inkscape
parentAdd files needed for applet hosted mode. Thanks to Richard F. Ostrow Jr. <ksh... (diff)
downloadgentoo-2-ecc332580df6c525f2af5bff456463d9060c0325.tar.gz
gentoo-2-ecc332580df6c525f2af5bff456463d9060c0325.tar.bz2
gentoo-2-ecc332580df6c525f2af5bff456463d9060c0325.zip
fix building with gcc-4.4 by Daniel J. in bug #265041
(Portage version: 2.2_rc30/cvs/Linux i686)
Diffstat (limited to 'media-gfx/inkscape')
-rw-r--r--media-gfx/inkscape/ChangeLog6
-rw-r--r--media-gfx/inkscape/files/inkscape-0.46-gcc44.patch188
-rw-r--r--media-gfx/inkscape/inkscape-0.46-r5.ebuild5
3 files changed, 196 insertions, 3 deletions
diff --git a/media-gfx/inkscape/ChangeLog b/media-gfx/inkscape/ChangeLog
index 4c9241b5a7d5..9d9f58cafdbc 100644
--- a/media-gfx/inkscape/ChangeLog
+++ b/media-gfx/inkscape/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/inkscape
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/ChangeLog,v 1.113 2009/03/30 13:44:06 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/ChangeLog,v 1.114 2009/04/20 19:16:58 maekke Exp $
+
+ 20 Apr 2009; Markus Meier <maekke@gentoo.org>
+ +files/inkscape-0.46-gcc44.patch, inkscape-0.46-r5:
+ fix building with gcc-4.4 by Daniel J. in bug #265041
30 Mar 2009; Peter Alfredsen <loki_val@gentoo.org>
inkscape-0.46-r5.ebuild:
diff --git a/media-gfx/inkscape/files/inkscape-0.46-gcc44.patch b/media-gfx/inkscape/files/inkscape-0.46-gcc44.patch
new file mode 100644
index 000000000000..5a7369c0c871
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.46-gcc44.patch
@@ -0,0 +1,188 @@
+diff -Naur inkscape-0.46-orig/src/2geom/sbasis-math.cpp inkscape-0.46/src/2geom/sbasis-math.cpp
+--- inkscape-0.46-orig/src/2geom/sbasis-math.cpp 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/2geom/sbasis-math.cpp 2009-04-05 18:21:30.000000000 -0400
+@@ -38,11 +38,11 @@
+ //#define ZERO 1e-3
+
+
+-namespace Geom {
++#include <math.h>
++#include <cstdio>
+
++namespace Geom {
+
+-#include <stdio.h>
+-#include <math.h>
+
+ //-|x|-----------------------------------------------------------------------
+ Piecewise<SBasis> abs(SBasis const &f){
+diff -Naur inkscape-0.46-orig/src/2geom/svg-path-parser.h inkscape-0.46/src/2geom/svg-path-parser.h
+--- inkscape-0.46-orig/src/2geom/svg-path-parser.h 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/2geom/svg-path-parser.h 2009-04-05 18:21:30.000000000 -0400
+@@ -32,6 +32,7 @@
+ #ifndef SEEN_SVG_PATH_PARSER_H
+ #define SEEN_SVG_PATH_PARSER_H
+
++#include <cstdio>
+ #include <vector>
+ #include <iterator>
+ #include <stdexcept>
+diff -Naur inkscape-0.46-orig/src/dom/domimpl.cpp inkscape-0.46/src/dom/domimpl.cpp
+--- inkscape-0.46-orig/src/dom/domimpl.cpp 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/dom/domimpl.cpp 2009-04-05 18:21:30.000000000 -0400
+@@ -30,6 +30,8 @@
+
+ #include "domimpl.h"
+
++#include <cstdio>
++
+ namespace org
+ {
+ namespace w3c
+diff -Naur inkscape-0.46-orig/src/dom/io/domstream.h inkscape-0.46/src/dom/io/domstream.h
+--- inkscape-0.46-orig/src/dom/io/domstream.h 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/dom/io/domstream.h 2009-04-05 18:21:30.000000000 -0400
+@@ -33,6 +33,8 @@
+
+ #include <dom/dom.h>
+
++#include <cstdio>
++
+ namespace org
+ {
+ namespace w3c
+diff -Naur inkscape-0.46-orig/src/dom/io/socket.h inkscape-0.46/src/dom/io/socket.h
+--- inkscape-0.46-orig/src/dom/io/socket.h 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/dom/io/socket.h 2009-04-05 18:34:14.000000000 -0400
+@@ -29,6 +29,7 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
++#include <cstdio>
+ #include "dom/dom.h"
+
+ #ifdef HAVE_SSL
+diff -Naur inkscape-0.46-orig/src/dom/io/stringstream.h inkscape-0.46/src/dom/io/stringstream.h
+--- inkscape-0.46-orig/src/dom/io/stringstream.h 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/dom/io/stringstream.h 2009-04-05 18:22:50.000000000 -0400
+@@ -29,7 +29,7 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
+-
++#include <cstdio>
+ #include "domstream.h"
+
+
+diff -Naur inkscape-0.46-orig/src/dom/svg/svgtypes.h inkscape-0.46/src/dom/svg/svgtypes.h
+--- inkscape-0.46-orig/src/dom/svg/svgtypes.h 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/dom/svg/svgtypes.h 2009-04-05 18:21:30.000000000 -0400
+@@ -47,6 +47,7 @@
+ #include "dom/smil.h"
+
+
++#include <cstdio>
+ #include <math.h>
+
+
+diff -Naur inkscape-0.46-orig/src/dom/xpathtoken.h inkscape-0.46/src/dom/xpathtoken.h
+--- inkscape-0.46-orig/src/dom/xpathtoken.h 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/dom/xpathtoken.h 2009-04-05 18:21:30.000000000 -0400
+@@ -35,6 +35,7 @@
+
+ #include <math.h>
+
++#include <cstdio>
+ #include <vector>
+
+ namespace org
+diff -Naur inkscape-0.46-orig/src/io/inkscapestream.h inkscape-0.46/src/io/inkscapestream.h
+--- inkscape-0.46-orig/src/io/inkscapestream.h 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/io/inkscapestream.h 2009-04-05 18:21:30.000000000 -0400
+@@ -12,6 +12,7 @@
+ */
+
+
++#include <cstdio>
+ #include <glibmm.h>
+
+ namespace Inkscape
+diff -Naur inkscape-0.46-orig/src/io/sys.cpp inkscape-0.46/src/io/sys.cpp
+--- inkscape-0.46-orig/src/io/sys.cpp 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/io/sys.cpp 2009-04-05 18:21:30.000000000 -0400
+@@ -22,6 +22,8 @@
+ #include <glibmm/ustring.h>
+ #include <gtk/gtkmessagedialog.h>
+
++#include <cstdio>
++
+ #include "prefs-utils.h"
+ #include "sys.h"
+
+diff -Naur inkscape-0.46-orig/src/libavoid/vertices.h inkscape-0.46/src/libavoid/vertices.h
+--- inkscape-0.46-orig/src/libavoid/vertices.h 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/libavoid/vertices.h 2009-04-05 18:21:30.000000000 -0400
+@@ -23,6 +23,7 @@
+ #ifndef AVOID_VERTICES_H
+ #define AVOID_VERTICES_H
+
++#include <cstdio>
+ #include <list>
+ #include <set>
+ #include <map>
+diff -Naur inkscape-0.46-orig/src/libnr/nr-matrix-fns.cpp inkscape-0.46/src/libnr/nr-matrix-fns.cpp
+--- inkscape-0.46-orig/src/libnr/nr-matrix-fns.cpp 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/libnr/nr-matrix-fns.cpp 2009-04-05 18:21:30.000000000 -0400
+@@ -1,5 +1,7 @@
+ #include <libnr/nr-matrix-fns.h>
+
++#include <cstdio>
++
+ namespace NR {
+
+ Matrix elliptic_quadratic_form(Matrix const &m) {
+diff -Naur inkscape-0.46-orig/src/libnr/nr-matrix.cpp inkscape-0.46/src/libnr/nr-matrix.cpp
+--- inkscape-0.46-orig/src/libnr/nr-matrix.cpp 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/libnr/nr-matrix.cpp 2009-04-05 18:21:30.000000000 -0400
+@@ -11,6 +11,7 @@
+ * This code is in public domain
+ */
+
++#include <cstdio>
+ #include <cstdlib>
+ #include "nr-matrix.h"
+
+diff -Naur inkscape-0.46-orig/src/streams-handles.cpp inkscape-0.46/src/streams-handles.cpp
+--- inkscape-0.46-orig/src/streams-handles.cpp 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/streams-handles.cpp 2009-04-05 18:21:30.000000000 -0400
+@@ -12,6 +12,7 @@
+ #include "streams-handles.h"
+ #include "uri.h"
+
++#include <cstdio>
+ #include <iostream>
+
+ namespace Inkscape {
+diff -Naur inkscape-0.46-orig/src/streams-zlib.cpp inkscape-0.46/src/streams-zlib.cpp
+--- inkscape-0.46-orig/src/streams-zlib.cpp 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/streams-zlib.cpp 2009-04-05 18:21:30.000000000 -0400
+@@ -9,6 +9,7 @@
+ * Released under GNU LGPL, read the file 'COPYING.LIB' for more information
+ */
+
++#include <cstdio>
+ #include <cstring>
+ #include <string>
+ #include <string.h>
+diff -Naur inkscape-0.46-orig/src/xml/event.cpp inkscape-0.46/src/xml/event.cpp
+--- inkscape-0.46-orig/src/xml/event.cpp 2009-04-05 16:47:42.000000000 -0400
++++ inkscape-0.46/src/xml/event.cpp 2009-04-05 18:21:30.000000000 -0400
+@@ -14,6 +14,7 @@
+ */
+
+ #include <glib.h> // g_assert()
++#include <cstdio>
+
+ #include "event.h"
+ #include "event-fns.h"
+
diff --git a/media-gfx/inkscape/inkscape-0.46-r5.ebuild b/media-gfx/inkscape/inkscape-0.46-r5.ebuild
index 210f6e054b0c..df6496f177cc 100644
--- a/media-gfx/inkscape/inkscape-0.46-r5.ebuild
+++ b/media-gfx/inkscape/inkscape-0.46-r5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/inkscape-0.46-r5.ebuild,v 1.11 2009/03/30 13:44:06 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/inkscape-0.46-r5.ebuild,v 1.12 2009/04/20 19:16:58 maekke Exp $
EAPI="2"
-inherit gnome2 eutils
+inherit gnome2 eutils autotools
DESCRIPTION="A SVG based generic vector-drawing program"
HOMEPAGE="http://www.inkscape.org/"
@@ -74,6 +74,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
epatch "${FILESDIR}"/${P}-poppler-0.8.3.patch
epatch "${FILESDIR}"/${P}-bug-174720-0.patch
epatch "${FILESDIR}"/${P}-bug-174720-1.patch