summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-18 09:54:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-18 09:54:29 +0000
commit956f4058ec70506c05799a8b5bd8836d521fc264 (patch)
tree680fe33ff845c9149cf827f0b1a4345606442b9e /media-gfx/iscan-plugin-gt-f500
parentVersion bump with new SRC_URI. Thanks to Jared in bug #455776. (diff)
downloadgentoo-2-956f4058ec70506c05799a8b5bd8836d521fc264.tar.gz
gentoo-2-956f4058ec70506c05799a8b5bd8836d521fc264.tar.bz2
gentoo-2-956f4058ec70506c05799a8b5bd8836d521fc264.zip
Version bump with new SRC_URI. Thanks to Jared in bug #455776.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'media-gfx/iscan-plugin-gt-f500')
-rw-r--r--media-gfx/iscan-plugin-gt-f500/ChangeLog11
-rw-r--r--media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild85
2 files changed, 93 insertions, 3 deletions
diff --git a/media-gfx/iscan-plugin-gt-f500/ChangeLog b/media-gfx/iscan-plugin-gt-f500/ChangeLog
index f89d5742fe6f..7041be9d35a4 100644
--- a/media-gfx/iscan-plugin-gt-f500/ChangeLog
+++ b/media-gfx/iscan-plugin-gt-f500/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/iscan-plugin-gt-f500
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-plugin-gt-f500/ChangeLog,v 1.4 2012/06/08 02:15:09 zmedico Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-plugin-gt-f500/ChangeLog,v 1.5 2013/02/18 09:54:29 flameeyes Exp $
+
+*iscan-plugin-gt-f500-1.0.0.1-r1 (18 Feb 2013)
+
+ 18 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org>
+ +iscan-plugin-gt-f500-1.0.0.1-r1.ebuild:
+ Version bump with new SRC_URI. Thanks to Jared in bug #455776.
08 Jun 2012; Zac Medico <zmedico@gentoo.org>
iscan-plugin-gt-f500-1.0.0.1.ebuild:
@@ -21,4 +27,3 @@
20 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+iscan-plugin-gt-f500-1.0.0.1.ebuild, +metadata.xml:
Initial import of the iscan plugin/firmware for EPSON Perfection 2480/2580.
-
diff --git a/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild b/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild
new file mode 100644
index 000000000000..9102d9ff3d78
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild,v 1.1 2013/02/18 09:54:29 flameeyes Exp $
+
+EAPI="4"
+
+inherit multilib rpm versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+
+DESCRIPTION="Epson Perfection 2480/2580 PHOTO scanner plugin for SANE 'epkowa' backend."
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+SRC_URI="http://dev.gentoo.org/~flameeyes/avasys/${MY_P}.c2.i386.rpm"
+
+LICENSE="EPSON EAPL"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+IUSE="minimal"
+
+DEPEND="minimal? ( >=media-gfx/iscan-2.21.0 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ # install scanner firmware
+ insinto /usr/share/iscan
+ doins "${WORKDIR}/usr/share/iscan/"*
+
+ dodoc usr/share/doc/*/*
+
+ use minimal && return
+ # install scanner plugins
+ exeinto /opt/iscan/esci
+ doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
+}
+
+pkg_setup() {
+ basecmds=(
+ "iscan-registry --COMMAND interpreter usb 0x04b8 0x0121 '/opt/iscan/esci/libesint41.so.2 /usr/share/iscan/esfw41.bin'"
+ )
+}
+
+pkg_postinst() {
+ elog
+ elog "Firmware file esfw41.bin for Epson Perfection 2480/2580 PHOTO"
+ elog "has been installed in /usr/share/iscan."
+ elog
+ use minimal && return
+ [[ -n ${REPLACING_VERSIONS} ]] && return
+
+ # Needed for scanner to work properly.
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/add}
+ done
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/add}"
+ done
+ fi
+}
+
+pkg_prerm() {
+ use minimal && return
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/remove}
+ done
+ else
+ ewarn "Unable to de-register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/remove}"
+ done
+ fi
+}