summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-26 16:13:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-26 16:13:06 +0000
commita9fd71b3a4381dcdd58a1176787c26dd6b43542c (patch)
tree56e02b8ddc0dda1bd12a042c5066675d9e685854 /media-gfx/iscan-plugin-perfection-v370
parentEnable multilib. (diff)
downloadgentoo-2-a9fd71b3a4381dcdd58a1176787c26dd6b43542c.tar.gz
gentoo-2-a9fd71b3a4381dcdd58a1176787c26dd6b43542c.tar.bz2
gentoo-2-a9fd71b3a4381dcdd58a1176787c26dd6b43542c.zip
Initial import of plugin for EPSON Perfection V370 scanner.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'media-gfx/iscan-plugin-perfection-v370')
-rw-r--r--media-gfx/iscan-plugin-perfection-v370/ChangeLog9
-rw-r--r--media-gfx/iscan-plugin-perfection-v370/iscan-plugin-perfection-v370-1.0.0.2.ebuild94
-rw-r--r--media-gfx/iscan-plugin-perfection-v370/metadata.xml19
3 files changed, 122 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-perfection-v370/ChangeLog b/media-gfx/iscan-plugin-perfection-v370/ChangeLog
new file mode 100644
index 000000000000..864056c2923a
--- /dev/null
+++ b/media-gfx/iscan-plugin-perfection-v370/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-gfx/iscan-plugin-perfection-v370
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-plugin-perfection-v370/ChangeLog,v 1.1 2013/02/26 16:13:06 flameeyes Exp $
+
+*iscan-plugin-perfection-v370-1.0.0.2 (26 Feb 2013)
+
+ 26 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org>
+ +iscan-plugin-perfection-v370-1.0.0.2.ebuild, +metadata.xml:
+ Initial import of plugin for EPSON Perfection V370 scanner.
diff --git a/media-gfx/iscan-plugin-perfection-v370/iscan-plugin-perfection-v370-1.0.0.2.ebuild b/media-gfx/iscan-plugin-perfection-v370/iscan-plugin-perfection-v370-1.0.0.2.ebuild
new file mode 100644
index 000000000000..990981da5d0d
--- /dev/null
+++ b/media-gfx/iscan-plugin-perfection-v370/iscan-plugin-perfection-v370-1.0.0.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-plugin-perfection-v370/iscan-plugin-perfection-v370-1.0.0.2.ebuild,v 1.1 2013/02/26 16:13:06 flameeyes Exp $
+
+EAPI=5
+
+inherit rpm versionator multilib
+
+MY_PV="$(get_version_component_range 1-3)"
+MY_PVR="$(replace_version_separator 3 -)"
+
+SCANNER="Perfection V370"
+FIRMWARE="esfwdd.bin"
+
+DESCRIPTION="Epson ${SCANNER} and similar scanner plugin for SANE 'epkowa' backend."
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+SRC_URI="amd64? ( http://dev.gentoo.org/~flameeyes/avasys/${PN}-${MY_PVR}.x86_64.rpm )
+ x86? ( http://dev.gentoo.org/~flameeyes/avasys/${PN}-${MY_PVR}.i386.rpm )"
+
+LICENSE="AVASYS"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=">=media-gfx/iscan-2.21.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/opt/iscan/lib/*"
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ # install scanner firmware
+ insinto /usr/share/iscan
+ doins "${WORKDIR}"/usr/share/iscan/*
+
+ dodoc usr/share/doc/*/*
+
+ # install scanner plugins
+ exeinto /opt/iscan/lib
+ doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
+}
+
+pkg_setup() {
+ basecmds=(
+ "iscan-registry --COMMAND interpreter usb 0x04b8 0x014a /opt/iscan/lib/libiscan-plugin-perfection-v370 /usr/share/iscan/${FIRMWARE}"
+ )
+}
+
+pkg_postinst() {
+ elog
+ elog "Firmware file ${FIRMWARE} for ${SCANNER}"
+ elog "has been installed in /usr/share/iscan."
+ elog
+
+ # Only register scanner on new installs
+ [[ -n ${REPLACING_VERSIONS} ]] && return
+
+ # Needed for scanner to work properly.
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/add}
+ done
+ elog "New firmware has been registered automatically."
+ elog
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/add}"
+ done
+ fi
+}
+
+pkg_prerm() {
+ # Only unregister on on uninstall
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/remove}
+ done
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/remove}"
+ done
+ fi
+}
diff --git a/media-gfx/iscan-plugin-perfection-v370/metadata.xml b/media-gfx/iscan-plugin-perfection-v370/metadata.xml
new file mode 100644
index 000000000000..93e07c910e9e
--- /dev/null
+++ b/media-gfx/iscan-plugin-perfection-v370/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Proprietary plugin for several EPSON scanner models, to be used
+ with the epkowa SANE backend (provided by
+ <pkg>media-gfx/iscan</pkg>). 32-bit and 64-bit.
+
+ Supports the following models:
+
+ Epson GT-F740
+ Epson GT-S640
+ Epson Perfection V37
+ Epson Perfection V370 Photo
+ </longdescription>
+</pkgmetadata>