summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-21 16:48:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-21 16:48:03 +0000
commitb185eec3668a8aaa91cfadc0f55abf46575e89a5 (patch)
treeaed4af5e304932fd4dc581188706e1434f3fb5f5 /media-gfx/iscan
parentFix up metadata.xml. If there's no maintainer for the package, the metadata a... (diff)
downloadgentoo-2-b185eec3668a8aaa91cfadc0f55abf46575e89a5.tar.gz
gentoo-2-b185eec3668a8aaa91cfadc0f55abf46575e89a5.tar.bz2
gentoo-2-b185eec3668a8aaa91cfadc0f55abf46575e89a5.zip
Run full-fledged eautoreconf, otherwise the maintainer-mode will re-run it anyway causing two runs of autoconf; add patch to build with GCC 4.3.
(Portage version: 2.1.5_rc5)
Diffstat (limited to 'media-gfx/iscan')
-rw-r--r--media-gfx/iscan/ChangeLog7
-rw-r--r--media-gfx/iscan/files/iscan-2.10.0+gcc-4.3.patch33
-rw-r--r--media-gfx/iscan/iscan-2.10.0.ebuild8
3 files changed, 44 insertions, 4 deletions
diff --git a/media-gfx/iscan/ChangeLog b/media-gfx/iscan/ChangeLog
index dd051c60d08c..dcb02aa5b78b 100644
--- a/media-gfx/iscan/ChangeLog
+++ b/media-gfx/iscan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/iscan
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/ChangeLog,v 1.24 2008/01/26 03:23:50 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/ChangeLog,v 1.25 2008/04/21 16:48:02 flameeyes Exp $
+
+ 21 Apr 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/iscan-2.10.0+gcc-4.3.patch, iscan-2.10.0.ebuild:
+ Run full-fledged eautoreconf, otherwise the maintainer-mode will re-run it
+ anyway causing two runs of autoconf; add patch to build with GCC 4.3.
26 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
-iscan-2.4.0-r1.ebuild, -iscan-2.6.0.ebuild, -iscan-2.7.0.ebuild:
diff --git a/media-gfx/iscan/files/iscan-2.10.0+gcc-4.3.patch b/media-gfx/iscan/files/iscan-2.10.0+gcc-4.3.patch
new file mode 100644
index 000000000000..676c761fe129
--- /dev/null
+++ b/media-gfx/iscan/files/iscan-2.10.0+gcc-4.3.patch
@@ -0,0 +1,33 @@
+Index: iscan-2.10.0/lib/imgstream.cc
+===================================================================
+--- iscan-2.10.0.orig/lib/imgstream.cc
++++ iscan-2.10.0/lib/imgstream.cc
+@@ -28,11 +28,15 @@
+
+ #include <argz.h>
+
++#include <cstdlib>
++
+ #include "imgstream.hh"
+
+ namespace iscan
+ {
+
++
++
+ imgstream::imgstream ()
+ : imgstream_base_t (NULL), _fbuf (new filebuf (NULL)), _mine (true)
+ {
+Index: iscan-2.10.0/lib/jpegstream.cc
+===================================================================
+--- iscan-2.10.0.orig/lib/jpegstream.cc
++++ iscan-2.10.0/lib/jpegstream.cc
+@@ -26,6 +26,8 @@
+ // the GNU General Public License in all respects for all of the
+ // code used other then esmod.
+
++#include <cstdlib>
++
+ #include "jpegstream.hh"
+
+ #include "gettext.h"
diff --git a/media-gfx/iscan/iscan-2.10.0.ebuild b/media-gfx/iscan/iscan-2.10.0.ebuild
index 2bf83c8ad5d0..71200641f33f 100644
--- a/media-gfx/iscan/iscan-2.10.0.ebuild
+++ b/media-gfx/iscan/iscan-2.10.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/iscan-2.10.0.ebuild,v 1.1 2007/11/17 20:47:33 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/iscan-2.10.0.ebuild,v 1.2 2008/04/21 16:48:02 flameeyes Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -195,8 +195,10 @@ src_unpack() {
sed -i -e 's:iscan.1::g' doc/Makefile*
fi
+ epatch "${FILESDIR}/${P}+gcc-4.3.patch"
+
# autotool stuff
- eautoconf
+ eautoreconf
}
src_compile() {