summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-02-15 22:43:51 +0000
committerTim Harder <radhermit@gentoo.org>2013-02-15 22:43:51 +0000
commit87c40a84ed4ae58c2f6a1eb447c77b72daa2ab98 (patch)
tree38d897fdac814b14127676261c5b40f22ba76dc9 /media-gfx/jhead
parentStable for sparc, wrt bug #457236 (diff)
downloadgentoo-2-87c40a84ed4ae58c2f6a1eb447c77b72daa2ab98.tar.gz
gentoo-2-87c40a84ed4ae58c2f6a1eb447c77b72daa2ab98.tar.bz2
gentoo-2-87c40a84ed4ae58c2f6a1eb447c77b72daa2ab98.zip
Version bump.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-gfx/jhead')
-rw-r--r--media-gfx/jhead/ChangeLog9
-rw-r--r--media-gfx/jhead/jhead-2.97.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/media-gfx/jhead/ChangeLog b/media-gfx/jhead/ChangeLog
index af25443631af..8d5735df80b9 100644
--- a/media-gfx/jhead/ChangeLog
+++ b/media-gfx/jhead/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/jhead
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/ChangeLog,v 1.141 2012/09/08 08:30:02 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/ChangeLog,v 1.142 2013/02/15 22:43:51 radhermit Exp $
+
+*jhead-2.97 (15 Feb 2013)
+
+ 15 Feb 2013; Tim Harder <radhermit@gentoo.org> +jhead-2.97.ebuild:
+ Version bump.
08 Sep 2012; Tim Harder <radhermit@gentoo.org> -jhead-2.95.ebuild:
Remove old.
diff --git a/media-gfx/jhead/jhead-2.97.ebuild b/media-gfx/jhead/jhead-2.97.ebuild
new file mode 100644
index 000000000000..c5c5b69c510f
--- /dev/null
+++ b/media-gfx/jhead/jhead-2.97.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/jhead-2.97.ebuild,v 1.1 2013/02/15 22:43:51 radhermit Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
+HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
+SRC_URI="http://www.sentex.net/~mwandel/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_prepare() {
+ # bug 275200 - respect flags and use mktemp instead of mkstemp
+ epatch "${FILESDIR}"/${PN}-2.90-mkstemp_respect_flags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc *.txt
+ dohtml *.html
+ doman ${PN}.1
+}