summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIoannis Aslanidis <deathwing00@gentoo.org>2007-01-21 11:38:43 +0000
committerIoannis Aslanidis <deathwing00@gentoo.org>2007-01-21 11:38:43 +0000
commit4d8556302c74e243f0f313c3c506ba2028308f01 (patch)
tree0511a3b0df36ea4c92e22604f277aa7fbf6b3c91 /media-gfx/kphotoalbum/kphotoalbum-3.0.ebuild
parentRevision bump, fixing the initpost patch (thanks to Karel Hala <stripe at suc... (diff)
downloadgentoo-2-4d8556302c74e243f0f313c3c506ba2028308f01.tar.gz
gentoo-2-4d8556302c74e243f0f313c3c506ba2028308f01.tar.bz2
gentoo-2-4d8556302c74e243f0f313c3c506ba2028308f01.zip
Fixed bug #162659.
(Portage version: 2.1.2-r1)
Diffstat (limited to 'media-gfx/kphotoalbum/kphotoalbum-3.0.ebuild')
-rw-r--r--media-gfx/kphotoalbum/kphotoalbum-3.0.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/media-gfx/kphotoalbum/kphotoalbum-3.0.ebuild b/media-gfx/kphotoalbum/kphotoalbum-3.0.ebuild
index a425a6ced4f2..65ff60d81aa8 100644
--- a/media-gfx/kphotoalbum/kphotoalbum-3.0.ebuild
+++ b/media-gfx/kphotoalbum/kphotoalbum-3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/kphotoalbum/kphotoalbum-3.0.ebuild,v 1.1 2007/01/13 19:41:57 centic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/kphotoalbum/kphotoalbum-3.0.ebuild,v 1.2 2007/01/21 11:38:43 deathwing00 Exp $
inherit kde
@@ -48,3 +48,14 @@ pkg_setup()
fi
}
+src_compile()
+{
+ if ! use exif; then
+ einfo "NOTICE: You have the exif USE flag disabled. ${CATEGORY}/${PN}"
+ einfo "will be compiled without EXIF support unless you installed"
+ einfo "media-gfx/exiv2 manually."
+ local myconf="--disable-exiv2"
+ fi
+ kde_src_compile
+}
+