summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Marlowe <mattm@gentoo.org>2013-02-11 03:56:07 +0000
committerMatthew Marlowe <mattm@gentoo.org>2013-02-11 03:56:07 +0000
commitbf51d95743d41e883968f6dcf43d153a3f174cd2 (patch)
treeeef146c95f9195f194cee55b8269f2746a6f5d6f /media-gfx/opencsg
parentNew package, dependency of latest akonadi-facebook snapshot (diff)
downloadgentoo-2-bf51d95743d41e883968f6dcf43d153a3f174cd2.tar.gz
gentoo-2-bf51d95743d41e883968f6dcf43d153a3f174cd2.tar.bz2
gentoo-2-bf51d95743d41e883968f6dcf43d153a3f174cd2.zip
Fix for bug 436532, thanks to Toffanin for patch/testing.
(Portage version: 2.1.11.43/cvs/Linux x86_64, signed Manifest commit with key 786037A7)
Diffstat (limited to 'media-gfx/opencsg')
-rw-r--r--media-gfx/opencsg/ChangeLog9
-rw-r--r--media-gfx/opencsg/opencsg-1.3.2-r1.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/media-gfx/opencsg/ChangeLog b/media-gfx/opencsg/ChangeLog
index 1fa132883b72..49f965dd7d36 100644
--- a/media-gfx/opencsg/ChangeLog
+++ b/media-gfx/opencsg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/opencsg
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/opencsg/ChangeLog,v 1.3 2012/08/21 07:47:57 mattm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/opencsg/ChangeLog,v 1.4 2013/02/11 03:56:07 mattm Exp $
+
+*opencsg-1.3.2-r1 (11 Feb 2013)
+
+ 11 Feb 2013; Matthew Marlowe <mattm@gentoo.org> +opencsg-1.3.2-r1.ebuild:
+ Fix for bug 436532, thanks to Toffanin for patch/testing.
21 Aug 2012; Matthew Marlowe <mattm@gentoo.org> opencsg-1.3.2.ebuild:
Moved to testing arches so that packages that depend on opencsg can also enter
diff --git a/media-gfx/opencsg/opencsg-1.3.2-r1.ebuild b/media-gfx/opencsg/opencsg-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..510416d354b8
--- /dev/null
+++ b/media-gfx/opencsg/opencsg-1.3.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/opencsg/opencsg-1.3.2-r1.ebuild,v 1.1 2013/02/11 03:56:07 mattm Exp $
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="The Constructive Solid Geometry rendering library"
+HOMEPAGE="http://www.opencsg.org"
+SRC_URI="http://www.opencsg.org/OpenCSG-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="media-libs/glew x11-libs/qt-core:4"
+DEPEND="${CDEPEND} sys-devel/gcc"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/OpenCSG-${PV}"
+
+src_prepare() {
+ # removes duplicated headers
+ rm -r "${S}"/glew || die
+
+ # We actually want to install something
+ cat << EOF >> src/src.pro
+include.path=/usr/include
+include.files=../include/*
+target.path=/usr/$(get_libdir)
+INSTALLS += target include
+EOF
+
+}
+
+src_configure() {
+ eqmake4 "${S}"/src/src.pro
+}