summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-02-10 10:59:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-02-10 10:59:12 +0000
commit7ba485248bd18a35a21d63eaf4303cd80775bc28 (patch)
tree38bdbbb95869b2def8dad7ae16cf852150236db4 /media-gfx/sam2p/files/sam2p-0.45-cflags.patch
parentx86 stable, bug #208933 (diff)
downloadgentoo-2-7ba485248bd18a35a21d63eaf4303cd80775bc28.tar.gz
gentoo-2-7ba485248bd18a35a21d63eaf4303cd80775bc28.tar.bz2
gentoo-2-7ba485248bd18a35a21d63eaf4303cd80775bc28.zip
Respect cflags, dont prestrip executables, call gmake for Makedep as GNU make is required, import a patch from bsd ports to make it build on fbsd, keyword ~x86-fbsd; install examples via examples useflag. There still remains that 'gmake Makedep' breaks if used with distcc, I couldn't fix it.
(Portage version: 2.1.4.2)
Diffstat (limited to 'media-gfx/sam2p/files/sam2p-0.45-cflags.patch')
-rw-r--r--media-gfx/sam2p/files/sam2p-0.45-cflags.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/sam2p/files/sam2p-0.45-cflags.patch b/media-gfx/sam2p/files/sam2p-0.45-cflags.patch
new file mode 100644
index 000000000000..d6636d5308cf
--- /dev/null
+++ b/media-gfx/sam2p/files/sam2p-0.45-cflags.patch
@@ -0,0 +1,37 @@
+Index: sam2p-0.45/configure.in
+===================================================================
+--- sam2p-0.45.orig/configure.in
++++ sam2p-0.45/configure.in
+@@ -81,7 +81,7 @@ fi
+ dnl Checks for programs.
+ dnl AC_PROG_CC
+ AC_LANG_CPLUSPLUS
+-CXXFLAGS=" "
++#CXXFLAGS=" "
+ dnl ^^^ set it to non-empty, so AC_PROG_CXX won't include `-g'
+ CCC="$CCC g++"
+ dnl ^^^ check g++ before c++ (see acspecific.m4, grep AC_PROG_CXX)
+@@ -215,7 +215,7 @@ AC_OUTPUT(Makehelp)
+
+ dnl AC_PTS_RUN_OK([perl -x -S ./ccdep.pl $CXX], [], [AC_MSG_ERROR(cannot compute depends)])
+ rm -f Makedep
+-AC_PTS_RUN_OK([make Makedep], [], [AC_MSG_ERROR(cannot compute depends)])
++AC_PTS_RUN_OK([gmake Makedep], [], [AC_MSG_ERROR(cannot compute depends)])
+ AC_PTS_OK
+ echo "configure done. Now you should run: make; make install"
+
+Index: sam2p-0.45/Makefile
+===================================================================
+--- sam2p-0.45.orig/Makefile
++++ sam2p-0.45/Makefile
+@@ -49,8 +49,8 @@ IDE_MODES := release debug
+ IDE_TARGETS_debug := $(patsubst %,%.yes, $(TARGETS))
+ IDE_TARGETS_release := $(TARGETS)
+
+-CXD_assert =$(CXX) -s -O2
+-CXD_no =$(CXX) -s -DNDEBUG -O3
++CXD_assert =$(CXX)
++CXD_no =$(CXX) -DNDEBUG
+ # CXD_yes =$(CXX) $(GFLAG) -lefence
+ CXD_yes =$(CXX) $(GFLAG)
+ CXD_checker=checkerg++ $(GFLAG)