summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-04-27 08:08:38 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-04-27 08:08:38 +0000
commit01eb0e2621d7bd7c0a7176ed686996d709c74a6c (patch)
treed33433f08b89e225f5fe0e5ab85f32f93c7a41f7 /media-gfx/sane-backends/sane-backends-1.0.15-r1.ebuild
parentFixed HOMEPAGE and SRC_URI for bug #90433. (diff)
downloadgentoo-2-01eb0e2621d7bd7c0a7176ed686996d709c74a6c.tar.gz
gentoo-2-01eb0e2621d7bd7c0a7176ed686996d709c74a6c.tar.bz2
gentoo-2-01eb0e2621d7bd7c0a7176ed686996d709c74a6c.zip
Fixes for gt68xx-based scanners (bug #90442)
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-gfx/sane-backends/sane-backends-1.0.15-r1.ebuild')
-rw-r--r--media-gfx/sane-backends/sane-backends-1.0.15-r1.ebuild106
1 files changed, 106 insertions, 0 deletions
diff --git a/media-gfx/sane-backends/sane-backends-1.0.15-r1.ebuild b/media-gfx/sane-backends/sane-backends-1.0.15-r1.ebuild
new file mode 100644
index 000000000000..2b6af24bbb43
--- /dev/null
+++ b/media-gfx/sane-backends/sane-backends-1.0.15-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/sane-backends-1.0.15-r1.ebuild,v 1.1 2005/04/27 08:08:38 phosphan Exp $
+
+inherit eutils
+
+IUSE="usb gphoto2 ipv6"
+
+DESCRIPTION="Scanner Access Now Easy - Backends"
+HOMEPAGE="http://www.sane-project.org/"
+
+DEPEND=">=media-libs/jpeg-6b
+ x86? ( sys-libs/libieee1284 )
+ =sys-apps/sed-4*
+ usb? ( dev-libs/libusb )
+ gphoto2? ( media-gfx/gphoto2 )"
+
+BROTHERMFCDRIVER="sane-backends-1.0.15-brothermfc.patch"
+
+SRC_URI="ftp://ftp.mostang.com/pub/sane/${P}/${P}.tar.gz
+ ftp://ftp.mostang.com/pub/sane/old-versions/${P}/${P}.tar.gz
+ usb? ( mirror://gentoo/${BROTHERMFCDRIVER}.bz2 )"
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="~x86 ~sparc ~ppc ~ppc64 ~amd64 ~alpha"
+
+
+src_unpack() {
+ unpack ${A}
+ if use usb; then
+ unpack ${BROTHERMFCDRIVER}.bz2
+ fi
+ cp ${FILESDIR}/linux_sg3_err.h ${S}/sanei
+
+ cd ${S}
+
+ epatch ${FILESDIR}/canoscan-focus.patch
+ epatch ${FILESDIR}/sane-backend-1.0.15-gt68xx-update67.patch
+
+ #only generate the .ps and not the fonts
+ sed -i -e 's:$(DVIPS) sane.dvi -o sane.ps:$(DVIPS) sane.dvi -M1 -o sane.ps:' \
+ doc/Makefile.in
+ #compile errors when using NDEBUG otherwise
+ sed -i -e 's:function_name:__FUNCTION__:g' backend/artec_eplus48u.c
+ use usb && epatch ${WORKDIR}/${BROTHERMFCDRIVER}
+ use usb && epatch ${FILESDIR}/libusbscanner-device-r1.patch
+}
+
+src_compile() {
+ local myconf
+ myconf="$(use_enable usb libusb) $(use_with gphoto2) $(use_enable ipv6)"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die
+ make || die
+ if use usb; then
+ cd tools/hotplug
+ grep < libsane.usermap -v '^$' > libsane.usermap.new
+ mv libsane.usermap.new libsane.usermap
+ fi
+}
+
+src_install () {
+
+
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ mandir=${D}/usr/share/man \
+ docdir=${D}/usr/share/doc/${PF} \
+ libdir=${D}/usr/$(get_libdir) \
+ install || die
+
+ if use usb; then
+ cd tools/hotplug
+ insinto /etc/hotplug/usb
+ exeinto /etc/hotplug/usb
+ doins libsane.usermap
+ doexe libusbscanner
+ newdoc README README.hotplug
+ cd ../..
+ fi
+
+ docinto backend
+ cd backend
+ dodoc GUIDE *.README *.BUGS *.CHANGES *.FAQ *.TODO
+
+ echo "SANE_CONFIG_DIR=/etc/sane.d" > 30sane
+ insinto /etc/env.d
+ doins 30sane
+
+}
+
+pkg_preinst() {
+ enewgroup scanner
+}
+
+pkg_postinst() {
+ if use usb; then
+ einfo "There are some problems with the hotplug script when"
+ einfo "restarting hotplug with some kernel versions."
+ einfo "If you have trouble, please edit"
+ einfo "/etc/hotplug/usb/libusbscanner"
+ einfo "and see bug #50934 for details."
+ fi
+}