summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2008-08-12 20:11:13 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2008-08-12 20:11:13 +0000
commit765a53472716f0ba2cb27396c8f82e9567efc0ff (patch)
tree0606c6e3120d2687339dbefb4fa578a328d93486 /media-gfx/sane-backends
parentdevelopment versions of cairo (diff)
downloadgentoo-2-765a53472716f0ba2cb27396c8f82e9567efc0ff.tar.gz
gentoo-2-765a53472716f0ba2cb27396c8f82e9567efc0ff.tar.bz2
gentoo-2-765a53472716f0ba2cb27396c8f82e9567efc0ff.zip
Fix for parallel install jobs, see bug #228937
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-gfx/sane-backends')
-rw-r--r--media-gfx/sane-backends/ChangeLog6
-rw-r--r--media-gfx/sane-backends/files/parallel-install-1.0.19.patch30
-rw-r--r--media-gfx/sane-backends/sane-backends-1.0.19-r2.ebuild5
3 files changed, 38 insertions, 3 deletions
diff --git a/media-gfx/sane-backends/ChangeLog b/media-gfx/sane-backends/ChangeLog
index 926b6b86933c..63ab28384301 100644
--- a/media-gfx/sane-backends/ChangeLog
+++ b/media-gfx/sane-backends/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/sane-backends
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.147 2008/08/06 19:31:12 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.148 2008/08/12 20:11:13 phosphan Exp $
+
+ 12 Aug 2008; Patrick Kursawe <phosphan@gentoo.org>
+ +files/parallel-install-1.0.19.patch, sane-backends-1.0.19-r2.ebuild:
+ Fix for parallel install jobs, see bug #228937
06 Aug 2008; Markus Meier <maekke@gentoo.org>
sane-backends-1.0.19-r1.ebuild:
diff --git a/media-gfx/sane-backends/files/parallel-install-1.0.19.patch b/media-gfx/sane-backends/files/parallel-install-1.0.19.patch
new file mode 100644
index 000000000000..bc26ef53a389
--- /dev/null
+++ b/media-gfx/sane-backends/files/parallel-install-1.0.19.patch
@@ -0,0 +1,30 @@
+--- backend/Makefile.in 2008-08-12 21:50:12.000000000 +0200
++++ backend/Makefile.in.new 2008-08-12 21:58:24.000000000 +0200
+@@ -234,8 +234,10 @@
+
+ install: $(INSTALL_LOCKPATH) install-be@BE_INSTALL_FLAVOR@ install-libsane install-becfg
+
+-install-be:
++install-paths:
+ $(MKDIR) $(DESTDIR)$(libdir) $(DESTDIR)$(libsanedir) $(DESTDIR)$(configdir)
++
++install-be: install-paths
+ @# Install all backends in $(prefix)/lib/sane/
+ @list="$(LIBS)"; for be in $$list; do \
+ echo installing $${be} in $(DESTDIR)$(libsanedir)/$${be}...; \
+@@ -267,13 +269,13 @@
+ cp -p .libs/libsane-$${be}.so $(DESTDIR)$(BEOS_ADDONDIR)/$${be} || exit 1; \
+ done
+
+-install-libsane:
++install-libsane: install-paths
+ @echo installing libsane.la in $(DESTDIR)$(libdir)/libsane.la...
+ @$(LIBTOOL) $(MINST) $(INSTALL_PROGRAM) libsane.la \
+ $(DESTDIR)$(libdir)/libsane.la >/dev/null
+ @$(LIBTOOL) $(MINST) --finish $(DESTDIR)$(libdir)
+
+-install-becfg:
++install-becfg: install-paths
+ @list="$(CONFIGS)"; for cfg in $$list; do \
+ if test ! -r $${cfg}; then continue; fi; \
+ if test -f $(DESTDIR)$(configdir)/$${cfg}; then \
diff --git a/media-gfx/sane-backends/sane-backends-1.0.19-r2.ebuild b/media-gfx/sane-backends/sane-backends-1.0.19-r2.ebuild
index ff5a78cda482..6a1b4b8ca980 100644
--- a/media-gfx/sane-backends/sane-backends-1.0.19-r2.ebuild
+++ b/media-gfx/sane-backends/sane-backends-1.0.19-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/sane-backends-1.0.19-r2.ebuild,v 1.1 2008/08/01 15:18:23 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/sane-backends-1.0.19-r2.ebuild,v 1.2 2008/08/12 20:11:13 phosphan Exp $
inherit eutils
@@ -100,7 +100,8 @@ src_unpack() {
fi
epatch "${FILESDIR}"/udev-rule-5.patch
epatch "${FILESDIR}"/fujitsu_DBG_LEVEL.patch
- epatch "${FILESDIR}"/epson2fixes-"${PV}".patch
+ epatch "${FILESDIR}/epson2fixes-${PV}".patch
+ epatch "${FILESDIR}/parallel-install-${PV}".patch
cat >> backend/dll.conf.in <<-EOF
# Add support for the HP-specific backend. Needs net-print/hplip installed.
hpaio