summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-12-28 22:55:23 +0000
committerMichael Januszewski <spock@gentoo.org>2008-12-28 22:55:23 +0000
commit055b58fc36906d8b3c75d81490fee8a4b328577e (patch)
tree526ebfe96b66d2e38df0ea62929afec6abbb6e37 /media-gfx/splashutils/splashutils-1.5.4.3.ebuild
parentfixed #250715. (diff)
downloadgentoo-2-055b58fc36906d8b3c75d81490fee8a4b328577e.tar.gz
gentoo-2-055b58fc36906d8b3c75d81490fee8a4b328577e.tar.bz2
gentoo-2-055b58fc36906d8b3c75d81490fee8a4b328577e.zip
Fix bug #252134 (compatibility with OpenRC 0.4.x) and #251953 (pre-stripped files). Remove forced serial make (-j1) in 1.5.4.3.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-rc8 x86_64)
Diffstat (limited to 'media-gfx/splashutils/splashutils-1.5.4.3.ebuild')
-rw-r--r--media-gfx/splashutils/splashutils-1.5.4.3.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/media-gfx/splashutils/splashutils-1.5.4.3.ebuild b/media-gfx/splashutils/splashutils-1.5.4.3.ebuild
index 9e3c0b48e28c..401678dffcea 100644
--- a/media-gfx/splashutils/splashutils-1.5.4.3.ebuild
+++ b/media-gfx/splashutils/splashutils-1.5.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4.3.ebuild,v 1.2 2008/12/11 16:01:13 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4.3.ebuild,v 1.3 2008/12/28 22:55:23 spock Exp $
EAPI="1"
@@ -83,6 +83,12 @@ src_unpack() {
if ! use truetype ; then
sed -i -e 's/fbtruetype kbd/kbd/' "${SM}/Makefile"
fi
+
+ if has_version ">=sys-apps/openrc-0.4.0"; then
+ cd "${SG}"
+ epatch "${FILESDIR}"/splashutils-openrc-0.4-fix.patch
+ cd "${S}"
+ fi
}
src_compile() {
@@ -103,7 +109,7 @@ src_compile() {
--with-lpng-src=${LPNGSRC} \
--with-zlib-src=${ZLIBSRC} || die "failed to configure splashutils"
- emake -j1 KLCC="${CC}" CC="${CC}" || die "failed to build splashutils"
+ emake KLCC="${CC}" CC="${CC}" STRIP="true" || die "failed to build splashutils"
if has_version ">=sys-apps/baselayout-1.13.99"; then
cd "${SG}"
@@ -118,7 +124,7 @@ src_install() {
make DESTDIR="${D}" LIB=${LIB} install || die
cd "${S}"
- make DESTDIR="${D}" install || die
+ make DESTDIR="${D}" STRIP="true" install || die
mv "${D}"/usr/${LIB}/libfbsplash.so* "${D}"/${LIB}/
gen_usr_ldscript libfbsplash.so