summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-06-12 13:40:40 +0000
committerMichael Januszewski <spock@gentoo.org>2005-06-12 13:40:40 +0000
commit0451f5be50bdc0a95a8ddea8f4c8483340f215b1 (patch)
tree0ea5079c125c1b6ee8f666444d6b263d50648206 /media-gfx/splashutils
parentStable on alpha. (diff)
downloadgentoo-2-0451f5be50bdc0a95a8ddea8f4c8483340f215b1.tar.gz
gentoo-2-0451f5be50bdc0a95a8ddea8f4c8483340f215b1.tar.bz2
gentoo-2-0451f5be50bdc0a95a8ddea8f4c8483340f215b1.zip
Negate -fstack-protector regardless of the 'hardened' USE flag state (fix for bug #71193).
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-gfx/splashutils')
-rw-r--r--media-gfx/splashutils/ChangeLog7
-rw-r--r--media-gfx/splashutils/splashutils-0.9.1.ebuild8
-rw-r--r--media-gfx/splashutils/splashutils-1.1.9.6.ebuild16
3 files changed, 12 insertions, 19 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index 6ade817bf3b4..07fdacdae7c3 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.31 2005/06/12 13:38:23 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.32 2005/06/12 13:40:40 spock Exp $
+
+ 12 Jun 2005; Michał Januszewski <spock@gentoo.org>
+ splashutils-0.9.1.ebuild, splashutils-1.1.9.6.ebuild:
+ Negate -fstack-protector regardless of the 'hardened' USE flag state (fix
+ for bug #71193).
12 Jun 2005; Michał Januszewski <spock@gentoo.org>
-splashutils-1.1.9.5.ebuild:
diff --git a/media-gfx/splashutils/splashutils-0.9.1.ebuild b/media-gfx/splashutils/splashutils-0.9.1.ebuild
index 5fa8e7272374..e1323284ca0e 100644
--- a/media-gfx/splashutils/splashutils-0.9.1.ebuild
+++ b/media-gfx/splashutils/splashutils-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-0.9.1.ebuild,v 1.6 2005/06/05 12:24:47 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-0.9.1.ebuild,v 1.7 2005/06/12 13:40:40 spock Exp $
MISCSPLASH="miscsplashutils-0.1.2"
GENTOOSPLASH="splashutils-gentoo-0.1.4"
@@ -63,10 +63,8 @@ src_unpack() {
fi
# this should make this version of splashutils compile with hardened systems
- if use hardened; then
- sed -e 's@K_CFLAGS =@K_CFLAGS = -fno-stack-protector@' -i ${S}/Makefile
- sed -e 's@CFLAGS =@CFLAGS = -fno-stack-protector@' -i ${S}/libs/klibc-${KLIBC_VERSION}/klibc/MCONFIG
- fi
+ sed -e 's@K_CFLAGS =@K_CFLAGS = -fno-stack-protector@' -i ${S}/Makefile
+ sed -e 's@CFLAGS =@CFLAGS = -fno-stack-protector@' -i ${S}/libs/klibc-${KLIBC_VERSION}/klibc/MCONFIG
}
src_compile() {
diff --git a/media-gfx/splashutils/splashutils-1.1.9.6.ebuild b/media-gfx/splashutils/splashutils-1.1.9.6.ebuild
index 1acf540b0bc5..65a5fda7349c 100644
--- a/media-gfx/splashutils/splashutils-1.1.9.6.ebuild
+++ b/media-gfx/splashutils/splashutils-1.1.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.1.9.6.ebuild,v 1.4 2005/05/24 21:23:25 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.1.9.6.ebuild,v 1.5 2005/06/12 13:40:40 spock Exp $
inherit multilib
@@ -49,14 +49,6 @@ pkg_setup() {
ewarn "with 'hardened' GCC flags. As a workaround, the package will be compiled with"
ewarn "-fno-stack-protector. Hardened GCC features will not be used while building"
ewarn "the fbsplash kernel helper."
- else
- if [[ -n "`echo ${GCC_SPECS} | grep hardened`" ]]; then
- ewarn "It appears that you're using a hardened gcc, even though the 'hardened'"
- ewarn "USE flag is not set. This is a common source of compilation problems with"
- ewarn "splashutils. Please use 'gcc-config' to set a non-hardened profile and"
- ewarn "make sure the environment is up-to-date (especially, that the GCC_SPECS"
- ewarn "env. variable is set correctly)."
- fi
fi
}
@@ -115,10 +107,8 @@ src_unpack() {
fi
# This should make splashutils compile on hardened systems.
- if use hardened; then
- sed -e 's@K_CFLAGS =@K_CFLAGS = -fno-stack-protector@' -i ${S}/Makefile
- sed -e 's@CFLAGS =@CFLAGS = -fno-stack-protector@' -i ${S}/libs/klibc-${V_KLIBC}/klibc/MCONFIG
- fi
+ sed -e 's@K_CFLAGS =@K_CFLAGS = -fno-stack-protector@' -i ${S}/Makefile
+ sed -e 's@CFLAGS =@CFLAGS = -fno-stack-protector@' -i ${S}/libs/klibc-${V_KLIBC}/klibc/MCONFIG
mkdir ${S}/kernel