summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-09-12 12:28:27 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-09-12 12:28:27 +0000
commitbad76a1b89523b8e78ebfe014841a45a267744b6 (patch)
tree3d81f1ca20f6f159ad7f72a05a4cd48f1eb4f2a1 /media-gfx/splashutils
parentfix HOMEPAGE (diff)
downloadgentoo-2-bad76a1b89523b8e78ebfe014841a45a267744b6.tar.gz
gentoo-2-bad76a1b89523b8e78ebfe014841a45a267744b6.tar.bz2
gentoo-2-bad76a1b89523b8e78ebfe014841a45a267744b6.zip
Migrate to EAPI 2 so that we can switch from built_with_use to has_version.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'media-gfx/splashutils')
-rw-r--r--media-gfx/splashutils/ChangeLog7
-rw-r--r--media-gfx/splashutils/splashutils-1.5.4.3.ebuild15
2 files changed, 14 insertions, 8 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index 426da0d8e163..1e9b429c1484 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.162 2009/09/12 12:07:21 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.163 2009/09/12 12:28:27 betelgeuse Exp $
+
+ 12 Sep 2009; Petteri Räty <betelgeuse@gentoo.org>
+ splashutils-1.5.4.3.ebuild:
+ Migrate to EAPI 2 so that we can switch from built_with_use to
+ has_version.
12 Sep 2009; Petteri Räty <betelgeuse@gentoo.org>
-splashutils-1.5.4.2.ebuild:
diff --git a/media-gfx/splashutils/splashutils-1.5.4.3.ebuild b/media-gfx/splashutils/splashutils-1.5.4.3.ebuild
index d19702c5d674..748d367805a6 100644
--- a/media-gfx/splashutils/splashutils-1.5.4.3.ebuild
+++ b/media-gfx/splashutils/splashutils-1.5.4.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4.3.ebuild,v 1.14 2009/05/31 14:19:34 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4.3.ebuild,v 1.15 2009/09/12 12:28:27 betelgeuse Exp $
-EAPI="1"
+EAPI="2"
inherit autotools eutils multilib toolchain-funcs
@@ -60,9 +60,7 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A}
-
+src_prepare() {
mv "${WORKDIR}"/{libpng-${V_PNG},jpeg-${V_JPEG},zlib-${V_ZLIB},freetype-${V_FT}} "${S}/libs"
# We need to delete the Makefile and let it be rebuilt when splashutils
# is being configured. Either that, or we end up with a segfaulting kernel
@@ -72,7 +70,8 @@ src_unpack() {
cd "${S}"
ln -sf "${S}/src" "${WORKDIR}/core"
- if ! tc-is-cross-compiler && built_with_use sys-devel/gcc vanilla; then
+ if ! tc-is-cross-compiler && \
+ has_version "sys-devel/gcc:$(gcc-version)[vanilla]" ; then
ewarn "Your GCC was built with the 'vanilla' flag set. If you can't compile"
ewarn "splashutils, you're on your own, as this configuration is not supported."
else
@@ -102,7 +101,7 @@ src_unpack() {
eautoreconf
}
-src_compile() {
+src_configure() {
tc-export CC
cd "${SM}"
emake CC="${CC}" LIB=$(get_libdir) STRIP=true || die "failed to build miscsplashutils"
@@ -120,7 +119,9 @@ src_compile() {
--with-lpng-src=${LPNGSRC} \
--with-zlib-src=${ZLIBSRC} \
--with-essential-libdir=/$(get_libdir) || die "failed to configure splashutils"
+}
+src_compile() {
emake CC="${CC}" STRIP="true" || die "failed to build splashutils"
if has_version ">=sys-apps/baselayout-1.13.99"; then