summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2007-04-06 09:02:01 +0000
committerMichael Januszewski <spock@gentoo.org>2007-04-06 09:02:01 +0000
commitbb47d317fe209e23fe23584554f47ab831064d85 (patch)
tree1d1c10e7b2f4d983c346b2f9d7b24afa2ef6f397 /media-gfx/splashutils
parentx86 stable, bug 173010 (diff)
downloadgentoo-2-bb47d317fe209e23fe23584554f47ab831064d85.tar.gz
gentoo-2-bb47d317fe209e23fe23584554f47ab831064d85.tar.bz2
gentoo-2-bb47d317fe209e23fe23584554f47ab831064d85.zip
Add a patch to remove some debugging messages.
(Portage version: 2.1.2.3)
Diffstat (limited to 'media-gfx/splashutils')
-rw-r--r--media-gfx/splashutils/ChangeLog6
-rw-r--r--media-gfx/splashutils/files/splashutils-1.4-remove-debug-msgs.patch12
-rw-r--r--media-gfx/splashutils/splashutils-1.4.ebuild4
3 files changed, 20 insertions, 2 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index c4b664c266d2..0e8627649955 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.79 2007/04/05 22:14:00 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.80 2007/04/06 09:02:01 spock Exp $
+
+ 06 Apr 2007; Michał Januszewski <spock@gentoo.org>
+ +files/splashutils-1.4-remove-debug-msgs.patch, splashutils-1.4.ebuild:
+ Add a patch to remove some debugging messages.
*splashutils-1.4 (05 Apr 2007)
diff --git a/media-gfx/splashutils/files/splashutils-1.4-remove-debug-msgs.patch b/media-gfx/splashutils/files/splashutils-1.4-remove-debug-msgs.patch
new file mode 100644
index 000000000000..34d2d17f960a
--- /dev/null
+++ b/media-gfx/splashutils/files/splashutils-1.4-remove-debug-msgs.patch
@@ -0,0 +1,12 @@
+diff --git a/core/daemon.c b/core/daemon.c
+index 8519756..2fca8ab 100644
+--- a/core/daemon.c
++++ b/core/daemon.c
+@@ -576,7 +576,6 @@ void obj_update_status(char *svc, enum ESVC state)
+ else
+ ca->flags &= ~F_ANIM_DISPLAY;
+
+- printf("updating anim, have: %d\n", ca->flags);
+ break;
+ }
+ #endif
diff --git a/media-gfx/splashutils/splashutils-1.4.ebuild b/media-gfx/splashutils/splashutils-1.4.ebuild
index d37854343ee3..767a7a14ff1b 100644
--- a/media-gfx/splashutils/splashutils-1.4.ebuild
+++ b/media-gfx/splashutils/splashutils-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.4.ebuild,v 1.1 2007/04/05 22:14:00 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.4.ebuild,v 1.2 2007/04/06 09:02:01 spock Exp $
inherit eutils multilib toolchain-funcs
@@ -67,6 +67,8 @@ src_unpack() {
cd ${S}
ln -sf ${S} ${WORKDIR}/core
+ epatch ${FILESDIR}/splashutils-1.4-remove-debug-msgs.patch
+
# Check whether the kernel tree has been patched with fbsplash.
if [[ ! -e /usr/$(get_libdir)/klibc/include/linux/console_splash.h ]]; then
ewarn "The kernel tree against which dev-libs/klibc was built was not patched"