summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-05-30 02:11:46 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-05-30 02:11:46 +0000
commitc2705989ed2d01a20611b408179aa37410540acd (patch)
treef4ea2d1264e05154ac6322ef8977301325d740ac /media-gfx/springgraph/springgraph-82.ebuild
parentclean up ugly ebuilds (diff)
downloadgentoo-2-c2705989ed2d01a20611b408179aa37410540acd.tar.gz
gentoo-2-c2705989ed2d01a20611b408179aa37410540acd.tar.bz2
gentoo-2-c2705989ed2d01a20611b408179aa37410540acd.zip
version bump, and old ver in stable
Diffstat (limited to 'media-gfx/springgraph/springgraph-82.ebuild')
-rw-r--r--media-gfx/springgraph/springgraph-82.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-gfx/springgraph/springgraph-82.ebuild b/media-gfx/springgraph/springgraph-82.ebuild
new file mode 100644
index 000000000000..fc45d0ac3a5e
--- /dev/null
+++ b/media-gfx/springgraph/springgraph-82.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/springgraph/springgraph-82.ebuild,v 1.1 2004/05/30 02:11:46 robbat2 Exp $
+
+DESCRIPTION="Generate spring graphs from graphviz input files"
+HOMEPAGE="http://www.chaosreigns.com/code/springgraph"
+MY_PV="0.${PV}"
+MY_P="${PN}_${MY_PV}"
+SRC_FILE="${MY_P}.orig.tar.gz"
+SRC_DEBIAN_PATCH="${MY_P}-1.diff.gz"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${SRC_FILE}
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${SRC_DEBIAN_PATCH}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~hppa ~mips ~ppc ~sparc ~ia64 ~amd64"
+IUSE=""
+DEPEND=""
+RDEPEND="dev-perl/GD"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ unpack ${SRC_FILE}
+ epatch ${DISTDIR}/${SRC_DEBIAN_PATCH}
+}
+
+src_compile() {
+ # nothing to do
+ :
+}
+
+src_install() {
+ into /usr
+ dobin ${PN}
+ doman debian/${PN}.1
+}