summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-10-17 22:47:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-10-17 22:47:25 +0000
commit1e154079087736b5ca9a5be95a2f27ab10702576 (patch)
tree8f8d85414541075120faa3d3e2fc655f4bf4e693 /media-gfx/wally
parentQA fixes; unquoted variables (diff)
downloadgentoo-2-1e154079087736b5ca9a5be95a2f27ab10702576.tar.gz
gentoo-2-1e154079087736b5ca9a5be95a2f27ab10702576.tar.bz2
gentoo-2-1e154079087736b5ca9a5be95a2f27ab10702576.zip
Version bump. Remove old patch
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/wally')
-rw-r--r--media-gfx/wally/ChangeLog9
-rw-r--r--media-gfx/wally/files/disable_popup.patch9
-rw-r--r--media-gfx/wally/files/wally-2.2.0-disable-kde4.patch16
-rw-r--r--media-gfx/wally/files/wally-2.2.0-disable_popup.patch11
-rw-r--r--media-gfx/wally/wally-2.2.0.ebuild47
5 files changed, 82 insertions, 10 deletions
diff --git a/media-gfx/wally/ChangeLog b/media-gfx/wally/ChangeLog
index 08521b0931d8..8c0087aaf13e 100644
--- a/media-gfx/wally/ChangeLog
+++ b/media-gfx/wally/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/wally
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/ChangeLog,v 1.17 2009/10/05 15:46:16 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/ChangeLog,v 1.18 2009/10/17 22:47:21 hwoarang Exp $
+
+*wally-2.2.0 (17 Oct 2009)
+
+ 17 Oct 2009; Markos Chandras <hwoarang@gentoo.org> +wally-2.2.0.ebuild,
+ +files/wally-2.2.0-disable-kde4.patch,
+ +files/wally-2.2.0-disable_popup.patch, -files/disable_popup.patch:
+ Version bump. Remove old patch
05 Oct 2009; Theo Chatzimichos <tampakrap@gentoo.org> wally-2.0.3.ebuild:
Use kde4-base eclass in order to have better KDE intergration, also add
diff --git a/media-gfx/wally/files/disable_popup.patch b/media-gfx/wally/files/disable_popup.patch
deleted file mode 100644
index 35b78cd97cfb..000000000000
--- a/media-gfx/wally/files/disable_popup.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-Index: wally-2.0.2/wallyplugin/CMakeLists.txt
-===================================================================
---- wally-2.0.2.orig/wallyplugin/CMakeLists.txt
-+++ wally-2.0.2/wallyplugin/CMakeLists.txt
-@@ -22,4 +22,3 @@ install(TARGETS plasma_wallpaper_wallypl
-
- install(FILES plasma-wallpaper-wallyplugin.desktop DESTINATION ${SERVICES_INSTALL_DIR})
- install(FILES wallyplugin.png DESTINATION ${ICON_INSTALL_DIR}/oxygen/16x16/apps)
--install(CODE "execute_process(COMMAND \"kdialog\" \"--title\" \"WallyPlugin\" \"--msgbox\" \"Please restart Plasma in order to use WallyPlugin\")")
diff --git a/media-gfx/wally/files/wally-2.2.0-disable-kde4.patch b/media-gfx/wally/files/wally-2.2.0-disable-kde4.patch
new file mode 100644
index 000000000000..4639535a98fe
--- /dev/null
+++ b/media-gfx/wally/files/wally-2.2.0-disable-kde4.patch
@@ -0,0 +1,16 @@
+Index: wally-2.2.0/CMakeLists.txt
+===================================================================
+--- wally-2.2.0.orig/CMakeLists.txt
++++ wally-2.2.0/CMakeLists.txt
+@@ -238,11 +238,6 @@ else( APPLE )
+ add_custom_command( TARGET ${PROGNAME} POST_BUILD COMMAND strip ARGS ${WALLY_PATH} WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} )
+ endif( CMAKE_BUILD_TYPE STREQUAL Release )
+
+- find_package( KDE4 )
+- if ( KDE4_FOUND )
+- add_subdirectory( ${CMAKE_SOURCE_DIR}/wallyplugin )
+- endif( KDE4_FOUND )
+-
+ endif( APPLE )
+
+ file( GLOB TS_FILES ${CMAKE_SOURCE_DIR}/res/lang/*.ts )
diff --git a/media-gfx/wally/files/wally-2.2.0-disable_popup.patch b/media-gfx/wally/files/wally-2.2.0-disable_popup.patch
new file mode 100644
index 000000000000..24e91d9b152e
--- /dev/null
+++ b/media-gfx/wally/files/wally-2.2.0-disable_popup.patch
@@ -0,0 +1,11 @@
+Index: wallyplugin/CMakeLists.txt
+===================================================================
+--- wallyplugin.orig/CMakeLists.txt
++++ wallyplugin/CMakeLists.txt
+@@ -26,6 +26,3 @@ install(TARGETS plasma_wallpaper_wallypl
+
+ install(FILES plasma-wallpaper-wallyplugin.desktop DESTINATION ${SERVICES_INSTALL_DIR})
+ install(FILES wallyplugin.png DESTINATION ${ICON_INSTALL_DIR}/oxygen/16x16/apps)
+-
+-install(CODE "execute_process(COMMAND kbuildsycoca4 OUTPUT_QUIET ERROR_QUIET)")
+-install(CODE "execute_process(COMMAND kdialog --title \"WallyPlugin\" --msgbox \"WallyPlugin will be loaded next time KDE is started. Please select it in Appearance Settings.\")")
diff --git a/media-gfx/wally/wally-2.2.0.ebuild b/media-gfx/wally/wally-2.2.0.ebuild
new file mode 100644
index 000000000000..323d5378a450
--- /dev/null
+++ b/media-gfx/wally/wally-2.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/wally-2.2.0.ebuild,v 1.1 2009/10/17 22:47:21 hwoarang Exp $
+
+EAPI="2"
+
+KDE_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="A Qt4 wallpaper changer"
+HOMEPAGE="http://wally.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="media-libs/libexif
+ x11-libs/qt-svg:4
+ kde? ( >=kde-base/kdelibs-4.2.0 )"
+
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-disable_popup.patch"
+ )
+
+src_prepare() {
+ kde4-base_src_prepare
+ ! use kde && epatch "${FILESDIR}/${P}-disable-kde4.patch"
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon "${S}"/res/images/idle.png wally.png
+ make_desktop_entry wally Wally wally "Graphics;Qt"
+}
+
+pkg_postinst() {
+ if use kde;then
+ elog
+ elog "In order to use wallyplugin you need to"
+ elog "restart plasma on your KDE4 enviroment."
+ elog
+ fi
+}