summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2009-10-03 07:46:16 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2009-10-03 07:46:16 +0000
commit062467c62b388ac4e4b46930b781d96c300a3ac0 (patch)
tree1eb3a00b4c8fe79a24c73908bdef9dbf114ce5d3 /media-gfx/xsane
parentVersion bump. (diff)
downloadgentoo-2-062467c62b388ac4e4b46930b781d96c300a3ac0.tar.gz
gentoo-2-062467c62b388ac4e4b46930b781d96c300a3ac0.tar.bz2
gentoo-2-062467c62b388ac4e4b46930b781d96c300a3ac0.zip
Version bump, see bug #287360
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-gfx/xsane')
-rw-r--r--media-gfx/xsane/ChangeLog7
-rw-r--r--media-gfx/xsane/xsane-0.997.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/media-gfx/xsane/ChangeLog b/media-gfx/xsane/ChangeLog
index 8abed41b429d..b35d10cd9c63 100644
--- a/media-gfx/xsane/ChangeLog
+++ b/media-gfx/xsane/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/xsane
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/ChangeLog,v 1.81 2009/10/01 19:39:46 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/ChangeLog,v 1.82 2009/10/03 07:46:16 phosphan Exp $
+
+*xsane-0.997 (03 Oct 2009)
+
+ 03 Oct 2009; Patrick Kursawe <phosphan@gentoo.org> +xsane-0.997.ebuild:
+ Version bump, see bug #287360
01 Oct 2009; Patrick Kursawe <phosphan@gentoo.org> xsane-0.996.ebuild:
Removing duplicate desktop file (bug #286503).
diff --git a/media-gfx/xsane/xsane-0.997.ebuild b/media-gfx/xsane/xsane-0.997.ebuild
new file mode 100644
index 000000000000..77335079954b
--- /dev/null
+++ b/media-gfx/xsane/xsane-0.997.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/xsane-0.997.ebuild,v 1.1 2009/10/03 07:46:16 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="graphical scanning frontend"
+HOMEPAGE="http://www.xsane.org/"
+SRC_URI="http://www.xsane.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls jpeg png tiff gimp lcms"
+
+RDEPEND="media-gfx/sane-backends
+ >=x11-libs/gtk+-2.0
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+ gimp? ( media-gfx/gimp )
+ lcms? ( media-libs/lcms )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ export OLDXSANE
+ if has_version '<=media-gfx/xsane-0.93'; then
+ OLDXSANE="yes"
+ else
+ OLDXSANE="no"
+ fi
+}
+
+src_compile() {
+ local extraCPPflags
+ if use lcms; then
+ extraCPPflags="-I /usr/include/lcms"
+ fi
+ CPPFLAGS="${CPPFLAGS} ${extraCPPflags}" econf --enable-gtk2 \
+ $(use_enable nls) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable tiff) \
+ $(use_enable gimp) \
+ $(use_enable lcms) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc xsane.*
+ # link xsane so it is seen as a plugin in gimp
+ if use gimp; then
+ local plugindir
+ if [ -x /usr/bin/gimptool ]; then
+ plugindir="$(gimptool --gimpplugindir)/plug-ins"
+ elif [ -x /usr/bin/gimptool-2.0 ]; then
+ plugindir="$(gimptool-2.0 --gimpplugindir)/plug-ins"
+ else
+ die "Can't find GIMP plugin directory."
+ fi
+ dodir "${plugindir}"
+ dosym /usr/bin/xsane "${plugindir}"
+ fi
+ newicon src/xsane-48x48.png ${PN}.png
+}
+
+pkg_postinst() {
+ if [ x${OLDXSANE} = 'xyes' ]; then
+ ewarn "If you are upgrading from <=xsane-0.93, please make sure to"
+ ewarn "remove ~/.sane/xsane/xsane.rc _before_ you start xsane for"
+ ewarn "the first time."
+ fi
+}