summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-09-26 21:01:46 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-09-26 21:01:46 +0000
commit37ca4930a92a584bda17536c05393609b4ce7411 (patch)
tree013350e8b38f585c721d87a635b066b347850337 /media-gfx
parentRemove vulnerable versions for security bug #283370 (diff)
downloadgentoo-2-37ca4930a92a584bda17536c05393609b4ce7411.tar.gz
gentoo-2-37ca4930a92a584bda17536c05393609b4ce7411.tar.bz2
gentoo-2-37ca4930a92a584bda17536c05393609b4ce7411.zip
Adding mime package file for .album, bug 181351 . Patch thanks to Peter Fox
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/flphoto/ChangeLog11
-rw-r--r--media-gfx/flphoto/files/album.xml9
-rw-r--r--media-gfx/flphoto/flphoto-1.3.1-r1.ebuild54
3 files changed, 72 insertions, 2 deletions
diff --git a/media-gfx/flphoto/ChangeLog b/media-gfx/flphoto/ChangeLog
index d73451f18d66..570e6e75e433 100644
--- a/media-gfx/flphoto/ChangeLog
+++ b/media-gfx/flphoto/ChangeLog
@@ -1,11 +1,18 @@
# ChangeLog for media-gfx/flphoto
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/ChangeLog,v 1.13 2008/11/23 20:25:34 halcy0n Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/ChangeLog,v 1.14 2009/09/26 21:01:45 vostorga Exp $
26 Jul 2003; Jared Hudson <jhhudso@gentoo.org> : Fixed flphoto so that it only
depends on a specific version of fltk, since the other versions cause
compile errors.
+*flphoto-1.3.1-r1 (26 Sep 2009)
+
+ 26 Sep 2009; Víctor Ostorga <vostorga@gentoo.org>
+ +flphoto-1.3.1-r1.ebuild, +files/album.xml:
+ Adding mime package file for .album, bug 181351 . Patch thanks to Peter
+ Fox
+
23 Nov 2008; Mark Loeser <halcy0n@gentoo.org>
+files/flphoto-1.3.1-glibc28.patch, flphoto-1.2.ebuild,
flphoto-1.3.1.ebuild:
diff --git a/media-gfx/flphoto/files/album.xml b/media-gfx/flphoto/files/album.xml
new file mode 100644
index 000000000000..514932d2d0a7
--- /dev/null
+++ b/media-gfx/flphoto/files/album.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info
+xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="text/x-flphoto">
+ <sub-class-of type="text/plain"/>
+ <comment>flphoto album file</comment>
+ <glob pattern="*.album" />
+ </mime-type>
+</mime-info>
diff --git a/media-gfx/flphoto/flphoto-1.3.1-r1.ebuild b/media-gfx/flphoto/flphoto-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..d8b552c43dbe
--- /dev/null
+++ b/media-gfx/flphoto/flphoto-1.3.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.3.1-r1.ebuild,v 1.1 2009/09/26 21:01:45 vostorga Exp $
+
+EAPI=1
+
+inherit eutils fdo-mime
+
+DESCRIPTION="Basic image management and display program based on the FLTK toolkit"
+HOMEPAGE="http://www.easysw.com/~mike/flphoto/"
+SRC_URI="mirror://sourceforge/fltk/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cups gphoto2"
+
+DEPEND=">=x11-libs/fltk-1.1.4:1.1
+ cups? ( net-print/cups )
+ gphoto2? ( media-gfx/gphoto2 )
+ x11-misc/shared-mime-info
+ dev-libs/openssl
+ media-libs/jpeg
+ media-libs/libpng
+ sys-libs/zlib
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/flphoto-1.3.1-glibc28.patch
+}
+
+src_compile() {
+ econf --with-docdir=/usr/share/doc/${P} || die
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/album.xml
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}