summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2012-08-29 14:54:50 +0000
committerIan Stakenvicius <axs@gentoo.org>2012-08-29 14:54:50 +0000
commit412b1fb087ce38abe313ab14c86f73c486464efe (patch)
treec60da5a2dc6c7b436daa79d019633616647e0a39 /media-gfx
parentRemove old. (diff)
downloadgentoo-2-412b1fb087ce38abe313ab14c86f73c486464efe.tar.gz
gentoo-2-412b1fb087ce38abe313ab14c86f73c486464efe.tar.bz2
gentoo-2-412b1fb087ce38abe313ab14c86f73c486464efe.zip
fixed bad patch in last commit
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/freewrl/ChangeLog6
-rw-r--r--media-gfx/freewrl/files/freewrl-1.22.13-fontconfig-match.patch19
2 files changed, 24 insertions, 1 deletions
diff --git a/media-gfx/freewrl/ChangeLog b/media-gfx/freewrl/ChangeLog
index 45453449db39..1ea4077929ae 100644
--- a/media-gfx/freewrl/ChangeLog
+++ b/media-gfx/freewrl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/freewrl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/ChangeLog,v 1.46 2012/08/29 14:25:19 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/ChangeLog,v 1.47 2012/08/29 14:54:50 axs Exp $
+
+ 29 Aug 2012; Ian Stakenvicius <axs@gentoo.org>
+ files/freewrl-1.22.13-fontconfig-match.patch:
+ fixed bad patch in last commit
29 Aug 2012; Ian Stakenvicius <axs@gentoo.org> freewrl-1.22.13.ebuild,
+files/freewrl-1.22.13-fontconfig-match.patch:
diff --git a/media-gfx/freewrl/files/freewrl-1.22.13-fontconfig-match.patch b/media-gfx/freewrl/files/freewrl-1.22.13-fontconfig-match.patch
index e69de29bb2d1..36b844ea8b62 100644
--- a/media-gfx/freewrl/files/freewrl-1.22.13-fontconfig-match.patch
+++ b/media-gfx/freewrl/files/freewrl-1.22.13-fontconfig-match.patch
@@ -0,0 +1,19 @@
+--- src/lib/scenegraph/Component_Text.c 15 Aug 2012 13:31:45 -0000 1.56
++++ src/lib/scenegraph/Component_Text.c 29 Aug 2012 14:18:43 -0000 1.57
+@@ -370,6 +370,7 @@
+ FcPattern *FW_fp=NULL;
+ FcPattern *FW_fm=NULL;
+ FcChar8 *FW_file=NULL;
++ FcResult fcjunkresult;
+ #else
+
+ if (!p->font_directory) {
+@@ -487,7 +488,7 @@
+ #ifdef HAVE_FONTCONFIG
+ FcConfigSubstitute(0,FW_fp,FcMatchPattern);
+ FcDefaultSubstitute(FW_fp);
+- if (!(FW_fm = FcFontMatch(0,FW_fp,0))) {
++ if (!(FW_fm = FcFontMatch(0,FW_fp,&fcjunkresult))) {
+ /* do whatever is done when no match found */
+ printf ("could not find font for id %x\n",num);
+ } else {