summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-20 10:52:37 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-20 10:52:37 +0000
commit4e720b127f5a64dfd307c8a00742b3aa9961bc79 (patch)
tree1e8e8e6ce4668fd3c3c4aa307369e490632c5c3d /media-gfx
parentWhitespace (diff)
downloadgentoo-2-4e720b127f5a64dfd307c8a00742b3aa9961bc79.tar.gz
gentoo-2-4e720b127f5a64dfd307c8a00742b3aa9961bc79.tar.bz2
gentoo-2-4e720b127f5a64dfd307c8a00742b3aa9961bc79.zip
Remove old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/exiv2/ChangeLog6
-rw-r--r--media-gfx/exiv2/exiv2-0.19.ebuild113
-rw-r--r--media-gfx/exiv2/files/exiv2-0.19-syntax-fix.patch19
-rw-r--r--media-gfx/exiv2/files/exiv2-0.21.1-time-fix.patch62
4 files changed, 5 insertions, 195 deletions
diff --git a/media-gfx/exiv2/ChangeLog b/media-gfx/exiv2/ChangeLog
index a1ddfa24f53b..73aece013d38 100644
--- a/media-gfx/exiv2/ChangeLog
+++ b/media-gfx/exiv2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/exiv2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.116 2013/09/20 14:35:31 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.117 2013/12/20 10:52:37 johu Exp $
+
+ 20 Dec 2013; Johannes Huber <johu@gentoo.org> -exiv2-0.19.ebuild,
+ -files/exiv2-0.19-syntax-fix.patch, -files/exiv2-0.21.1-time-fix.patch:
+ Remove old.
20 Sep 2013; Jeroen Roovers <jer@gentoo.org> exiv2-0.23-r1.ebuild:
Stable for HPPA (bug #481934).
diff --git a/media-gfx/exiv2/exiv2-0.19.ebuild b/media-gfx/exiv2/exiv2-0.19.ebuild
deleted file mode 100644
index 737bbac35419..000000000000
--- a/media-gfx/exiv2/exiv2-0.19.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.19.ebuild,v 1.11 2012/07/02 21:51:47 sbriesen Exp $
-
-EAPI="2"
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="EXIF and IPTC metadata C++ library and command line utility"
-HOMEPAGE="http://www.exiv2.org/"
-SRC_URI="http://www.exiv2.org/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="contrib doc examples nls unicode xmp zlib"
-IUSE_LINGUAS="de es fi fr pl ru sk"
-IUSE="${IUSE} $(printf 'linguas_%s ' ${IUSE_LINGUAS})"
-
-RDEPEND="
- virtual/libiconv
- nls? ( virtual/libintl )
- xmp? ( dev-libs/expat )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}
- contrib? ( >=dev-libs/boost-1.37 )
- doc? (
- dev-lang/python
- app-doc/doxygen
- dev-libs/libxslt
- virtual/pkgconfig
- media-gfx/graphviz
- )
- nls? ( sys-devel/gettext )
-"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-syntax-fix.patch
-
- if use unicode; then
- for i in doc/cmd.txt; do
- echo ">>> Converting "${i}" to UTF-8"
- iconv -f LATIN1 -t UTF-8 "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
- done
- fi
-
- if use doc; then
- echo ">>> Updating doxygen config"
- doxygen 2>&1 >/dev/null -u config/Doxyfile
- fi
-
- if use contrib; then
- # create build environment for contrib
- ln -snf ../../src contrib/organize/exiv2
- sed -i -e 's:/usr/local/include/.*:/usr/include:g' \
- -e 's:/usr/local/lib/lib:-l:g' -e 's:-gcc..-mt-._..\.a::g' \
- contrib/organize/boost.mk
- fi
-}
-
-src_configure() {
- local myconf="$(use_enable nls) $(use_enable xmp)"
- use zlib || myconf="${myconf} --without-zlib" # plain 'use_with' fails
-
- # Bug #78720. amd64/gcc-3.4/-fvisibility* fail.
- if [[ $(gcc-major-version) -lt 4 ]]; then
- use amd64 && myconf="${myconf} --disable-visibility"
- fi
-
- econf ${myconf}
-}
-
-src_compile() {
- emake || die "emake failed"
-
- if use contrib; then
- emake -C contrib/organize \
- LDFLAGS="\$(BOOST_LIBS) -L../../src -lexiv2 ${LDFLAGS}" \
- CPPFLAGS="${CPPFLAGS} -I\$(BOOST_INC_DIR) -I. -DEXV_HAVE_STDINT_H" \
- || die "emake organize failed"
- fi
-
- if use doc; then
- emake doc || die "emake doc failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use contrib; then
- emake DESTDIR="${D}" -C contrib/organize install || die "emake install organize failed"
- fi
-
- dodoc README doc/{ChangeLog,cmd.txt}
- use xmp && dodoc doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt}
- use doc && dohtml -r doc/html/.
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins samples/*.cpp
- fi
-}
-
-pkg_postinst() {
- ewarn
- ewarn "PLEASE PLEASE take note of this:"
- ewarn "Please make *sure* to run revdep-rebuild now"
- ewarn "Certain things on your system may have linked against a"
- ewarn "different version of exiv2 -- those things need to be"
- ewarn "recompiled. Sorry for the inconvenience!"
- ewarn
-}
diff --git a/media-gfx/exiv2/files/exiv2-0.19-syntax-fix.patch b/media-gfx/exiv2/files/exiv2-0.19-syntax-fix.patch
deleted file mode 100644
index 9f217fdae648..000000000000
--- a/media-gfx/exiv2/files/exiv2-0.19-syntax-fix.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-------------------------------------------------------------------------
-r1990 | ahuggel | 2010-01-02 02:15:28 +0100 (Sat, 02 Jan 2010) | 1 line
-
-Minor fix. (Fulvio Senore)
-------------------------------------------------------------------------
-
-Index: exiv2/src/value.cpp
-===================================================================
---- exiv2/src/value.cpp (revision 1989)
-+++ exiv2/src/value.cpp (revision 1990)
-@@ -160,7 +160,7 @@
- DataBuf Value::dataArea() const
- {
- return DataBuf(0, 0);
-- };
-+ }
-
- DataValue::DataValue(TypeId typeId) : Value(typeId)
- {
diff --git a/media-gfx/exiv2/files/exiv2-0.21.1-time-fix.patch b/media-gfx/exiv2/files/exiv2-0.21.1-time-fix.patch
deleted file mode 100644
index f15fe4c318e8..000000000000
--- a/media-gfx/exiv2/files/exiv2-0.21.1-time-fix.patch
+++ /dev/null
@@ -1,62 +0,0 @@
---- exiv2-0.21.1/src/actions.cpp (revision 2474)
-+++ exiv2-0.21.1/src/actions.cpp (revision 2475)
-@@ -104,11 +104,11 @@
- */
- int str2Tm(const std::string& timeStr, struct tm* tm);
-
-- //! Convert a UTC time to a string "YYYY:MM:DD HH:MI:SS", "" on error
-+ //! Convert a localtime to a string "YYYY:MM:DD HH:MI:SS", "" on error
- std::string time2Str(time_t time);
-
- //! Convert a tm structure to a string "YYYY:MM:DD HH:MI:SS", "" on error
-- std::string tm2Str(struct tm* tm);
-+ std::string tm2Str(const struct tm* tm);
-
- /*!
- @brief Copy metadata from source to target according to Params::copyXyz
-@@ -1565,7 +1565,7 @@
- << " " << _("years") << "\n";
- return 1;
- }
-- time_t time = timegm(&tm);
-+ time_t time = mktime(&tm);
- time += adjustment_ + dayAdjustment_ * 86400;
- timeStr = time2Str(time);
- if (Params::instance().verbose_) {
-@@ -1739,7 +1739,7 @@
- int Timestamp::read(struct tm* tm)
- {
- int rc = 1;
-- time_t t = mktime(tm);
-+ time_t t = mktime(tm); // interpret tm according to current timezone settings
- if (t != (time_t)-1) {
- rc = 0;
- actime_ = t;
-@@ -1783,22 +1783,18 @@
- tm->tm_sec = tmp;
-
- // Conversions to set remaining fields of the tm structure
-- time_t time = timegm(tm);
--#ifdef EXV_HAVE_GMTIME_R
-- if (time == (time_t)-1 || gmtime_r(&time, tm) == 0) return 11;
--#else
-- if (time == (time_t)-1 || std::gmtime(&time) == 0) return 11;
--#endif
-+ if (mktime(tm) == (time_t)-1) return 11;
-+
- return 0;
- } // str2Tm
-
- std::string time2Str(time_t time)
- {
-- struct tm* tm = gmtime(&time);
-+ struct tm* tm = localtime(&time);
- return tm2Str(tm);
- } // time2Str
-
-- std::string tm2Str(struct tm* tm)
-+ std::string tm2Str(const struct tm* tm)
- {
- if (0 == tm) return "";
-
-