summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-01 08:00:09 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-01 08:00:09 +0000
commit588acb85dd462a5f348212eca0b305bee29a4476 (patch)
treea73eb56e1cb1a298f71851014083d8de2d7929fb /media-gfx
parentavoid regenerating info pages due to changed version/bugurl fields #464008 (diff)
downloadgentoo-2-588acb85dd462a5f348212eca0b305bee29a4476.tar.gz
gentoo-2-588acb85dd462a5f348212eca0b305bee29a4476.tar.bz2
gentoo-2-588acb85dd462a5f348212eca0b305bee29a4476.zip
Link against libavutil (fixes bug #463826).
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gmic/ChangeLog6
-rw-r--r--media-gfx/gmic/files/gmic-1.5.5.1-makefile.patch118
-rw-r--r--media-gfx/gmic/gmic-1.5.5.1.ebuild4
3 files changed, 125 insertions, 3 deletions
diff --git a/media-gfx/gmic/ChangeLog b/media-gfx/gmic/ChangeLog
index 87964facf438..5cc5ec825b67 100644
--- a/media-gfx/gmic/ChangeLog
+++ b/media-gfx/gmic/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/gmic
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gmic/ChangeLog,v 1.34 2013/03/30 05:46:56 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gmic/ChangeLog,v 1.35 2013/04/01 08:00:08 radhermit Exp $
+
+ 01 Apr 2013; Tim Harder <radhermit@gentoo.org> gmic-1.5.5.1.ebuild,
+ +files/gmic-1.5.5.1-makefile.patch:
+ Link against libavutil (fixes bug #463826).
*gmic-1.5.5.1 (30 Mar 2013)
diff --git a/media-gfx/gmic/files/gmic-1.5.5.1-makefile.patch b/media-gfx/gmic/files/gmic-1.5.5.1-makefile.patch
new file mode 100644
index 000000000000..06570eaac158
--- /dev/null
+++ b/media-gfx/gmic/files/gmic-1.5.5.1-makefile.patch
@@ -0,0 +1,118 @@
+--- gmic-1.5.5.1/src/Makefile
++++ gmic-1.5.5.1/src/Makefile
+@@ -77,7 +77,7 @@
+
+ # Flags that are mandatory to compile 'gmic'.
+ MANDATORY_CFLAGS += -Dgmic_build -I$(USR)/include
+-MANDATORY_LDFLAGS += -L$(USR)/lib
++MANDATORY_LDFLAGS +=
+ ifeq ($(IS_GCC),yes)
+ MANDATORY_CFLAGS += -Wall -W
+ MANDATORY_LDFLAGS += -lm
+@@ -85,28 +85,20 @@
+ MANDATORY_CFLAGS+=$(IS_BETA_CFLAGS)
+
+ # Flags to enable debugging.
+-DEBUG_CFLAGS = -Dcimg_use_vt100 -Dcimg_verbosity=3 -g
+-
+-# Flags to enable optimizations.
+-ifeq ($(IS_GCC),yes)
+-OPT_CFLAGS = -O3 # -fno-tree-pre # -ffast-math
+-endif
+-ifeq ($(CC),icc)
+-OPT_CFLAGS = -O3 -ipo -no-prec-div -override-limits
+-endif
++DEBUG_CFLAGS = -Dcimg_use_vt100 -Dcimg_verbosity=3
+
+ # Flags to enable image display, using X11
+ # (keep /usr/ dirname here since X11 is located in /usr/ on Mac too).
+ # This requires the presence of the X11 include and library files.
+ # (package 'libx11-dev' on Debian).
+-X11_CFLAGS = -Dcimg_display=1 -Dcimg_appname=\\\"gmic\\\" -I/usr/X11R6/include #-Dcimg_use_xrandr
+-X11_LDFLAGS = -L/usr/X11R6/lib -lX11 -lpthread #-lXrandr
++X11_CFLAGS = -Dcimg_display=1 -Dcimg_appname=\\\"gmic\\\" #-Dcimg_use_xrandr
++X11_LDFLAGS = -lX11 -lpthread #-lXrandr
+
+ # Flags to enable fast display, using XShm.
+ # This requires the presence of the X11 extension include and library files.
+ # (package 'libx11-dev' on Debian).
+ XSHM_CFLAGS = -Dcimg_use_xshm
+-XSHM_LDFLAGS = -L$(USR)/X11R6/lib -lXext
++XSHM_LDFLAGS = -lXext
+
+ # Flags to enable image display, using GDI32.
+ # This requires the presence of the GDI32 include and library files.
+@@ -141,7 +133,7 @@
+ # This requires the presence of the FFMPEG include and library files.
+ # (packages 'libavcodec-dev', 'libavutil-dev', 'libavformat-dev' and 'libswscale-dev' on Debian).
+ FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -D__STDC_CONSTANT_MACROS -I$(USR)/include/libavcodec -I$(USR)/include/libavformat -I$(USR)/include/libswscale -I$(USR)/include/ffmpeg
+-FFMPEG_LDFLAGS = -lavcodec -lavformat -lswscale
++FFMPEG_LDFLAGS = -lavcodec -lavformat -lavutil -lswscale
+
+ # Flags to enable native support for compressed .cimgz files, using the Zlib library.
+ # This requires the presence of the Zlib include and library files.
+@@ -152,14 +144,8 @@
+ # Flags to enable native support of webcams, using the OpenCV library.
+ # This requires the presence of the OpenCV include and library files.
+ # (package 'libcv3-2-dev' on Debian).
+-ifeq ($(OS),Darwin)
+ OPENCV_CFLAGS = -Dcimg_use_opencv -I$(USR)/include -I$(USR)/include/opencv
+ OPENCV_LDFLAGS = `pkg-config opencv --libs` #-> Use this for OpenCV 2.2.0 !
+-else
+-OPENCV_CFLAGS = -Dcimg_use_opencv -I$(USR)/include -I$(USR)/include/opencv
+-# OPENCV_LDFLAGS = -lcv -lhighgui
+-OPENCV_LDFLAGS = -lopencv_core -lopencv_highgui #-> Use this for OpenCV >= 2.2.0 !
+-endif
+
+ # Flags to enable native support of most classical image file formats, using the GraphicsMagick++ library.
+ # This requires the presence of the GraphicsMagick++ include and library files.
+@@ -287,10 +273,10 @@
+ endif
+
+ gimp:
+- $(MAKE) "CFLAGS=$(STD_GIMP_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS+=$(STD_GIMP_LDFLAGS) $(OPT_LDFLAGS)" "STRIP_EXE=1" gmic_gimp
++ $(MAKE) "CFLAGS+=$(STD_GIMP_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS+=$(STD_GIMP_LDFLAGS) $(OPT_LDFLAGS)" gmic_gimp
+
+ lib:
+- $(MAKE) "CFLAGS=$(STD_LIB_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS+=$(STD_LIB_LDFLAGS) $(OPT_LDFLAGS)" gmic_lib
++ $(MAKE) "CFLAGS+=$(STD_LIB_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS+=$(STD_LIB_LDFLAGS) $(OPT_LDFLAGS)" gmic_lib
+
+ zart: lib
+ ifneq ($(OS),Darwin)
+@@ -313,10 +299,10 @@
+ $(MAKE) "CFLAGS+=$(DEBUG_UNIX_CFLAGS)" "LDFLAGS+=$(DEBUG_UNIX_LDFLAGS)" gmic_minimal
+
+ linux:
+- $(MAKE) "CFLAGS=$(STD_UNIX_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS=$(STD_UNIX_LDFLAGS)" "STRIP_EXE=1" gmic_gmic
++ $(MAKE) "CFLAGS+=$(STD_UNIX_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS+=$(STD_UNIX_LDFLAGS)" gmic_gmic
+
+ custom:
+- $(MAKE) "CFLAGS=$(CUST_UNIX_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS=$(CUST_UNIX_LDFLAGS)" "STRIP_EXE=1" gmic_gmic
++ $(MAKE) "CFLAGS+=$(CUST_UNIX_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS+=$(CUST_UNIX_LDFLAGS)" gmic_gmic
+
+ solaris:
+ $(MAKE) "CFLAGS=$(STD_UNIX_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS=$(STD_UNIX_LDFLAGS) -R$(USR)/X11R6/lib -lrt -lnsl -lsocket" "STRIP_EXE=1" gmic_gmic
+@@ -337,7 +323,6 @@
+ ar rcs libgmic.a gmic_lib.o
+ ifneq ($(OS),Darwin)
+ $(CC) -shared -Wl,-soname,libgmic.so.1 -o libgmic.so gmic_lib.o $(LDFLAGS)
+- $(CC) -o gmic_use_lib gmic_use_lib.cpp -L. -lgmic $(FFTW_LDFLAGS)
+ else
+ $(CC) -shared -o libgmic.so gmic_lib.o $(LDFLAGS)
+ endif
+@@ -346,7 +331,6 @@
+ $(CC) -o gmic_gimp.o -c gmic.cpp $(CFLAGS) -Dgmic_gimp -Dgmic_float_only
+ gmic_gimp : gmic_gimp.o gmic_gimp.cpp
+ $(CC) -o gmic_gimp gmic_gimp.cpp gmic_gimp.o `gimptool-2.0$(EXE) --cflags` $(CFLAGS) `gimptool-2.0$(EXE) --libs` $(LDFLAGS)
+- strip gmic_gimp$(EXE)
+
+ gmic_minimal: gmic.cpp
+ $(CC) -o gmic gmic.cpp $(CFLAGS) -Dgmic_float_only -Dgmic_main $(LDFLAGS)
+@@ -371,7 +355,6 @@
+ $(CC) -o gmic_double.o -c gmic.cpp $(CFLAGS) -Dgmic_split_compilation -Dgmic_double
+ gmic_gmic: gmic_bool.o gmic_uchar.o gmic_char.o gmic_ushort.o gmic_short.o gmic_uint.o gmic_int.o gmic_float.o gmic_double.o gmic_def.h
+ $(CC) -o gmic gmic_bool.o gmic_uchar.o gmic_char.o gmic_ushort.o gmic_short.o gmic_uint.o gmic_int.o gmic_float.o gmic_double.o $(LDFLAGS)
+- strip gmic$(EXE)
+
+ def:
+ @echo "#ifndef gmic_gimp" > gmic_def.h
diff --git a/media-gfx/gmic/gmic-1.5.5.1.ebuild b/media-gfx/gmic/gmic-1.5.5.1.ebuild
index 64b8bbef3f07..9bd2b838016b 100644
--- a/media-gfx/gmic/gmic-1.5.5.1.ebuild
+++ b/media-gfx/gmic/gmic-1.5.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gmic/gmic-1.5.5.1.ebuild,v 1.1 2013/03/30 05:46:56 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gmic/gmic-1.5.5.1.ebuild,v 1.2 2013/04/01 08:00:08 radhermit Exp $
EAPI=5
@@ -39,7 +39,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}/src
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.5.2.2-makefile.patch
+ epatch "${FILESDIR}"/${P}-makefile.patch
epatch "${FILESDIR}"/${PN}-1.5.2.2-ffmpeg.patch
for i in ffmpeg fftw jpeg opencv png tiff zlib ; do