summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2008-10-25 11:36:56 +0000
committerMarkus Meier <maekke@gentoo.org>2008-10-25 11:36:56 +0000
commit72a80cb905081753ca23ec550d3667340015c49d (patch)
tree8807507c6e739cb311ed77a2e9539da517a0f466 /media-gfx
parentAdd patches by Zhang Le for fixing bug #240024 (fix curses/gpm search, fix am... (diff)
downloadgentoo-2-72a80cb905081753ca23ec550d3667340015c49d.tar.gz
gentoo-2-72a80cb905081753ca23ec550d3667340015c49d.tar.bz2
gentoo-2-72a80cb905081753ca23ec550d3667340015c49d.zip
bump to blender-2.48a (bugfix release); fix files/blender-2.37-dirs.patch reported in bug #242904
(Portage version: 2.2_rc12/cvs/Linux 2.6.27.3 i686)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/blender/ChangeLog11
-rw-r--r--media-gfx/blender/blender-2.48a-r1.ebuild151
-rw-r--r--media-gfx/blender/blender-2.48a.ebuild150
-rw-r--r--media-gfx/blender/files/blender-2.37-dirs.patch2
4 files changed, 312 insertions, 2 deletions
diff --git a/media-gfx/blender/ChangeLog b/media-gfx/blender/ChangeLog
index 097177ff5e44..3120fc7fed41 100644
--- a/media-gfx/blender/ChangeLog
+++ b/media-gfx/blender/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-gfx/blender
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/ChangeLog,v 1.156 2008/10/19 21:32:27 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/ChangeLog,v 1.157 2008/10/25 11:36:56 maekke Exp $
+
+*blender-2.48a-r1 (25 Oct 2008)
+*blender-2.48a (25 Oct 2008)
+
+ 25 Oct 2008; Markus Meier <maekke@gentoo.org>
+ files/blender-2.37-dirs.patch, +blender-2.48a.ebuild,
+ +blender-2.48a-r1.ebuild:
+ bump to blender-2.48a (bugfix release); fix files/blender-2.37-dirs.patch
+ reported in bug #242904
19 Oct 2008; Markus Meier <maekke@gentoo.org> blender-2.48-r1.ebuild:
downgrade EAPI to 0 as this seems to cause troubles to some users (bug
diff --git a/media-gfx/blender/blender-2.48a-r1.ebuild b/media-gfx/blender/blender-2.48a-r1.ebuild
new file mode 100644
index 000000000000..8bad7a45e542
--- /dev/null
+++ b/media-gfx/blender/blender-2.48a-r1.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.48a-r1.ebuild,v 1.1 2008/10/25 11:36:56 maekke Exp $
+
+inherit multilib flag-o-matic eutils python
+
+#IUSE="jpeg mozilla png sdl static truetype"
+IUSE="blender-game ffmpeg jpeg nls openal openexr openmp
+ player png quicktime verse"
+DESCRIPTION="3D Creation/Animation/Publishing System"
+HOMEPAGE="http://www.blender.org/"
+SRC_URI="http://download.blender.org/source/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 BL )"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-libs/openssl-0.9.6
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )
+ jpeg? ( media-libs/jpeg )
+ media-libs/tiff
+ >=dev-lang/python-2.4
+ nls? ( >=media-libs/freetype-2.0
+ virtual/libintl
+ >=media-libs/ftgl-2.1 )
+ openal? ( media-libs/openal
+ media-libs/freealut )
+ openexr? ( media-libs/openexr )
+ png? ( media-libs/libpng )
+ quicktime? ( media-libs/libquicktime )
+ >=media-libs/libsdl-1.2
+ virtual/opengl"
+
+DEPEND=">=dev-util/scons-0.98
+ x11-libs/libXt
+ x11-proto/inputproto
+ ${RDEPEND}"
+
+blend_with() {
+ local UWORD="$2"
+ if [ -z "${UWORD}" ]; then
+ UWORD="$1"
+ fi
+ if useq $1; then
+ echo "WITH_BF_${UWORD}=1" | tr '[:lower:]' '[:upper:]' \
+ >> "${S}"/user-config.py
+ else
+ echo "WITH_BF_${UWORD}=0" | tr '[:lower:]' '[:upper:]' \
+ >> "${S}"/user-config.py
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.37-dirs.patch
+ epatch "${FILESDIR}"/${PN}-2.44-scriptsdir.patch
+ epatch "${FILESDIR}"/${PN}-2.46-ffmpeg.patch
+ epatch "${FILESDIR}"/${PN}-2.46-cve-2008-1103-1.patch
+ epatch "${FILESDIR}"/${PN}-2.48-ffmpeg-20081014.patch
+
+ if use ffmpeg ; then
+# cd "${S}"/extern
+# rm -rf ffmpeg libmp3lame x264
+ cat <<- EOF >> "${S}"/user-config.py
+ BF_FFMPEG="/usr"
+ BF_FFMPEG_LIB="avformat avcodec swscale avutil"
+ EOF
+ fi
+ # pass compiler flags to the scons build system
+ # and set python version to current version in use
+ python_version
+ cat <<- EOF >> "${S}"/user-config.py
+ CFLAGS += '${CFLAGS}'
+ BF_PYTHON_VERSION="${PYVER}"
+ BF_PYTHON_INC="/usr/include/python${PYVER}"
+ BF_PYTHON_BINARY="/usr/bin/python${PYVER}"
+ BF_PYTHON_LIB="python${PYVER}"
+ EOF
+
+ if use openmp && built_with_use --missing false sys-devel/gcc openmp ; then
+ echo "WITH_BF_OPENMP=1" >> "${S}"/user-config.py
+ elog "enabling openmp"
+ else
+ echo "WITH_BF_OPENMP=0" >> "${S}"/user-config.py
+ elog "disabling openmp"
+ fi
+}
+
+src_compile() {
+ for arg in \
+ 'blender-game gameengine' \
+ 'ffmpeg' \
+ 'jpeg' \
+ 'nls international' \
+ 'openal' \
+ 'openexr' \
+ 'player' \
+ 'png' \
+ 'verse' ; do
+ blend_with ${arg}
+ done
+
+ # scons uses -l differently -> remove it
+ scons ${MAKEOPTS/-l[0-9]} || die \
+ "!!! Please add ${S}/scons.config when filing bugs reports to bugs.gentoo.org"
+
+ cd "${WORKDIR}"/install/linux2/plugins
+ chmod 755 bmake
+ emake || die
+}
+
+src_install() {
+ exeinto /usr/bin/
+ doexe "${WORKDIR}"/install/linux2/blender
+ use player && doexe "${WORKDIR}"/install/linux2/blenderplayer
+
+ dodir /usr/share/${PN}
+
+ exeinto /usr/$(get_libdir)/${PN}/textures
+ doexe "${WORKDIR}"/install/linux2/plugins/texture/*.so
+ exeinto /usr/$(get_libdir)/${PN}/sequences
+ doexe "${WORKDIR}"/install/linux2/plugins/sequence/*.so
+ insinto /usr/include/${PN}
+ doins "${WORKDIR}"/install/linux2/plugins/include/*.h
+
+ if use nls ; then
+ mv "${WORKDIR}"/install/linux2/.blender/{.Blanguages,.bfont.ttf} \
+ "${D}"/usr/share/${PN}
+ mv "${WORKDIR}"/install/linux2/.blender/locale \
+ "${D}"/usr/share/locale
+ fi
+
+ mv "${WORKDIR}"/install/linux2/.blender/scripts "${D}"/usr/share/${PN}
+
+ insinto /usr/share/pixmaps
+ doins "${FILESDIR}"/${PN}.png
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/${PN}.desktop
+
+ dodoc INSTALL README
+ dodoc "${WORKDIR}"/install/linux2/BlenderQuickStart.pdf
+}
+
+pkg_preinst(){
+ if [ -h "${ROOT}/usr/$(get_libdir)/blender/plugins/include" ];
+ then
+ rm -f "${ROOT}"/usr/$(get_libdir)/blender/plugins/include
+ fi
+}
diff --git a/media-gfx/blender/blender-2.48a.ebuild b/media-gfx/blender/blender-2.48a.ebuild
new file mode 100644
index 000000000000..72cc95c618ad
--- /dev/null
+++ b/media-gfx/blender/blender-2.48a.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.48a.ebuild,v 1.1 2008/10/25 11:36:56 maekke Exp $
+
+inherit multilib flag-o-matic eutils python
+
+#IUSE="jpeg mozilla png sdl static truetype"
+IUSE="blender-game ffmpeg jpeg nls openal openexr openmp
+ player png quicktime verse"
+DESCRIPTION="3D Creation/Animation/Publishing System"
+HOMEPAGE="http://www.blender.org/"
+SRC_URI="http://download.blender.org/source/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 BL )"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-libs/openssl-0.9.6
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20070616-r1
+ media-libs/x264 )
+ jpeg? ( media-libs/jpeg )
+ media-libs/tiff
+ >=dev-lang/python-2.4
+ nls? ( >=media-libs/freetype-2.0
+ virtual/libintl
+ >=media-libs/ftgl-2.1 )
+ openal? ( media-libs/openal
+ media-libs/freealut )
+ openexr? ( media-libs/openexr )
+ png? ( media-libs/libpng )
+ quicktime? ( media-libs/libquicktime )
+ >=media-libs/libsdl-1.2
+ virtual/opengl"
+
+DEPEND=">=dev-util/scons-0.98
+ x11-libs/libXt
+ x11-proto/inputproto
+ ${RDEPEND}"
+
+blend_with() {
+ local UWORD="$2"
+ if [ -z "${UWORD}" ]; then
+ UWORD="$1"
+ fi
+ if useq $1; then
+ echo "WITH_BF_${UWORD}=1" | tr '[:lower:]' '[:upper:]' \
+ >> "${S}"/user-config.py
+ else
+ echo "WITH_BF_${UWORD}=0" | tr '[:lower:]' '[:upper:]' \
+ >> "${S}"/user-config.py
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.37-dirs.patch
+ epatch "${FILESDIR}"/${PN}-2.44-scriptsdir.patch
+ epatch "${FILESDIR}"/${PN}-2.46-cve-2008-1103-1.patch
+
+ if use ffmpeg ; then
+# cd "${S}"/extern
+# rm -rf ffmpeg libmp3lame x264
+ cat <<- EOF >> "${S}"/user-config.py
+ BF_FFMPEG="/usr"
+ BF_FFMPEG_LIB="avformat avcodec swscale avutil"
+ EOF
+ fi
+ # pass compiler flags to the scons build system
+ # and set python version to current version in use
+ python_version
+ cat <<- EOF >> "${S}"/user-config.py
+ CFLAGS += '${CFLAGS}'
+ BF_PYTHON_VERSION="${PYVER}"
+ BF_PYTHON_INC="/usr/include/python${PYVER}"
+ BF_PYTHON_BINARY="/usr/bin/python${PYVER}"
+ BF_PYTHON_LIB="python${PYVER}"
+ EOF
+
+ if use openmp && built_with_use --missing false sys-devel/gcc openmp ; then
+ echo "WITH_BF_OPENMP=1" >> "${S}"/user-config.py
+ elog "enabling openmp"
+ else
+ echo "WITH_BF_OPENMP=0" >> "${S}"/user-config.py
+ elog "disabling openmp"
+ fi
+}
+
+src_compile() {
+ for arg in \
+ 'blender-game gameengine' \
+ 'ffmpeg' \
+ 'jpeg' \
+ 'nls international' \
+ 'openal' \
+ 'openexr' \
+ 'player' \
+ 'png' \
+ 'verse' ; do
+ blend_with ${arg}
+ done
+
+ # scons uses -l differently -> remove it
+ scons ${MAKEOPTS/-l[0-9]} || die \
+ "!!! Please add ${S}/scons.config when filing bugs reports to bugs.gentoo.org"
+
+ cd "${WORKDIR}"/install/linux2/plugins
+ chmod 755 bmake
+ emake || die
+}
+
+src_install() {
+ exeinto /usr/bin/
+ doexe "${WORKDIR}"/install/linux2/blender
+ use player && doexe "${WORKDIR}"/install/linux2/blenderplayer
+
+ dodir /usr/share/${PN}
+
+ exeinto /usr/$(get_libdir)/${PN}/textures
+ doexe "${WORKDIR}"/install/linux2/plugins/texture/*.so
+ exeinto /usr/$(get_libdir)/${PN}/sequences
+ doexe "${WORKDIR}"/install/linux2/plugins/sequence/*.so
+ insinto /usr/include/${PN}
+ doins "${WORKDIR}"/install/linux2/plugins/include/*.h
+
+ if use nls ; then
+ mv "${WORKDIR}"/install/linux2/.blender/{.Blanguages,.bfont.ttf} \
+ "${D}"/usr/share/${PN}
+ mv "${WORKDIR}"/install/linux2/.blender/locale \
+ "${D}"/usr/share/locale
+ fi
+
+ mv "${WORKDIR}"/install/linux2/.blender/scripts "${D}"/usr/share/${PN}
+
+ insinto /usr/share/pixmaps
+ doins "${FILESDIR}"/${PN}.png
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/${PN}.desktop
+
+ dodoc INSTALL README
+ dodoc "${WORKDIR}"/install/linux2/BlenderQuickStart.pdf
+}
+
+pkg_preinst(){
+ if [ -h "${ROOT}/usr/$(get_libdir)/blender/plugins/include" ];
+ then
+ rm -f "${ROOT}"/usr/$(get_libdir)/blender/plugins/include
+ fi
+}
diff --git a/media-gfx/blender/files/blender-2.37-dirs.patch b/media-gfx/blender/files/blender-2.37-dirs.patch
index 3ac7b9242a7b..1b6837fa70e8 100644
--- a/media-gfx/blender/files/blender-2.37-dirs.patch
+++ b/media-gfx/blender/files/blender-2.37-dirs.patch
@@ -10,7 +10,7 @@ diff -ruN blender.orig/source/blender/src/language.c blender/source/blender/src/
- strcpy(name, ".blender/.Blanguages");
+ /* Check the standar location. Takes care of the case
+ * in which the distribution installs blender */
-+ strcpy(name, "/usr/lib/blender/.Blanguages");
++ strcpy(name, "/usr/share/blender/.Blanguages");
#endif
lines= BLI_read_file_as_lines(name);