summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-02-07 21:36:28 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-02-07 21:36:28 +0000
commit8e29c7fb6961685e8b18a5b6763d02836ca512c6 (patch)
tree1707b4aee06324f6fa88eb5ffcf756052777c18c /media-gfx
parentInherit multilib. (diff)
downloadgentoo-2-8e29c7fb6961685e8b18a5b6763d02836ca512c6.tar.gz
gentoo-2-8e29c7fb6961685e8b18a5b6763d02836ca512c6.tar.bz2
gentoo-2-8e29c7fb6961685e8b18a5b6763d02836ca512c6.zip
New package, bug 58091. Thanks to Konstantin Münning for ebuild and patch.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hp2xx/ChangeLog10
-rw-r--r--media-gfx/hp2xx/files/hp2xx-3.4.4-r1.patch137
-rw-r--r--media-gfx/hp2xx/hp2xx-3.4.4.ebuild45
-rw-r--r--media-gfx/hp2xx/metadata.xml9
4 files changed, 201 insertions, 0 deletions
diff --git a/media-gfx/hp2xx/ChangeLog b/media-gfx/hp2xx/ChangeLog
new file mode 100644
index 000000000000..47c773ef8be5
--- /dev/null
+++ b/media-gfx/hp2xx/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-gfx/hp2xx
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hp2xx/ChangeLog,v 1.1 2012/02/07 21:36:28 dilfridge Exp $
+
+*hp2xx-3.4.4 (07 Feb 2012)
+
+ 07 Feb 2012; Andreas K. Huettel <dilfridge@gentoo.org> +hp2xx-3.4.4.ebuild,
+ +files/hp2xx-3.4.4-r1.patch, +metadata.xml:
+ New package, bug 58091. Thanks to Konstantin Münning for ebuild and patch.
+
diff --git a/media-gfx/hp2xx/files/hp2xx-3.4.4-r1.patch b/media-gfx/hp2xx/files/hp2xx-3.4.4-r1.patch
new file mode 100644
index 000000000000..9bff4f43b922
--- /dev/null
+++ b/media-gfx/hp2xx/files/hp2xx-3.4.4-r1.patch
@@ -0,0 +1,137 @@
+diff -ruN hp2xx-3.4.4.orig/makes/generic.mak hp2xx-3.4.4/makes/generic.mak
+--- hp2xx-3.4.4.orig/makes/generic.mak 2003-06-21 17:16:35.000000000 +0200
++++ hp2xx-3.4.4/makes/generic.mak 2012-02-07 22:30:29.000000000 +0100
+@@ -30,11 +30,11 @@
+ CP = cp
+ MKINFO = makeinfo
+ RMCMD = rm -f
+-STRIP = strip
++STRIP = true
+
+ # Installation sites (GNU conventions):
+ #
+-prefix = /usr/local
++prefix = /usr
+ bindir = $(prefix)/bin
+ includedir = $(prefix)/include
+ mandir = $(prefix)/man
+@@ -44,10 +44,10 @@
+ # CC and CFLAGS set for gcc, but any ANSI-C compiler should work.
+ # For non-gcc compilers, simply set CFLAGS = -O (to start with)
+ #
+-CC = gcc
+-CFLAGS = -O2 -Wall -finline-functions
++#CC = gcc
++#CFLAGS = -O2 -Wall -finline-functions
+
+-LFLAGS = # only sometimes needed; see below for examples
++LFLAGS = $(LDFLAGS) # only sometimes needed; see below for examples
+ CPPFLAGS = -I. # only sometimes needed; see below for examples
+ BINDCMD = # only needed for EMX and DJGPP DOS extenders
+
+@@ -62,7 +62,7 @@
+ #
+ DEFINES = -DUNIX -DHAS_UNIX_X11
+ PREVIEWER = to_x11
+-ALL_LIBS = -lX11 -lm # Maybe -lX instead of -lX11 is needed?
++ALL_LIBS = -L/usr/X11R6/lib/ -lX11 -lm # Maybe -lX instead of -lX11 is needed?
+ #
+ # Generic UNIX, no previewer
+ #
+@@ -195,31 +195,41 @@
+ EX_SRC =
+ EX_OBJ =
+ EX_DEFS =
++EX_LIBS = -lz
+ #
+ # PNG support (requires -lpng and -lz on the ALL_LIBS line)
+-#EX_SRC = png.c to_png.c
+-#EX_OBJ = png.o to_png.o
+-#EX_DEFS= -DPNG
++EX_SRC += png.c to_png.c
++EX_OBJ += png.o to_png.o
++EX_DEFS += -DPNG
++EX_LIBS += -lpng
+ #
+ # TIFF support (requires -ltiff and possibly -lz on the ALL_LIBS line)
+-#EX_SRC = to_tif.c
+-#EX_OBJ = to_tif.o
+-#EX_DEFS = -DTIF
++EX_SRC += to_tif.c
++EX_OBJ += to_tif.o
++EX_DEFS += -DTIF
++EX_LIBS += -ltiff
+ #
+ # JPEG support (requires -ljpeg)
+-#EX_SRC = to_jpg.c
+-#EX_OBJ = to_jpg.o
+-#EX_DEFS = -DJPG
++EX_SRC += to_jpg.c
++EX_OBJ += to_jpg.o
++EX_DEFS += -DJPG
++EX_LIBS += -ljpeg
+ #
+ # PDF support (requires -lpdf)
+-#EX_SRC = to_pdf.c
+-#EX_OBJ = to_pdf.o
+-#EX_DEFS = -DUSEPDF
++#EX_SRC += to_pdf.c
++#EX_OBJ += to_pdf.o
++#EX_DEFS += -DUSEPDF
++#EX_LIBS += -lpdf
+ #
+ # Include extras:
+-# EX_SRC = to_pic.c to_pac.c
+-# EX_OBJ = to_pic.o to_pac.o
+-# EX_DEFS = -DPIC_PAC
++EX_SRC += to_pic.c to_pac.c
++EX_OBJ += to_pic.o to_pac.o
++EX_DEFS += -DPIC_PAC
++#
++# Epson Esc/P2 support
++EX_SRC += to_escp2.c
++EX_OBJ += to_escp2.o
++EX_DEFS += -DEPSON
+ #
+ #############################################################################
+ # No user-serviceable parts below!
+@@ -245,8 +255,8 @@
+ PROGRAM = hp2xx
+
+ default:
+- @echo "This makefile needs manual configuration! Edit it now!
+- @echo "After configuration, you may use the following commands:
++ @echo "This makefile needs manual configuration! Edit it now!"
++ @echo "After configuration, you may use the following commands:"
+ @echo ""
+ @echo "make all Compile everything"
+ @echo "make check Run a color application in preview mode"
+@@ -267,7 +277,7 @@
+ #########################################################################
+
+ all: $(OBJS)
+- $(CC) $(LFLAGS) $(OBJS) $(ALL_LIBS) -o $(PROGRAM)
++ $(CC) $(LFLAGS) $(OBJS) $(ALL_LIBS) $(EX_LIBS) -o $(PROGRAM)
+ $(BINDCMD)
+
+
+diff -ruN hp2xx-3.4.4.orig/sources/png.c hp2xx-3.4.4/sources/png.c
+--- hp2xx-3.4.4.orig/sources/png.c 2003-06-21 17:31:51.000000000 +0200
++++ hp2xx-3.4.4/sources/png.c 2012-02-07 22:26:33.000000000 +0100
+@@ -5,6 +5,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include "to_png.h"
++#include <zlib.h>
+ #include <png.h>
+
+ #define PDNCOL 256
+@@ -36,7 +37,7 @@
+ }
+
+ /* set up error handlimg for libpng */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ return;
+ }
diff --git a/media-gfx/hp2xx/hp2xx-3.4.4.ebuild b/media-gfx/hp2xx/hp2xx-3.4.4.ebuild
new file mode 100644
index 000000000000..237c12841dc9
--- /dev/null
+++ b/media-gfx/hp2xx/hp2xx-3.4.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hp2xx/hp2xx-3.4.4.ebuild,v 1.1 2012/02/07 21:36:28 dilfridge Exp $
+
+EAPI=4
+
+inherit eutils base
+
+DESCRIPTION="Versatile tool to convert Hewlett-Packard's HP-GL plotter language into other graphics formats"
+HOMEPAGE="http://www.gnu.org/software/hp2xx/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="
+ media-libs/libpng
+ media-libs/tiff
+ sys-libs/zlib
+ virtual/jpeg
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-r1.patch" )
+
+src_prepare() {
+ base_src_prepare
+ cp -v makes/generic.mak sources/Makefile || die
+}
+
+src_compile() {
+ cd "${S}/sources" || die
+ emake all
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/info /usr/share/man/man1
+
+ make prefix="${D}/usr" \
+ mandir="${D}/usr/share/man" \
+ infodir="${D}/usr/share/info" \
+ install || die
+}
diff --git a/media-gfx/hp2xx/metadata.xml b/media-gfx/hp2xx/metadata.xml
new file mode 100644
index 000000000000..743e9890266b
--- /dev/null
+++ b/media-gfx/hp2xx/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>konstantin@muenning.com</email>
+ <name>Konstantin Münning</name>
+ </maintainer>
+ <herd>printing</herd>
+</pkgmetadata>