summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-03-29 13:37:31 +0000
committerIan Delaney <idella4@gentoo.org>2015-03-29 13:37:31 +0000
commit993ed912f3ea7354dd128921b9a3dd21afd6cde0 (patch)
tree5c4b0291f576cf8d478880c662e02baf6948d9e9 /media-gfx
parentDisable grass as it will be removed (#514514) (diff)
downloadgentoo-2-993ed912f3ea7354dd128921b9a3dd21afd6cde0.tar.gz
gentoo-2-993ed912f3ea7354dd128921b9a3dd21afd6cde0.tar.bz2
gentoo-2-993ed912f3ea7354dd128921b9a3dd21afd6cde0.zip
revbump; add patch and ebuild prepared by maintainer with assist from package's author, all found in bug #529800, fixes said bug
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hp2xx/ChangeLog11
-rw-r--r--media-gfx/hp2xx/files/hp2xx-3.4.4-docbuild.patch14
-rw-r--r--media-gfx/hp2xx/hp2xx-3.4.4-r1.ebuild70
3 files changed, 93 insertions, 2 deletions
diff --git a/media-gfx/hp2xx/ChangeLog b/media-gfx/hp2xx/ChangeLog
index 846b39b00a60..edb447ac5def 100644
--- a/media-gfx/hp2xx/ChangeLog
+++ b/media-gfx/hp2xx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/hp2xx
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/hp2xx/ChangeLog,v 1.3 2013/03/17 15:51:41 hwoarang Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hp2xx/ChangeLog,v 1.4 2015/03/29 13:37:30 idella4 Exp $
+
+*hp2xx-3.4.4-r1 (29 Mar 2015)
+
+ 29 Mar 2015; Ian Delaney <idella4@gentoo.org>
+ +files/hp2xx-3.4.4-docbuild.patch, +hp2xx-3.4.4-r1.ebuild:
+ revbump; add patch and ebuild prepared by maintainer with assist from
+ package's author, all found in bug #529800, fixes said bug
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/media-gfx/hp2xx/files/hp2xx-3.4.4-docbuild.patch b/media-gfx/hp2xx/files/hp2xx-3.4.4-docbuild.patch
new file mode 100644
index 000000000000..4245eea61254
--- /dev/null
+++ b/media-gfx/hp2xx/files/hp2xx-3.4.4-docbuild.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/attachment.cgi?id=399898
+Only first hunk preserved.
+diff -ruN hp2xx-3.4.4-r0/doc/hp2xxinf.tex hp2xx-3.4.4-r3/doc/hp2xxinf.tex
+--- hp2xx-3.4.4-r0/doc/hp2xxinf.tex 2003-06-21 17:41:16.000000000 +0200
++++ hp2xx-3.4.4-r3/doc/hp2xxinf.tex 2015-03-27 20:36:32.000000000 +0100
+@@ -92,7 +92,7 @@
+ @page
+ @tex
+ {\parskip=0pt
+-\hfill mk\@daveg.com\par
++\hfill mk@@daveg.com\par
+ \hfill {\it Using HP2XX}, \manvers\par
+ \hfill \TeX{}info \texinfoversion\par
+ }
diff --git a/media-gfx/hp2xx/hp2xx-3.4.4-r1.ebuild b/media-gfx/hp2xx/hp2xx-3.4.4-r1.ebuild
new file mode 100644
index 000000000000..be2df68d524f
--- /dev/null
+++ b/media-gfx/hp2xx/hp2xx-3.4.4-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hp2xx/hp2xx-3.4.4-r1.ebuild,v 1.1 2015/03/29 13:37:30 idella4 Exp $
+
+EAPI=4
+
+inherit eutils base
+
+DESCRIPTION="Versatile tool to convert Hewlett-Packard's HP-GL plotter language into other graphics formats"
+HOMEPAGE="http://www.gnu.org/software/hp2xx/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="X jpeg png tiff"
+
+RDEPEND="
+ png? ( media-libs/libpng sys-libs/zlib )
+ tiff? ( media-libs/tiff )
+ jpeg? ( virtual/jpeg )
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo"
+
+PATCHES=( "${FILESDIR}"/${P}-r1.patch
+ "${FILESDIR}"/${P}-docbuild.patch )
+
+src_prepare() {
+ base_src_prepare
+ cp -v makes/generic.mak sources/Makefile || die
+}
+
+src_compile() {
+ cd "${S}/sources" || die
+ export PREVIEWER="no_prev"
+ export EX_SRC=
+ export EX_OBJ=
+ export EX_DEFS=-DUNIX
+ export ALL_LIBS=-lm
+ use X && \
+ PREVIEWER="to_x11" \
+ EX_DEFS="-DHAS_UNIX_X11" \
+ ALL_LIBS="${ALL_LIBS} -lX11"
+ use jpeg && \
+ EX_SRC="${EX_SRC} to_jpg.c" \
+ EX_OBJ="${EX_OBJ} to_jpg.o" \
+ EX_DEFS="${EX_DEFS} -DJPG" \
+ ALL_LIBS="${ALL_LIBS} -ljpeg"
+ use png && \
+ EX_SRC="${EX_SRC} png.c to_png.c" \
+ EX_OBJ="${EX_OBJ} png.o to_png.o" \
+ EX_DEFS="${EX_DEFS} -DPNG" \
+ ALL_LIBS="${ALL_LIBS} -lpng"
+ use tiff && \
+ EX_SRC="${EX_SRC} to_tif.c" \
+ EX_OBJ="${EX_OBJ} to_tif.o" \
+ EX_DEFS="${EX_DEFS} -DTIF" \
+ ALL_LIBS="${ALL_LIBS} -ltiff"
+ emake all
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/info /usr/share/man/man1
+
+ make prefix="${D}/usr" \
+ mandir="${D}/usr/share/man" \
+ infodir="${D}/usr/share/info" \
+ install || die
+}