summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-16 13:46:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-07-16 13:46:25 +0000
commita16e6e8e9f167e7bb282a07b994aac5eeb6b2483 (patch)
tree80d378c4179047f58ab90cdd7259cd7893a837e9 /media-gfx
parentStable on alpha, bug 550348 (diff)
downloadgentoo-2-a16e6e8e9f167e7bb282a07b994aac5eeb6b2483.tar.gz
gentoo-2-a16e6e8e9f167e7bb282a07b994aac5eeb6b2483.tar.bz2
gentoo-2-a16e6e8e9f167e7bb282a07b994aac5eeb6b2483.zip
drop libpng libs from .pc file since it does not use libpng and never substitutes it, bug #551208
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/pstoedit/ChangeLog9
-rw-r--r--media-gfx/pstoedit/files/pstoedit-3.70-pkgconfig.patch14
-rw-r--r--media-gfx/pstoedit/pstoedit-3.70-r1.ebuild60
3 files changed, 82 insertions, 1 deletions
diff --git a/media-gfx/pstoedit/ChangeLog b/media-gfx/pstoedit/ChangeLog
index 47db8d014ed4..5319d4cc9b35 100644
--- a/media-gfx/pstoedit/ChangeLog
+++ b/media-gfx/pstoedit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/pstoedit
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/ChangeLog,v 1.93 2015/04/29 15:22:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/ChangeLog,v 1.94 2015/07/16 13:46:25 aballier Exp $
+
+*pstoedit-3.70-r1 (16 Jul 2015)
+
+ 16 Jul 2015; Alexis Ballier <aballier@gentoo.org> +pstoedit-3.70-r1.ebuild,
+ +files/pstoedit-3.70-pkgconfig.patch:
+ drop libpng libs from .pc file since it does not use libpng and never
+ substitutes it, bug #551208
*pstoedit-3.70 (29 Apr 2015)
diff --git a/media-gfx/pstoedit/files/pstoedit-3.70-pkgconfig.patch b/media-gfx/pstoedit/files/pstoedit-3.70-pkgconfig.patch
new file mode 100644
index 000000000000..c101077431e5
--- /dev/null
+++ b/media-gfx/pstoedit/files/pstoedit-3.70-pkgconfig.patch
@@ -0,0 +1,14 @@
+LIBPNG_LDFLAGS is never substituted...
+https://bugs.gentoo.org/show_bug.cgi?id=551208
+
+Index: pstoedit-3.70/config/pstoedit.pc.in
+===================================================================
+--- pstoedit-3.70.orig/config/pstoedit.pc.in
++++ pstoedit-3.70/config/pstoedit.pc.in
+@@ -7,5 +7,5 @@ Name: pstoedit
+ Description: converts PostScript(TM) and PDF files to other vector graphic formats
+ Version: @VERSION@.0
+ Requires:
+-Libs: -L@libdir@ -lpstoedit @LIBPNG_LDFLAGS@ @CXX_STD_LIB@ @CXX_RUNTIME_LIB@ @LIBLD_LDFLAGS@
++Libs: -L@libdir@ -lpstoedit @CXX_STD_LIB@ @CXX_RUNTIME_LIB@ @LIBLD_LDFLAGS@
+ Cflags: -I@includedir@
diff --git a/media-gfx/pstoedit/pstoedit-3.70-r1.ebuild b/media-gfx/pstoedit/pstoedit-3.70-r1.ebuild
new file mode 100644
index 000000000000..25485bbbcb6d
--- /dev/null
+++ b/media-gfx/pstoedit/pstoedit-3.70-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.70-r1.ebuild,v 1.1 2015/07/16 13:46:25 aballier Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Translate PostScript and PDF graphics into other vector formats"
+HOMEPAGE="http://sourceforge.net/projects/pstoedit/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="emf flash imagemagick plotutils pptx static-libs"
+
+RDEPEND="
+ >=media-libs/gd-2.0.35-r1
+ >=app-text/ghostscript-gpl-8.71-r1
+ emf? ( >=media-libs/libemf-1.0.3 )
+ flash? ( >=media-libs/ming-0.4.3 )
+ imagemagick? ( >=media-gfx/imagemagick-6.6.1.2[cxx] )
+ plotutils? ( media-libs/plotutils )
+ pptx? ( dev-libs/libzip )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i \
+ -e '/CXXFLAGS="-g"/d' \
+ -e 's:-pedantic::' \
+ configure.ac || die
+
+ epatch "${FILESDIR}"/${PN}-3.60-libdl.patch
+ epatch "${FILESDIR}"/${PN}-3.70-pkgconfig.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with emf) \
+ $(use_with imagemagick magick) \
+ $(use_with plotutils libplot) \
+ $(use_with flash swf) \
+ $(use_with pptx)
+}
+
+src_install() {
+ default
+ doman doc/pstoedit.1
+ dodoc doc/*.txt
+ dohtml doc/*.htm
+
+ find "${ED}" -name '*.la' -delete
+}