summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Walls <malverian@gentoo.org>2003-03-16 22:09:16 +0000
committerPhilip Walls <malverian@gentoo.org>2003-03-16 22:09:16 +0000
commitb76bc9045b886527c7944a39406d49916e51790d (patch)
treeb745af8bad23f34d5f631637f4ae123c3395d0e1 /media-gfx
parentadded reoback to portage (diff)
downloadgentoo-2-b76bc9045b886527c7944a39406d49916e51790d.tar.gz
gentoo-2-b76bc9045b886527c7944a39406d49916e51790d.tar.bz2
gentoo-2-b76bc9045b886527c7944a39406d49916e51790d.zip
Initial import
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/truevision/ChangeLog8
-rw-r--r--media-gfx/truevision/files/digest-truevision-0.3.102
-rw-r--r--media-gfx/truevision/files/truevision-0.3.10-gentoo1.patch203
-rw-r--r--media-gfx/truevision/truevision-0.3.10.ebuild32
4 files changed, 245 insertions, 0 deletions
diff --git a/media-gfx/truevision/ChangeLog b/media-gfx/truevision/ChangeLog
new file mode 100644
index 000000000000..734579a54fc0
--- /dev/null
+++ b/media-gfx/truevision/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for media-gfx/truevision
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/truevision/ChangeLog,v 1.1 2003/03/16 22:09:16 malverian Exp $
+
+*truevision-0.4.10 (16 Mar 2003)
+
+ 16 Mar 2003; Philip Walls <malverian@gentoo.org
+ Initial import.
diff --git a/media-gfx/truevision/files/digest-truevision-0.3.10 b/media-gfx/truevision/files/digest-truevision-0.3.10
new file mode 100644
index 000000000000..a5a0906b3d06
--- /dev/null
+++ b/media-gfx/truevision/files/digest-truevision-0.3.10
@@ -0,0 +1,2 @@
+MD5 260acc07ffb0943554816eb47d4be88b truevision-0.3.10.tar.gz 1088249
+MD5 658bf82b0000435b04737de181e534e5 truevision-extramat-0.3.10.tar.gz 1738369
diff --git a/media-gfx/truevision/files/truevision-0.3.10-gentoo1.patch b/media-gfx/truevision/files/truevision-0.3.10-gentoo1.patch
new file mode 100644
index 000000000000..9d8954673066
--- /dev/null
+++ b/media-gfx/truevision/files/truevision-0.3.10-gentoo1.patch
@@ -0,0 +1,203 @@
+diff -U3 -r truevision-0.3.10/configure truevision-0.3.10-patched/configure
+--- truevision-0.3.10/configure 2002-01-01 06:43:00.000000000 -0500
++++ truevision-0.3.10-patched/configure 2003-03-15 18:38:04.000000000 -0500
+@@ -4629,11 +4629,11 @@
+
+
+
+-PACKAGE_PIXMAPS_DIR="`gnome-config --datadir`/pixmaps/${PACKAGE}"
++PACKAGE_PIXMAPS_DIR="${datadir}/pixmaps/${PACKAGE}"
+
+
+
+-PACKAGE_MATERIALS_DIR="`gnome-config --datadir`/${PACKAGE}/materials"
++PACKAGE_MATERIALS_DIR="${datadir}/${PACKAGE}/materials"
+
+
+
+diff -U3 -r truevision-0.3.10/src/density.cc truevision-0.3.10-patched/src/density.cc
+--- truevision-0.3.10/src/density.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/density.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -49,7 +49,7 @@
+ //**************************************
+ // Constructeur
+ //**************************************
+-PovTexDensity::PovTexDensity( app_objs *appref, void (*asuicidal_func)(gpointer, gpointer), gpointer amother, bool is_top=true ) : MaterialItem( app_ref )
++PovTexDensity::PovTexDensity( app_objs *appref, void (*asuicidal_func)(gpointer, gpointer), gpointer amother, bool is_top ) : MaterialItem( app_ref )
+ {
+ num = ++count;
+ char text[25];
+@@ -74,7 +74,7 @@
+ warp = new TvWidget_warp_rb( N_("Warp"), "WARP", NULL, app_ref );
+ }
+
+-void PovTexDensity::set_params( void (*asuicidal_func)(gpointer, gpointer), gpointer amother, bool is_top=true )
++void PovTexDensity::set_params( void (*asuicidal_func)(gpointer, gpointer), gpointer amother, bool is_top )
+ {
+ suicidal_func = asuicidal_func;
+ mother = amother;
+@@ -337,7 +337,7 @@
+ if ( map_editor != NULL ) map_editor->flush();
+ }
+
+-void PovTexDensity::output_to_povray( ofstream & file, bool inmap = false )
++void PovTexDensity::output_to_povray( ofstream & file, bool inmap )
+ {
+ if ( !inmap ) file << "\n\t\t\tdensity {\n\t\t\t\t";
+
+diff -U3 -r truevision-0.3.10/src/dlgutils.cc truevision-0.3.10-patched/src/dlgutils.cc
+--- truevision-0.3.10/src/dlgutils.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/dlgutils.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -41,7 +41,7 @@
+ }
+
+ // Double box
+-GtkWidget *dlg_double_box( GtkWidget *parent, GtkWidget* &vbox1, GtkWidget* &vbox2, bool packed = false )
++GtkWidget *dlg_double_box( GtkWidget *parent, GtkWidget* &vbox1, GtkWidget* &vbox2, bool packed )
+ {
+ GtkWidget *hbox = gtk_hbox_new( TRUE, 5 );
+ if ( packed ) gtk_box_pack_start( GTK_BOX(parent), hbox, TRUE, TRUE, 1 );
+diff -U3 -r truevision-0.3.10/src/mapedit.cc truevision-0.3.10-patched/src/mapedit.cc
+--- truevision-0.3.10/src/mapedit.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/mapedit.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -28,7 +28,7 @@
+ //********************************************
+ // MAP ITEM
+ //********************************************
+-MapItem::MapItem( char *nom, float val = -1 )
++MapItem::MapItem( char *nom, float val)
+ {
+ name = nom;
+ value = val;
+diff -U3 -r truevision-0.3.10/src/material.cc truevision-0.3.10-patched/src/material.cc
+--- truevision-0.3.10/src/material.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/material.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -66,7 +66,7 @@
+ //**************************************
+ // Add to list
+ //**************************************
+-void Material::add_to_list( GtkWidget *list, int position = -1 )
++void Material::add_to_list( GtkWidget *list, int position)
+ {
+ clist = GTK_CLIST( list );
+ gchar *titre[] = { name->value() };
+@@ -182,7 +182,7 @@
+ item_type = ref.item_type;
+ }
+
+-void MaterialItem::add_to_tree( GtkCTree *tree, GtkCTreeNode *node , GtkCTreeNode *sibling = NULL )
++void MaterialItem::add_to_tree( GtkCTree *tree, GtkCTreeNode *node , GtkCTreeNode *sibling)
+ {
+ ctree = tree;
+ parent_node = node;
+diff -U3 -r truevision-0.3.10/src/matpov.cc truevision-0.3.10-patched/src/matpov.cc
+--- truevision-0.3.10/src/matpov.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/matpov.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -600,7 +600,7 @@
+ }
+
+
+-void PovTexture::output_to_povray( ofstream & file, bool inmap = false )
++void PovTexture::output_to_povray( ofstream & file, bool inmap )
+ {
+ //if ( !is_used() ) return;
+
+diff -U3 -r truevision-0.3.10/src/texnormal.cc truevision-0.3.10-patched/src/texnormal.cc
+--- truevision-0.3.10/src/texnormal.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/texnormal.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -44,7 +44,7 @@
+ //**************************************
+ // Constructeurs & Destructeurs
+ //**************************************
+-PovTexNormal::PovTexNormal( app_objs *appref, bool mother = true ) : MaterialItem( app_ref )
++PovTexNormal::PovTexNormal( app_objs *appref, bool mother ) : MaterialItem( app_ref )
+ {
+ set_name( _("Normal") );
+ item_type = TV_MITEM_NORMAL;
+diff -U3 -r truevision-0.3.10/src/texpigment.cc truevision-0.3.10-patched/src/texpigment.cc
+--- truevision-0.3.10/src/texpigment.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/texpigment.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -48,7 +48,7 @@
+ //**************************************
+ // Constructeur
+ //**************************************
+-PovTexPigment::PovTexPigment( app_objs *appref, bool mother = true ) : MaterialItem( appref )
++PovTexPigment::PovTexPigment( app_objs *appref, bool mother ) : MaterialItem( appref )
+ {
+ set_name( _("Pigment") );
+ item_type = TV_MITEM_PIGMENT;
+@@ -373,7 +373,7 @@
+ }
+
+
+-void PovTexPigment::output_to_povray( ofstream & file, bool in_map=false )
++void PovTexPigment::output_to_povray( ofstream & file, bool in_map )
+ {
+ if ( !used->value() ) return;
+ if ( !in_map ) file << "\n\t\tpigment {\n\t\t\t";
+diff -U3 -r truevision-0.3.10/src/tvwidgets.cc truevision-0.3.10-patched/src/tvwidgets.cc
+--- truevision-0.3.10/src/tvwidgets.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/tvwidgets.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -56,7 +56,7 @@
+ in_update = false;
+ }
+
+-void TvWidget::pack_widget( GtkWidget *box, bool tt, GtkWidget *target=NULL )
++void TvWidget::pack_widget( GtkWidget *box, bool tt, GtkWidget *target )
+ {
+ if ( tt && tooltip != NULL )
+ {
+diff -U3 -r truevision-0.3.10/src/tvwidgets2.cc truevision-0.3.10-patched/src/tvwidgets2.cc
+--- truevision-0.3.10/src/tvwidgets2.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/tvwidgets2.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -887,7 +887,7 @@
+ const char *bfiletype_ext[bfiletype_num] = { "df3" };
+ const char *bfiletype_def[bfiletype_num] = { " df3 " };
+
+-TvWidget_blendmap::TvWidget_blendmap( const char *name, const char *sname, const char *tooltip, app_objs *appref, bool is_colmap = false )
++TvWidget_blendmap::TvWidget_blendmap( const char *name, const char *sname, const char *tooltip, app_objs *appref, bool is_colmap )
+ : TvWidget( name, sname, tooltip, appref )
+ {
+ option_box = NULL;
+diff -U3 -r truevision-0.3.10/src/undo.cc truevision-0.3.10-patched/src/undo.cc
+--- truevision-0.3.10/src/undo.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/undo.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -181,7 +181,7 @@
+ }
+
+ // Undo layers creation / deletion / move
+-void UndoRedoManager::push( UndoAction act, ObjectLayer *lay, int sens = -1 )
++void UndoRedoManager::push( UndoAction act, ObjectLayer *lay, int sens )
+ {
+ UndoItem *item = new UndoItem( act, lay, sens );
+ UndoList.push_back( item );
+@@ -191,7 +191,7 @@
+ }
+
+ // Undo materials creation / deletion / move
+-void UndoRedoManager::push( UndoAction act, Material *mat, int position = -1 )
++void UndoRedoManager::push( UndoAction act, Material *mat, int position )
+ {
+ UndoItem *item = new UndoItem( act, mat, position );
+ UndoList.push_back( item );
+@@ -231,7 +231,7 @@
+ // The main function used
+ // in fact it is also used for redo ;-)
+ //***************************************************
+-void UndoRedoManager::undo( bool doredo = false )
++void UndoRedoManager::undo( bool doredo )
+ {
+ // Define source & destination lists
+ // The determine if we act as undo or redo...
+diff -U3 -r truevision-0.3.10/src/undo.h truevision-0.3.10-patched/src/undo.h
+--- truevision-0.3.10/src/undo.h 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/undo.h 2003-03-15 18:38:29.000000000 -0500
+@@ -65,7 +65,7 @@
+ // one for undo and the other for redo
+ //**********************************************************
+ class UndoItem {
+- friend UndoRedoManager;
++ friend struct UndoRedoManager;
+
+ private:
+ UndoAction action;
diff --git a/media-gfx/truevision/truevision-0.3.10.ebuild b/media-gfx/truevision/truevision-0.3.10.ebuild
new file mode 100644
index 000000000000..55a1c79faada
--- /dev/null
+++ b/media-gfx/truevision/truevision-0.3.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/truevision/truevision-0.3.10.ebuild,v 1.1 2003/03/16 22:09:16 malverian Exp $
+
+DESCRIPTION="Gnome frontend to Povray"
+HOMEPAGE="http://truevision.sourceforge.net"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/truevision/${P}.tar.gz http://unc.dl.sourceforge.net/sourceforge/truevision/${PN}-extramat-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="=x11-libs/gtk+-1.2*
+ media-gfx/povray"
+
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ epatch ${FILESDIR}/truevision-0.3.10-gentoo1.patch || die
+ econf --prefix=${D}/usr --datadir=${D}/usr/share || die
+ emake || die
+}
+
+src_install() {
+ emake PREFIX=${D}/usr DATADIR=${D}/usr/share PACKAGE_MATERIALS_DIR=${D}/usr/share/truevision/materials PACKAGE_PIXMAPS_DIR=${D}/usr/share/pixmaps/truevision install || die
+
+ cd ${WORKDIR}/${PN}-extramat-${PV} || die
+ cp -R materials ${D}/usr/share/truevision/materials/ || die
+}