summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-08-24 06:53:50 +0000
committerAlex Alexander <wired@gentoo.org>2010-08-24 06:53:50 +0000
commitb79a200b3482293d4682ccf75127d14754863c2a (patch)
tree27a93512df33fb96337c723a56e9f6461bc3094d /media-gfx
parentrespect LDFLAGS (bug #332473) (diff)
downloadgentoo-2-b79a200b3482293d4682ccf75127d14754863c2a.tar.gz
gentoo-2-b79a200b3482293d4682ccf75127d14754863c2a.tar.bz2
gentoo-2-b79a200b3482293d4682ccf75127d14754863c2a.zip
version bump, bug #334159
(Portage version: 2.2_rc67_p716/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/wally/ChangeLog7
-rw-r--r--media-gfx/wally/wally-2.4.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/media-gfx/wally/ChangeLog b/media-gfx/wally/ChangeLog
index 6119964c4cba..601cffe9d4b8 100644
--- a/media-gfx/wally/ChangeLog
+++ b/media-gfx/wally/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/wally
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/ChangeLog,v 1.28 2010/07/14 13:39:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/ChangeLog,v 1.29 2010/08/24 06:53:50 wired Exp $
+
+*wally-2.4 (24 Aug 2010)
+
+ 24 Aug 2010; Alex Alexander <wired@gentoo.org> +wally-2.4.ebuild:
+ version bump, bug #334159
14 Jul 2010; Markos Chandras <hwoarang@gentoo.org> -wally-2.3.0.ebuild,
-wally-2.3.1.ebuild:
diff --git a/media-gfx/wally/wally-2.4.ebuild b/media-gfx/wally/wally-2.4.ebuild
new file mode 100644
index 000000000000..5e9e25a68fce
--- /dev/null
+++ b/media-gfx/wally/wally-2.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/wally-2.4.ebuild,v 1.1 2010/08/24 06:53:49 wired Exp $
+
+EAPI="2"
+KDE_REQUIRED="optional"
+inherit cmake-utils kde4-base
+
+DESCRIPTION="A Qt4 wallpaper changer"
+HOMEPAGE="http://www.becrux.com/index.php?page=projects&name=wally"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="media-libs/libexif
+ x11-libs/qt-svg:4
+ kde? ( >=kde-base/kdelibs-4.2.0 )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.2.0-disable_popup.patch"
+)
+
+src_prepare() {
+ # fix path or compile fails
+ sed "s:../build/:../../${P}_build/:g" -i res/wally.qrc || die "sed failed"
+
+ kde4-base_src_prepare
+ use kde || epatch "${FILESDIR}/${PN}-2.2.0-disable-kde4.patch"
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs} -DSTATIC=FALSE"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon "${S}"/res/images/idle.png wally.png || die
+ make_desktop_entry wally Wally wally "Graphics;Qt"
+}
+
+pkg_postinst() {
+ if use kde; then
+ elog
+ elog "In order to use wallyplugin you need to"
+ elog "restart plasma in your KDE4 enviroment."
+ elog
+ fi
+}