summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-02-28 11:02:42 +0000
committerMichael Weber <xmw@gentoo.org>2013-02-28 11:02:42 +0000
commitc5ec6142970b02b779a7e56b06fd243e112a37dd (patch)
tree165407e226361978b09c974c46affe65618af69b /media-gfx
parentKill libutp from tree wrt http://github.com/bittorrent/libutp/issues/44 witho... (diff)
downloadgentoo-2-c5ec6142970b02b779a7e56b06fd243e112a37dd.tar.gz
gentoo-2-c5ec6142970b02b779a7e56b06fd243e112a37dd.tar.bz2
gentoo-2-c5ec6142970b02b779a7e56b06fd243e112a37dd.zip
Fix compilation (bug 455076, reported by renesanso)
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/zbar/ChangeLog10
-rw-r--r--media-gfx/zbar/files/zbar-0.10-errors.patch10
-rw-r--r--media-gfx/zbar/zbar-0.10-r2.ebuild64
3 files changed, 82 insertions, 2 deletions
diff --git a/media-gfx/zbar/ChangeLog b/media-gfx/zbar/ChangeLog
index cf329b4fc584..df0085264b09 100644
--- a/media-gfx/zbar/ChangeLog
+++ b/media-gfx/zbar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/zbar
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/zbar/ChangeLog,v 1.6 2012/07/28 23:07:30 xmw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/zbar/ChangeLog,v 1.7 2013/02/28 11:02:42 xmw Exp $
+
+*zbar-0.10-r2 (28 Feb 2013)
+
+ 28 Feb 2013; Michael Weber <xmw@gentoo.org> +zbar-0.10-r2.ebuild,
+ +files/zbar-0.10-errors.patch:
+ Fix compilation (bug 455076, reported by renesanso)
28 Jul 2012; Michael Weber <xmw@gentoo.org> -zbar-0.10.ebuild:
Drop old
diff --git a/media-gfx/zbar/files/zbar-0.10-errors.patch b/media-gfx/zbar/files/zbar-0.10-errors.patch
new file mode 100644
index 000000000000..63328ce664bb
--- /dev/null
+++ b/media-gfx/zbar/files/zbar-0.10-errors.patch
@@ -0,0 +1,10 @@
+--- zbar-0.10/include/zbar/Exception.h
++++ zbar-0.10/include/zbar/Exception.h
+@@ -32,6 +32,7 @@
+
+ #include <exception>
+ #include <new>
++#include <cstddef>
+
+ namespace zbar {
+
diff --git a/media-gfx/zbar/zbar-0.10-r2.ebuild b/media-gfx/zbar/zbar-0.10-r2.ebuild
new file mode 100644
index 000000000000..d6fdafb2120f
--- /dev/null
+++ b/media-gfx/zbar/zbar-0.10-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/zbar/zbar-0.10-r2.ebuild,v 1.1 2013/02/28 11:02:42 xmw Exp $
+
+EAPI=5
+PYTHON_DEPEND="2:2.6"
+
+inherit autotools eutils flag-o-matic python
+
+DESCRIPTION="Library and tools for reading barcodes from images or video"
+HOMEPAGE="http://zbar.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zbar/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk imagemagick jpeg python qt4 static-libs +threads v4l X xv"
+
+RDEPEND="gtk? ( =dev-libs/glib-2* x11-libs/gtk+:2 )
+ imagemagick? ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ jpeg? ( virtual/jpeg )
+ python? ( gtk? ( >=dev-python/pygtk-2 ) )
+ qt4? ( x11-libs/qt-core:4 x11-libs/qt-gui:4 )
+ X? ( x11-libs/libXext
+ xv? ( x11-libs/libXv ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-v4l1-check.patch
+ epatch "${FILESDIR}"/${P}-errors.patch
+
+ python_convert_shebangs 2 examples/upcrpc.py test/{barcodetest,test_pygtk}.py
+
+ sed -i -e '/AM_INIT_AUTOMAKE/s:-Werror ::' configure.ac || die #423581
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -DNDEBUG
+ econf \
+ $(use_with jpeg) \
+ $(use_with gtk) \
+ $(use_with imagemagick) \
+ $(use_with python) \
+ $(use_with qt4 qt) \
+ $(use_enable static-libs static) \
+ $(use_enable threads pthread) \
+ $(use_with X x) \
+ $(use_with xv xv) \
+ $(use_enable v4l video)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc HACKING NEWS README TODO
+ rm -r "${ED}"/usr/share/doc/${PN}
+ prune_libtool_files --all
+}