summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-10-28 19:30:02 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-10-28 19:30:02 +0000
commitd747a1470383acd44535921e03e00d2b0e8a58cc (patch)
tree98cad15b54e61e455141ec33567a42e3de5ca7bd /media-gfx
parentAdd ~alpha (diff)
downloadgentoo-2-d747a1470383acd44535921e03e00d2b0e8a58cc.tar.gz
gentoo-2-d747a1470383acd44535921e03e00d2b0e8a58cc.tar.bz2
gentoo-2-d747a1470383acd44535921e03e00d2b0e8a58cc.zip
Respect ldflags. Bug #435048. Version bump. #438604
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/shotwell/ChangeLog8
-rw-r--r--media-gfx/shotwell/files/shotwell-0.13.1-ldflags.patch28
-rw-r--r--media-gfx/shotwell/shotwell-0.13.1.ebuild89
3 files changed, 124 insertions, 1 deletions
diff --git a/media-gfx/shotwell/ChangeLog b/media-gfx/shotwell/ChangeLog
index 964f7596f076..bcca411dc98f 100644
--- a/media-gfx/shotwell/ChangeLog
+++ b/media-gfx/shotwell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/shotwell
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/ChangeLog,v 1.38 2012/08/26 00:39:29 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/ChangeLog,v 1.39 2012/10/28 19:30:02 hwoarang Exp $
+
+*shotwell-0.13.1 (28 Oct 2012)
+
+ 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/shotwell-0.13.1-ldflags.patch, +shotwell-0.13.1.ebuild:
+ Respect ldflags. Bug #435048. Version bump. #438604
26 Aug 2012; Markos Chandras <hwoarang@gentoo.org> -files/0.10-ldflags.patch,
-files/0.11.0-ldflags.patch, -files/shotwell-0.10.1-libraw-config.patch,
diff --git a/media-gfx/shotwell/files/shotwell-0.13.1-ldflags.patch b/media-gfx/shotwell/files/shotwell-0.13.1-ldflags.patch
new file mode 100644
index 000000000000..97a9956bf52d
--- /dev/null
+++ b/media-gfx/shotwell/files/shotwell-0.13.1-ldflags.patch
@@ -0,0 +1,28 @@
+Respect LDFLAGS when building C files. Bug #435048
+Patch hasn't been sent upstream yet.
+Index: shotwell-0.13.1/Makefile
+===================================================================
+--- shotwell-0.13.1.orig/Makefile
++++ shotwell-0.13.1/Makefile
+@@ -697,7 +697,7 @@ $(EXPANDED_C_FILES): $(VALA_STAMP)
+ @
+
+ $(EXPANDED_OBJ_FILES): %.o: %.c $(CONFIG_IN) Makefile
+- $(CC) -c $(VALA_CFLAGS) $(CFLAGS) -o $@ $<
++ $(CC) -c $(VALA_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $<
+
+ $(PROGRAM): $(EXPANDED_OBJ_FILES) $(RESOURCES) $(LANG_STAMP) $(THUMBNAILER_BIN)
+ $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(LDFLAGS) $(RESOURCES) $(VALA_LDFLAGS) $(EXPORT_FLAGS) -o $@
+Index: shotwell-0.13.1/plugins/Makefile.plugin.mk
+===================================================================
+--- shotwell-0.13.1.orig/plugins/Makefile.plugin.mk
++++ shotwell-0.13.1/plugins/Makefile.plugin.mk
+@@ -54,7 +54,7 @@ $(CFILES): .stamp
+ @
+
+ $(OFILES): %.o: %.c $(CFILES)
+- $(CC) -c $(CFLAGS) $(DEFINES) -I../.. $(CFILES)
++ $(CC) -c $(CFLAGS) $(LDFLAGS) $(DEFINES) -I../.. $(CFILES)
+
+ $(PLUGIN).so: $(OFILES)
+ $(CC) $(CFLAGS) $(LDFLAGS) -shared $(OFILES) $(LIBS) -o $@
diff --git a/media-gfx/shotwell/shotwell-0.13.1.ebuild b/media-gfx/shotwell/shotwell-0.13.1.ebuild
new file mode 100644
index 000000000000..0cebea6e0cb4
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.13.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/shotwell-0.13.1.ebuild,v 1.1 2012/10/28 19:30:02 hwoarang Exp $
+
+EAPI=4
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+
+inherit gnome2 versionator eutils multilib toolchain-funcs vala
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="http://www.yorba.org/shotwell/"
+SRC_URI="http://www.yorba.org/download/${PN}/stable/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="ar ast bg bn ca cs da de el en_GB es et eu fi fr gl he hi hr hu ia id it ja kk
+ko lt lv mk nb nl pa pl pt pt_BR ro ru sk sl sr sv ta te ta_IN te_IN th tr uk vi zh_CN zh_TW"
+
+for x in ${LANGS}; do
+ IUSE+="linguas_${x} "
+done
+
+RDEPEND="
+ >=dev-db/sqlite-3.5.9:3
+ >=dev-libs/dbus-glib-0.80
+ >=dev-libs/glib-2.30.0:2
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libgee-0.5.0:0
+ >=dev-libs/libunique-3.0.0:3
+ >=dev-libs/libxml2-2.6.32:2
+ >=media-libs/gexiv2-0.3.92
+ media-libs/gst-plugins-base:0.10
+ media-libs/gstreamer:0.10
+ media-libs/lcms:2
+ >=media-libs/libexif-0.6.16
+ >=media-libs/libgphoto2-2.4.2
+ >=media-libs/libraw-0.14.0
+ >=net-libs/libsoup-2.26.0:2.4
+ net-libs/rest:0.7
+ net-libs/webkit-gtk:3
+ || ( >=sys-fs/udev-171[gudev] >=sys-fs/udev-145[extras] )
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ sys-devel/m4"
+
+DOCS=( AUTHORS MAINTAINERS NEWS README THANKS )
+
+# This probabl comes from libraries that
+# shotwell-video-thumbnailer links to.
+# Nothing we can do at the moment. #435048
+QA_FLAGS_IGNORED="/usr/bin/${PN}-video-thumbnailer"
+
+pkg_setup() {
+ tc-export CC
+ G2CONF="${G2CONF}
+ --disable-schemas-compile
+ --disable-desktop-update
+ --disable-icon-update
+ --lib=$(get_libdir)"
+}
+
+src_prepare() {
+ vala_src_prepare
+ sed \
+ -e 's|CFLAGS :|CFLAGS +|g' \
+ -i plugins/Makefile.plugin.mk || die
+ # respect LDFLAGS. Bug #435048
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+ local valaver="$(vala_best_api_version)"
+ emake VALAC="$(type -p valac-${valaver})"
+}
+
+src_install() {
+ gnome2_src_install
+ for x in ${LANGS}; do
+ if ! has ${x} ${LINGUAS}; then
+ find "${D}"/usr/share/locale/${x} -type f -exec rm {} \;
+ fi
+ done
+}