summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Peterson <lavajoe@gentoo.org>2008-05-28 21:52:46 +0000
committerJoe Peterson <lavajoe@gentoo.org>2008-05-28 21:52:46 +0000
commite4e0dad2078ece36588fe583a33ca0ca55ed89a8 (patch)
tree5674966fbb0ab5538a55d417b6891a4d8d898d04 /media-gfx
parentversion bump (diff)
downloadgentoo-2-e4e0dad2078ece36588fe583a33ca0ca55ed89a8.tar.gz
gentoo-2-e4e0dad2078ece36588fe583a33ca0ca55ed89a8.tar.bz2
gentoo-2-e4e0dad2078ece36588fe583a33ca0ca55ed89a8.zip
Backport location changes to 3.6.1; fix up some autoconf stuff
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/povray/ChangeLog8
-rw-r--r--media-gfx/povray/povray-3.6.1-r3.ebuild84
-rw-r--r--media-gfx/povray/povray-3.7.0_beta25-r1.ebuild36
3 files changed, 111 insertions, 17 deletions
diff --git a/media-gfx/povray/ChangeLog b/media-gfx/povray/ChangeLog
index aac5029dab95..ed9804f61173 100644
--- a/media-gfx/povray/ChangeLog
+++ b/media-gfx/povray/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/povray
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.73 2008/05/10 17:22:29 lavajoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.74 2008/05/28 21:52:46 lavajoe Exp $
+
+*povray-3.6.1-r3 (28 May 2008)
+
+ 28 May 2008; Joe Peterson <lavajoe@gentoo.org> +povray-3.6.1-r3.ebuild,
+ povray-3.7.0_beta25-r1.ebuild:
+ Backport location changes to 3.6.1; fix up some autoconf stuff
10 May 2008; Joe Peterson <lavajoe@gentoo.org> -povray-3.6.1-r1.ebuild:
Remove old
diff --git a/media-gfx/povray/povray-3.6.1-r3.ebuild b/media-gfx/povray/povray-3.6.1-r3.ebuild
new file mode 100644
index 000000000000..146cdae4148c
--- /dev/null
+++ b/media-gfx/povray/povray-3.6.1-r3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.6.1-r3.ebuild,v 1.1 2008/05/28 21:52:46 lavajoe Exp $
+
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="The Persistence Of Vision Ray Tracer"
+SRC_URI="ftp://ftp.povray.org/pub/povray/Official/Unix/${P}.tar.bz2"
+HOMEPAGE="http://www.povray.org/"
+
+LICENSE="povlegal-3.6"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="svga tiff X"
+
+DEPEND="media-libs/libpng
+ tiff? ( >=media-libs/tiff-3.6.1 )
+ media-libs/jpeg
+ sys-libs/zlib
+ X? ( x11-libs/libXaw )
+ svga? ( media-libs/svgalib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-configure.patch
+ epatch "${FILESDIR}"/${P}-find-egrep.patch
+
+ # Change some destination directories that cannot be adjusted via configure
+ cp Makefile.am Makefile.am.orig
+ sed -i -e "s:^povlibdir = .*:povlibdir = @datadir@/${PN}:" Makefile.am
+ sed -i -e "s:^povdocdir = .*:povdocdir = @datadir@/doc/${PF}:" Makefile.am
+ sed -i -e "s:^povconfdir = .*:povconfdir = @sysconfdir@/${PN}:" Makefile.am
+
+ cd unix
+ cp Makefile.am Makefile.am.orig
+ sed -i -e 's:^ -DPOVLIBDIR=.*: -DPOVLIBDIR=\\"@datadir@/'"${PN}"'\\" \\:' Makefile.am
+ sed -i -e 's:^ -DPOVCONFDIR=.*: -DPOVCONFDIR=\\"@sysconfdir@/'"${PN}"'\\" \\:' Makefile.am
+ cd ..
+
+ # Use of "automake" below will cause a QA warning,
+ # but eautoreconf does not work for this source.
+ eaclocal
+ eautoconf
+ automake
+}
+
+src_compile() {
+ # Fixes bug 71255
+ if [[ $(get-flag march) == k6-2 ]]; then
+ filter-flags -fomit-frame-pointer
+ fi
+
+ econf \
+ COMPILED_BY="Portage (Gentoo `uname`) on `hostname -f`" \
+ $(use_with svga) \
+ $(use_with tiff) \
+ $(use_with X) \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_preinst() {
+ # Copy the old config files if they are in the old location
+ # but do not yet exist in the new location.
+ # This way, they can be treated by CONFIG_PROTECT as normal.
+ for conf_file in $(ls "${D}/etc/${PN}"); do
+ if [ ! -e "${ROOT}etc/${PN}/${conf_file}" ]; then
+ for version_dir in $(ls "${ROOT}etc/${PN}" | grep "^[0-9]" | sort -rn); do
+ if [ -e "${ROOT}etc/${PN}/${version_dir}/${conf_file}" ]; then
+ mv "${ROOT}etc/${PN}/${version_dir}/${conf_file}" "${ROOT}etc/${PN}"
+ elog "Note: ${conf_file} moved from ${ROOT}etc/povray/${version_dir}/ to ${ROOT}etc/povray/"
+ break
+ fi
+ done
+ fi
+ done
+}
diff --git a/media-gfx/povray/povray-3.7.0_beta25-r1.ebuild b/media-gfx/povray/povray-3.7.0_beta25-r1.ebuild
index 9a8496d7d3fc..88f642bccbb5 100644
--- a/media-gfx/povray/povray-3.7.0_beta25-r1.ebuild
+++ b/media-gfx/povray/povray-3.7.0_beta25-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.7.0_beta25-r1.ebuild,v 1.1 2008/05/09 13:06:07 lavajoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.7.0_beta25-r1.ebuild,v 1.2 2008/05/28 21:52:46 lavajoe Exp $
inherit eutils autotools flag-o-matic versionator
@@ -30,19 +30,9 @@ DEPEND="media-libs/libpng
S="${WORKDIR}/${PN}-${MY_PV}"
-src_compile() {
- # Fixes bug 71255
- if [[ $(get-flag march) == k6-2 ]]; then
- filter-flags -fomit-frame-pointer
- fi
-
- # The config files are installed correctly (e.g. povray.conf),
- # but the code compiles using incorrect [default] paths
- # (based on /usr/local...), so povray will not find the system
- # config files without the following fix:
- MY_MAIN_VER=$(get_version_component_range 1-2)
- append-flags -DPOVLIBDIR=\\\"${ROOT}usr/share/${PN}\\\"
- append-flags -DPOVCONFDIR=\\\"${ROOT}etc/${PN}\\\"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
# Change some destination directories that cannot be adjusted via configure
cp configure.ac configure.ac.orig
@@ -55,10 +45,24 @@ src_compile() {
sed -i -e "s:^povdocdir = .*:povdocdir = @datadir@/doc/${PF}:" Makefile.am
sed -i -e "s:^povconfdir = .*:povconfdir = @sysconfdir@/${PN}:" Makefile.am
- autoreconf
+ eautoreconf
+}
+
+src_compile() {
+ # Fixes bug 71255
+ if [[ $(get-flag march) == k6-2 ]]; then
+ filter-flags -fomit-frame-pointer
+ fi
+
+ # The config files are installed correctly (e.g. povray.conf),
+ # but the code compiles using incorrect [default] paths
+ # (based on /usr/local...), so povray will not find the system
+ # config files without the following fix:
+ append-flags -DPOVLIBDIR=\\\"${ROOT}usr/share/${PN}\\\"
+ append-flags -DPOVCONFDIR=\\\"${ROOT}etc/${PN}\\\"
econf \
- COMPILED_BY="${USER} <${USER}@`uname -n`>" \
+ COMPILED_BY="Portage (Gentoo `uname`) on `hostname -f`" \
$(use_with svga) \
$(use_with tiff) \
$(use_with X) \