summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2008-03-16 18:15:04 +0000
committerMarkus Meier <maekke@gentoo.org>2008-03-16 18:15:04 +0000
commitef205554b8befa56721366d40c3c4c1d18c639c0 (patch)
tree67abd37df0e0b358492d43e34cdd6d5aaab2a1c4 /media-gfx
parentVersion bump to GTK+-2 release. (diff)
downloadgentoo-2-ef205554b8befa56721366d40c3c4c1d18c639c0.tar.gz
gentoo-2-ef205554b8befa56721366d40c3c4c1d18c639c0.tar.bz2
gentoo-2-ef205554b8befa56721366d40c3c4c1d18c639c0.zip
version bump, requested in bug #212566
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/imagemagick/ChangeLog8
-rw-r--r--media-gfx/imagemagick/files/imagemagick-6.3.9.8-hpgl.patch12
-rw-r--r--media-gfx/imagemagick/imagemagick-6.3.9.8.ebuild143
3 files changed, 162 insertions, 1 deletions
diff --git a/media-gfx/imagemagick/ChangeLog b/media-gfx/imagemagick/ChangeLog
index a61a684f30d4..29eba5b71fe0 100644
--- a/media-gfx/imagemagick/ChangeLog
+++ b/media-gfx/imagemagick/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/imagemagick
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.271 2008/03/14 11:12:19 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.272 2008/03/16 18:15:03 maekke Exp $
+
+*imagemagick-6.3.9.8 (16 Mar 2008)
+
+ 16 Mar 2008; Markus Meier <maekke@gentoo.org>
+ +files/imagemagick-6.3.9.8-hpgl.patch, +imagemagick-6.3.9.8.ebuild:
+ version bump, requested in bug #212566
14 Mar 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing Karol Wojtaszek (sekretarz, #56912) from metadata.xml.
diff --git a/media-gfx/imagemagick/files/imagemagick-6.3.9.8-hpgl.patch b/media-gfx/imagemagick/files/imagemagick-6.3.9.8-hpgl.patch
new file mode 100644
index 000000000000..07461b7950b0
--- /dev/null
+++ b/media-gfx/imagemagick/files/imagemagick-6.3.9.8-hpgl.patch
@@ -0,0 +1,12 @@
+diff -ru ImageMagick-6.3.9.orig/config/delegates.xml.in ImageMagick-6.3.9/config/delegates.xml.in
+--- ImageMagick-6.3.9.orig/config/delegates.xml.in 2008-03-16 18:16:10.000000000 +0100
++++ ImageMagick-6.3.9/config/delegates.xml.in 2008-03-16 18:18:30.000000000 +0100
+@@ -67,7 +67,7 @@
+ <delegate decode="gplt" command="&quot;@EchoDelegate@&quot; &quot;set size 1.25,0.62 set terminal postscript portrait color solid; set output &quot;%o&quot;; load &quot;%i&quot;&quot; &gt; &quot;%u&quot;;&quot;@GnuplotDecodeDelegate@&quot; &quot;%u&quot;"/>
+ <delegate decode="hdr" command="&quot;@HDRDecodeDelegate@&quot; &quot;%i&quot; &quot;%o&quot;"/>
+ <delegate decode="hpg" command="&quot;@HPGLDecodeDelegate@&quot; -q -m eps -f `basename &quot;%o&quot;` &quot;%i&quot; mv -f `basename &quot;%o&quot;` &quot;%o&quot;"/>
+- <delegate decode="hpgl" command="if [ -e @HPGLDecodeDelegate@ -o -e /usr/bin/@HPGLDecodeDelegate@ ]; then @HPGLDecodeDelegate@ -q -m eps -f `basename &quot;%o&quot;` &quot;%i&quot; mv -f `basename &quot;%o&quot;` &quot;%o else echo &quot;You need to install hp2xx to use HPGL files with ImageMagick.&quot; exit 1 fi"/>
++ <delegate decode="hpgl" command="if [ -e @HPGLDecodeDelegate@ -o -e /usr/bin/@HPGLDecodeDelegate@ ]; then @HPGLDecodeDelegate@ -q -m eps -f `basename &quot;%o&quot;` &quot;%i&quot;; mv -f `basename &quot;%o&quot;` &quot;%o&quot;; else echo &quot;You need to install hp2xx to use HPGL files with ImageMagick.&quot;; exit 1; fi"/>
+ <delegate decode="htm" command="&quot;@HTMLDecodeDelegate@&quot; -U -o &quot;%o&quot; &quot;%i&quot;"/>
+ <delegate decode="html" command="&quot;@HTMLDecodeDelegate@&quot; -U -o &quot;%o&quot; &quot;%i&quot;"/>
+ <delegate decode="https" command="&quot;@WWWDecodeDelegate@&quot; -s -k -o &quot;%o&quot; &quot;https:%M&quot;"/>
diff --git a/media-gfx/imagemagick/imagemagick-6.3.9.8.ebuild b/media-gfx/imagemagick/imagemagick-6.3.9.8.ebuild
new file mode 100644
index 000000000000..34cf9b3e3323
--- /dev/null
+++ b/media-gfx/imagemagick/imagemagick-6.3.9.8.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/imagemagick-6.3.9.8.ebuild,v 1.1 2008/03/16 18:15:03 maekke Exp $
+
+inherit eutils multilib perl-app
+
+MY_PN=ImageMagick
+MY_P=${MY_PN}-${PV%.*}
+MY_P2=${MY_PN}-${PV%.*}-${PV#*.*.*.}
+
+DESCRIPTION="A collection of tools and libraries for many image formats"
+HOMEPAGE="http://www.imagemagick.org/"
+SRC_URI="ftp://ftp.imagemagick.org/pub/${MY_PN}/${MY_P2}.tar.bz2"
+
+LICENSE="imagemagick"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bzip2 djvu doc fontconfig fpx graphviz gs hdri jbig jpeg jpeg2k lcms nocxx
+ openexr perl png q8 q32 svg tiff truetype X wmf xml zlib"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ djvu? ( app-text/djvu )
+ fontconfig? ( media-libs/fontconfig )
+ fpx? ( media-libs/libfpx )
+ graphviz? ( >=media-gfx/graphviz-2.6 )
+ gs? ( virtual/ghostscript )
+ jbig? ( media-libs/jbigkit )
+ jpeg? ( >=media-libs/jpeg-6b )
+ jpeg2k? ( media-libs/jasper )
+ lcms? ( >=media-libs/lcms-1.06 )
+ openexr? ( media-libs/openexr )
+ perl? ( >=dev-lang/perl-5.8.6-r6 !=dev-lang/perl-5.8.7 )
+ png? ( media-libs/libpng )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ xml? ( >=dev-libs/libxml2-2.4.10 )
+ truetype? ( =media-libs/freetype-2* media-fonts/corefonts )
+ wmf? ( >=media-libs/libwmf-0.2.8 )
+ zlib? ( sys-libs/zlib )
+ X? (
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM
+ svg? ( >=gnome-base/librsvg-2.9.0 )
+ )
+ !dev-perl/perlmagick
+ !sys-apps/compare"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ >=sys-devel/libtool-1.5.2-r6
+ X? ( x11-proto/xextproto )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use djvu && ! built_with_use app-text/djvu threads; then
+ eerror "app-text/djvu has to be built with threads support."
+ die "build app-text/djvu with USE=\"threads\""
+ fi
+ # for now, only build svg support when X is enabled, as librsvg
+ # pulls in quite some X dependencies.
+ if use svg && ! use X ; then
+ elog "the svg USE-flag requires the X USE-flag set."
+ elog "disabling svg support for now."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # fix doc dir, bug 91911
+ sed -i -e \
+ 's:DOCUMENTATION_PATH="${DATA_DIR}/doc/${DOCUMENTATION_RELATIVE_PATH}":DOCUMENTATION_PATH="/usr/share/doc/${PF}":g' \
+ "${S}"/configure || die
+
+ # bug 206925
+ epatch "${FILESDIR}"/${P}-hpgl.patch
+}
+
+src_compile() {
+ local myconf
+ if use q32 ; then
+ myconf="${myconf} --with-quantum-depth=32"
+ elif use q8 ; then
+ myconf="${myconf} --with-quantum-depth=8"
+ else
+ myconf="${myconf} --with-quantum-depth=16"
+ fi
+
+ if use X && use svg ; then
+ myconf="${myconf} --with-rsvg"
+ else
+ myconf="${myconf} --without-rsvg"
+ fi
+
+ econf \
+ ${myconf} \
+ --with-ltdl-include=/usr/include \
+ --with-ltdl-lib=/usr/$(get_libdir) \
+ --with-threads \
+ --with-modules \
+ $(use_with perl) \
+ --with-gs-font-dir=/usr/share/fonts/default/ghostscript \
+ $(use_enable hdri) \
+ $(use_with truetype windows-font-dir /usr/share/fonts/corefonts) \
+ $(use_with !nocxx magick-plus-plus) \
+ $(use_with bzip2 bzlib) \
+ $(use_with djvu) \
+ $(use_with fontconfig) \
+ $(use_with fpx) \
+ $(use_with gs dps) \
+ $(use_with gs gslib) \
+ $(use_with graphviz gvc) \
+ $(use_with jbig) \
+ $(use_with jpeg jpeg) \
+ $(use_with jpeg2k jp2) \
+ $(use_with lcms) \
+ $(use_with png) \
+ $(use_with svg rsvg) \
+ $(use_with tiff) \
+ $(use_with truetype freetype) \
+ $(use_with wmf) \
+ $(use_with xml) \
+ $(use_with zlib) \
+ $(use_with X x) \
+ $(use_with openexr) \
+ || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation of files into image failed"
+
+ # dont need these files with runtime plugins
+ rm -f "${D}"/usr/$(get_libdir)/*/*/*.{la,a}
+
+ use doc || rm -r "${D}"/usr/share/doc/${PF}/{www,images,index.html}
+ dodoc NEWS.txt ChangeLog AUTHORS.txt README.txt
+
+ # Fix perllocal.pod file collision
+ use perl && fixlocalpod
+}