summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2014-08-25 23:14:55 +0000
committerJustin Bronder <jsbronder@gentoo.org>2014-08-25 23:14:55 +0000
commitf0dec8f26605c59b6cdb4aa7dc40908ecd9d144a (patch)
tree2469c0a6d22004c642b7d925c70a7115a232332d /media-gfx
parentSecurity cleanup wrt bug 445846 (diff)
downloadgentoo-2-f0dec8f26605c59b6cdb4aa7dc40908ecd9d144a.tar.gz
gentoo-2-f0dec8f26605c59b6cdb4aa7dc40908ecd9d144a.tar.bz2
gentoo-2-f0dec8f26605c59b6cdb4aa7dc40908ecd9d144a.zip
Version bump (#520654). Thanks to Émeric Maschino for the patch.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4D7043C9)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/openmesh/ChangeLog7
-rw-r--r--media-gfx/openmesh/openmesh-3.2.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/media-gfx/openmesh/ChangeLog b/media-gfx/openmesh/ChangeLog
index 606dd6b059b8..13a6caadd448 100644
--- a/media-gfx/openmesh/ChangeLog
+++ b/media-gfx/openmesh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/openmesh
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/ChangeLog,v 1.31 2014/01/14 13:53:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/ChangeLog,v 1.32 2014/08/25 23:14:55 jsbronder Exp $
+
+*openmesh-3.2 (25 Aug 2014)
+
+ 25 Aug 2014; Justin Bronder <jsbronder@gentoo.org> +openmesh-3.2.ebuild:
+ Version bump (#520654). Thanks to Émeric Maschino for the patch.
14 Jan 2014; Agostino Sarubbo <ago@gentoo.org> openmesh-2.3.1.ebuild:
Stable for x86, wrt bug #495704
diff --git a/media-gfx/openmesh/openmesh-3.2.ebuild b/media-gfx/openmesh/openmesh-3.2.ebuild
new file mode 100644
index 000000000000..80ed0731fab2
--- /dev/null
+++ b/media-gfx/openmesh/openmesh-3.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/openmesh-3.2.ebuild,v 1.1 2014/08/25 23:14:55 jsbronder Exp $
+
+EAPI="5"
+inherit eutils cmake-utils
+
+MY_PN="OpenMesh"
+MY_PV="${PV/_rc/-RC}"
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+DESCRIPTION="A generic and efficient data structure for representing and manipulating polygonal meshes"
+HOMEPAGE="http://www.openmesh.org/"
+SRC_URI="http://openmesh.org/media/Releases/${MY_PV/-RC/RC}/${MY_PN}-${MY_PV}.tar.bz2"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="qt4 static-libs"
+
+RDEPEND="qt4? ( dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ media-libs/freeglut )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Fix libdir and remove rpath.
+ sed -i \
+ -e "s|\(set (ACG_PROJECT_LIBDIR \"\).*|\1$(get_libdir)/\")|" \
+ -e "s|\(set (ACG_PROJECT_PLUGINDIR \"\)lib\(.*\)|\1$(get_libdir)\2|" \
+ -e "s|\(BUILD_WITH_INSTALL_RPATH \)1|\1 0|" \
+ -e "s|\(SKIP_BUILD_RPATH\) 0|\1 1|" \
+ -e '/^ *INSTALL_RPATH/d' \
+ cmake/ACGCommon.cmake || die
+
+ if ! use static-libs; then
+ sed -i "s|\(SHARED\)ANDSTATIC|\1|" \
+ src/${MY_PN}/{Core,Tools}/CMakeLists.txt || die
+ sed -i '/OpenMeshCoreStatic/d' \
+ src/${MY_PN}/Tools/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ mycmakeargs="$(cmake-utils_use_build "qt4" "APPS")"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc LICENSE/* README CHANGELOG
+}