summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-21 14:06:23 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-21 14:06:23 +0000
commitc4306470ec659562fc19edf9c2cf1ae01ce90ae5 (patch)
tree533aa4ea69872df5872c8d592801d3791eeb5e63 /media-libs/aalib/aalib-1.4_rc4-r2.ebuild
parentnew version with a fixed librsvg dependency (diff)
downloadgentoo-2-c4306470ec659562fc19edf9c2cf1ae01ce90ae5.tar.gz
gentoo-2-c4306470ec659562fc19edf9c2cf1ae01ce90ae5.tar.bz2
gentoo-2-c4306470ec659562fc19edf9c2cf1ae01ce90ae5.zip
elibtoolized
Diffstat (limited to 'media-libs/aalib/aalib-1.4_rc4-r2.ebuild')
-rw-r--r--media-libs/aalib/aalib-1.4_rc4-r2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/aalib/aalib-1.4_rc4-r2.ebuild b/media-libs/aalib/aalib-1.4_rc4-r2.ebuild
new file mode 100644
index 000000000000..6e78ee24b46c
--- /dev/null
+++ b/media-libs/aalib/aalib-1.4_rc4-r2.ebuild
@@ -0,0 +1,62 @@
+## Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/aalib/aalib-1.4_rc4-r2.ebuild,v 1.1 2002/06/21 14:06:23 seemant Exp $
+
+inherit libtool
+
+MY_P=${P/_/}
+S=${WORKDIR}/${PN}-1.4.0
+DESCRIPTION="A ASCI-Graphics Library"
+SRC_URI="mirror://sourceforge/aa-project/${MY_P}.tar.gz"
+HOMEPAGE="http://aa-project.sourceforge.net/aalib/"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ slang? ( >=sys-libs/slang-1.4.2 )
+ X? ( virtual/x11 )
+ gpm? ( sys-libs/gpm )"
+
+SLOT=""
+LICENSE="GPL-2"
+
+src_unpack() {
+
+ unpack ${A}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff || die
+ touch *
+}
+
+src_compile() {
+
+ local myconf
+ use slang \
+ && myconf="--with-slang-driver=yes" \
+ || myconf="--with-slang-driver=no"
+
+ use X \
+ && myconf="${myconf} --with-x11-driver=yes" \
+ || myconf="${myconf} --with-x11-driver=no"
+
+ use gpm \
+ && myconf="${myconf} --with-gpm-mouse=no"
+
+ elibtoolize
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=${D}/usr/share/man \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc ANNOUNCE AUTHORS ChangeLog COPYING NEWS README*
+}
+