summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2007-06-27 15:18:41 +0000
committerTony Vroon <chainsaw@gentoo.org>2007-06-27 15:18:41 +0000
commitaed166e3090af9079d20a740ac6e489d79a486c7 (patch)
tree203924c882cd0bd82ff5ac2aeed6411cb1e5964e /media-libs/alsa-lib
parentVersion bump to 1.0.14 final as requested in bug #181042. (diff)
downloadgentoo-2-aed166e3090af9079d20a740ac6e489d79a486c7.tar.gz
gentoo-2-aed166e3090af9079d20a740ac6e489d79a486c7.tar.bz2
gentoo-2-aed166e3090af9079d20a740ac6e489d79a486c7.zip
Version bump to 1.0.14a as requested in bug #181042. Change advisory message to recommend in-kernel ALSA instead of the alsa-drivers ebuild as per new ALSA policy.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/ChangeLog9
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.14a.ebuild85
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-1.0.14a3
3 files changed, 96 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 0dcf841dfd0f..81b13463bf55 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.233 2007/06/01 04:36:34 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.234 2007/06/27 15:18:41 chainsaw Exp $
+
+*alsa-lib-1.0.14a (27 Jun 2007)
+
+ 27 Jun 2007; Tony Vroon <chainsaw@gentoo.org> +alsa-lib-1.0.14a.ebuild:
+ Version bump to 1.0.14a as requested in bug #181042. Change advisory message
+ to recommend in-kernel ALSA instead of the alsa-drivers ebuild as per new
+ ALSA policy.
01 Jun 2007; Joshua Kinard <kumba@gentoo.org> alsa-lib-1.0.14_rc3.ebuild:
Stable on mips.
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.14a.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.14a.ebuild
new file mode 100644
index 000000000000..ff84437333ad
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.14a.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.14a.ebuild,v 1.1 2007/06/27 15:18:41 chainsaw Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.9"
+
+inherit eutils autotools libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc debug alisp midi"
+
+RDEPEND=">=media-sound/alsa-headers-${PV/14a/14}"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+IUSE_PCM_PLUGIN="copy linear route mulaw alaw adpcm rate plug multi shm file null empty share meter hooks lfloat ladspa dmix dshare dsnoop asym iec958
+softvol extplug ioplug"
+
+for plugin in ${IUSE_PCM_PLUGIN}; do
+ IUSE="${IUSE} alsa_pcm_plugins_${plugin}"
+done
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ --disable-resmgr \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ $(use_enable midi instr) \
+ $(use_enable midi seq) $(use_enable midi aload) \
+ "--with-pcm-plugins=${ALSA_PCM_PLUGINS}" \
+ --disable-dependency-tracking \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ elog ""
+ elog "Please try in-kernel ALSA drivers instead of the alsa-drivers ebuild."
+ elog "If alsa-drivers works for you where a recent kernel does not, we want "
+ elog "to know about this. Our e-mail address is alsa-bugs@gentoo.org"
+ elog "However, if you notice no sound output or instability, please try to "
+ elog "upgrade your kernel to a newer version first."
+}
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14a b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14a
new file mode 100644
index 000000000000..a0b370ccdeba
--- /dev/null
+++ b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14a
@@ -0,0 +1,3 @@
+MD5 72dc63821ce33f2b97a151a909b06ff8 alsa-lib-1.0.14a.tar.bz2 785668
+RMD160 27eddeda716213807b38a33e7a13408bc073d9c0 alsa-lib-1.0.14a.tar.bz2 785668
+SHA256 de64de37a9acf918f347a3975e0ad3f58b24790dafdd03d9869a22ced4e5dcc7 alsa-lib-1.0.14a.tar.bz2 785668