summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2012-01-26 11:49:30 +0000
committerTony Vroon <chainsaw@gentoo.org>2012-01-26 11:49:30 +0000
commitbc518c55d65a9531890248dd0f25770157607899 (patch)
tree5a23290da6ff7e6302dc7905dc85f8d284619552 /media-libs/alsa-lib
parentRevision bump including latest genpatches with more security fixes. (diff)
downloadgentoo-2-bc518c55d65a9531890248dd0f25770157607899.tar.gz
gentoo-2-bc518c55d65a9531890248dd0f25770157607899.tar.bz2
gentoo-2-bc518c55d65a9531890248dd0f25770157607899.zip
Version bump. Do a full eautoreconf to avoid failures with et_EE locale, closes bug #361053 by Mart "leio" Raudsepp. Remove extraneous CFLAGS, closes bug #378653 by Agostino "ago" Sarubbo. Prevent build failures in the library and beyond by not allowing individual plugin control, closes bug #379925 by Myckel Habets. Removed old ebuild.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/ChangeLog15
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.25.ebuild (renamed from media-libs/alsa-lib/alsa-lib-1.0.23.ebuild)55
-rw-r--r--media-libs/alsa-lib/files/1.0.25-extraneous-cflags.diff23
3 files changed, 58 insertions, 35 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index cb87bcdf3650..c088fc9b352b 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-libs/alsa-lib
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.324 2011/12/29 21:35:32 halcy0n Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.325 2012/01/26 11:49:30 chainsaw Exp $
+
+*alsa-lib-1.0.25 (26 Jan 2012)
+
+ 26 Jan 2012; Tony Vroon <chainsaw@gentoo.org>
+ +files/1.0.25-extraneous-cflags.diff, -alsa-lib-1.0.23.ebuild,
+ +alsa-lib-1.0.25.ebuild:
+ Version bump. Do a full eautoreconf to avoid failures with et_EE locale,
+ closes bug #361053 by Mart "leio" Raudsepp. Remove extraneous CFLAGS, closes
+ bug #378653 by Agostino "ago" Sarubbo. Prevent build failures in the library
+ and beyond by not allowing individual plugin control, closes bug #379925 by
+ Myckel Habets. Removed old ebuild.
29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> alsa-lib-1.0.24.1.ebuild:
Stable for ppc/ppc64; bug #379423
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.23.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.25.ebuild
index 804d3746d4ea..ef5a4ac0e8b9 100644
--- a/media-libs/alsa-lib/alsa-lib-1.0.23.ebuild
+++ b/media-libs/alsa-lib/alsa-lib-1.0.25.ebuild
@@ -1,13 +1,15 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.23.ebuild,v 1.10 2011/02/17 17:26:29 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.25.ebuild,v 1.1 2012/01/26 11:49:30 chainsaw Exp $
+
+EAPI=4
PYTHON_DEPEND="python? 2"
-inherit eutils libtool python
+inherit autotools base python multilib
-MY_P="${P/_rc/rc}"
-S="${WORKDIR}/${MY_P}"
+MY_P=${P/_rc/rc}
+S=${WORKDIR}/${MY_P}
DESCRIPTION="Advanced Linux Sound Architecture Library"
HOMEPAGE="http://www.alsa-project.org/"
@@ -15,48 +17,31 @@ SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc debug alisp python"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc debug alisp python static-libs"
-DEPEND=">=media-sound/alsa-headers-${PV}
+DEPEND=">=media-sound/alsa-headers-1.0.25
doc? ( >=app-doc/doxygen-1.2.6 )"
RDEPEND=""
-
-IUSE_PCM_PLUGIN="copy linear route mulaw alaw adpcm rate plug multi shm file
-null empty share meter mmap_emul hooks lfloat ladspa dmix dshare dsnoop asym iec958
-softvol extplug ioplug"
-
-for plugin in ${IUSE_PCM_PLUGIN}; do
- IUSE="${IUSE} alsa_pcm_plugins_${plugin}"
-done
+PATCHES=( "${FILESDIR}/${PV}-extraneous-cflags.diff" )
pkg_setup() {
- if [ -z "${ALSA_PCM_PLUGINS}" ] ; then
- ewarn "You haven't selected _any_ PCM plugins. Either you set it to something like the default"
- ewarn "(which is being set in the profile UNLESS you unset them) or alsa based applications"
- ewarn "are going to *misbehave* !"
- epause 5
- fi
-
if use python; then
python_set_active_version 2
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- elibtoolize
+src_prepare() {
+ eautoreconf
epunt_cxx
}
-src_compile() {
+src_configure() {
local myconf
use elibc_uclibc && myconf="--without-versioned"
econf \
- --enable-static \
+ $(use_enable static-libs static) \
--enable-shared \
--disable-resmgr \
--enable-rawmidi \
@@ -65,11 +50,12 @@ src_compile() {
$(use_with debug) \
$(use_enable alisp) \
$(use_enable python) \
- --with-pcm-plugins="${ALSA_PCM_PLUGINS}" \
--disable-dependency-tracking \
${myconf}
+}
- emake || die "make failed"
+src_compile() {
+ emake || die
if use doc; then
emake doc || die "failed to generate docs"
@@ -79,7 +65,10 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+ find "${ED}"/usr/$(get_libdir)/alsa-lib -name '*.a' -exec rm -f {} +
dodoc ChangeLog TODO || die
use doc && dohtml -r doc/doxygen/html/*
diff --git a/media-libs/alsa-lib/files/1.0.25-extraneous-cflags.diff b/media-libs/alsa-lib/files/1.0.25-extraneous-cflags.diff
new file mode 100644
index 000000000000..6d687c567313
--- /dev/null
+++ b/media-libs/alsa-lib/files/1.0.25-extraneous-cflags.diff
@@ -0,0 +1,23 @@
+diff -uNr alsa-lib-1.0.25.ORIG/modules/mixer/simple/Makefile.am alsa-lib-1.0.25/modules/mixer/simple/Makefile.am
+--- alsa-lib-1.0.25.ORIG/modules/mixer/simple/Makefile.am 2012-01-26 10:46:50.870738448 +0000
++++ alsa-lib-1.0.25/modules/mixer/simple/Makefile.am 2012-01-26 11:12:16.972695934 +0000
+@@ -1,7 +1,7 @@
+ alsaplugindir = @ALSA_PLUGIN_DIR@
+ pkglibdir = $(alsaplugindir)/smixer
+
+-AM_CFLAGS = -g -O2 -W -Wall
++AM_CFLAGS = -W -Wall
+
+ INCLUDES=-I$(top_srcdir)/include
+
+diff -uNr alsa-lib-1.0.25.ORIG/src/pcm/scopes/Makefile.am alsa-lib-1.0.25/src/pcm/scopes/Makefile.am
+--- alsa-lib-1.0.25.ORIG/src/pcm/scopes/Makefile.am 2012-01-26 10:46:50.875738335 +0000
++++ alsa-lib-1.0.25/src/pcm/scopes/Makefile.am 2012-01-26 11:12:29.172695655 +0000
+@@ -1,6 +1,6 @@
+ pkglibdir = $(libdir)/@PACKAGE@/scopes
+
+-AM_CFLAGS = -g -O2 -W -Wall
++AM_CFLAGS = -W -Wall
+
+ pkglib_LTLIBRARIES = scope-level.la
+