summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-02-11 00:02:26 +0000
committerOlivier Crête <tester@gentoo.org>2008-02-11 00:02:26 +0000
commit98ca141b33e3fe4ec52adcbdf16b98db614e2b63 (patch)
tree2a37b4004f89ce3fd5f93bcc0b33de3f2a5d1b3d /media-libs/aubio/aubio-0.3.2-r1.ebuild
parentwhitespace (diff)
downloadgentoo-2-98ca141b33e3fe4ec52adcbdf16b98db614e2b63.tar.gz
gentoo-2-98ca141b33e3fe4ec52adcbdf16b98db614e2b63.tar.bz2
gentoo-2-98ca141b33e3fe4ec52adcbdf16b98db614e2b63.zip
Adding patch to make it install multilib-friendly
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-libs/aubio/aubio-0.3.2-r1.ebuild')
-rw-r--r--media-libs/aubio/aubio-0.3.2-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/media-libs/aubio/aubio-0.3.2-r1.ebuild b/media-libs/aubio/aubio-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..3f10b7d797a1
--- /dev/null
+++ b/media-libs/aubio/aubio-0.3.2-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/aubio/aubio-0.3.2-r1.ebuild,v 1.1 2008/02/11 00:02:25 tester Exp $
+
+inherit eutils autotools
+
+IUSE="alsa doc jack lash"
+
+DESCRIPTION="Library for audio labelling"
+HOMEPAGE="http://aubio.piem.org"
+SRC_URI="http://aubio.piem.org/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="=sci-libs/fftw-3*
+ >=dev-util/pkgconfig-0.9.0
+ media-libs/libsndfile
+ media-libs/libsamplerate
+ >=dev-lang/swig-1.3.0
+ dev-lang/python
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ lash? ( media-sound/lash )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen virtual/latex-base )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/aubio-0.3.2-multilib.patch
+
+ eautomake
+}
+
+src_compile() {
+ econf $(use_enable jack) \
+ $(use_enable alsa) \
+ $(use_enable lash) \
+ || die "econf failed"
+ emake || die "emake failed"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ cd "${S}/doc"
+ doxygen user.cfg || die "creating user doc failed"
+ doxygen devel.cfg || die "creating devel doc failed"
+ doxygen examples.cfg || die "creating examples doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ doman doc/*.1
+ if use doc; then
+ mv doc/user/html doc/user/user
+ dohtml -r doc/user/user
+ mv doc/devel/html doc/devel/devel
+ dohtml -r doc/devel/devel
+ mv doc/examples/html doc/examples/examples
+ dohtml -r doc/examples/examples
+ fi
+
+}