summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-12-04 21:13:18 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-12-04 21:13:18 +0000
commitc60eecf064aef7a5e39e2189e3d7bcd0ccbba6ae (patch)
tree989d758582feab7a5a1863d29263ab799966cd7f /media-libs/bio2jack/bio2jack-0.4.ebuild
parentFixed install under certain circumstances where the Makefile insisted on pref... (diff)
downloadgentoo-2-c60eecf064aef7a5e39e2189e3d7bcd0ccbba6ae.tar.gz
gentoo-2-c60eecf064aef7a5e39e2189e3d7bcd0ccbba6ae.tar.bz2
gentoo-2-c60eecf064aef7a5e39e2189e3d7bcd0ccbba6ae.zip
Version bump.
Diffstat (limited to 'media-libs/bio2jack/bio2jack-0.4.ebuild')
-rw-r--r--media-libs/bio2jack/bio2jack-0.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/bio2jack/bio2jack-0.4.ebuild b/media-libs/bio2jack/bio2jack-0.4.ebuild
new file mode 100644
index 000000000000..efa79cf96984
--- /dev/null
+++ b/media-libs/bio2jack/bio2jack-0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/bio2jack/bio2jack-0.4.ebuild,v 1.1 2004/12/04 21:13:18 eradicator Exp $
+
+IUSE="static"
+
+inherit libtool
+
+DESCRIPTION="A library for porting blocked I/O OSS/ALSA audio applications to JACK"
+HOMEPAGE="http://bio2jack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bio2jack/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~ppc64"
+
+RDEPEND=">=media-sound/jack-audio-connection-kit-0.80"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.50"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ export WANT_AUTOMAKE=1.8
+ export WANT_AUTOCONF=2.5
+ aclocal || die
+ automake || die
+ autoconf || die
+ elibtoolize || die
+}
+
+src_compile() {
+ econf `use_enable static` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dobin bio2jack-config
+ dodoc AUTHORS ChangeLog NEWS README
+}