summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-09-28 18:16:55 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-09-28 18:16:55 +0000
commit76da674a1dcc3188dc4d84068657a647f6d7a813 (patch)
treed0bf2b3526ead19a31ce9072bea6a07ef4bc1cca /media-libs/bio2jack
parentResolve 65695. (Manifest recommit) (diff)
downloadgentoo-2-76da674a1dcc3188dc4d84068657a647f6d7a813.tar.gz
gentoo-2-76da674a1dcc3188dc4d84068657a647f6d7a813.tar.bz2
gentoo-2-76da674a1dcc3188dc4d84068657a647f6d7a813.zip
Added static USE flag support.
Diffstat (limited to 'media-libs/bio2jack')
-rw-r--r--media-libs/bio2jack/ChangeLog6
-rw-r--r--media-libs/bio2jack/bio2jack-0.3-r1.ebuild10
2 files changed, 13 insertions, 3 deletions
diff --git a/media-libs/bio2jack/ChangeLog b/media-libs/bio2jack/ChangeLog
index 5131ccca5caa..af6c679cd04b 100644
--- a/media-libs/bio2jack/ChangeLog
+++ b/media-libs/bio2jack/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/bio2jack
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/bio2jack/ChangeLog,v 1.4 2004/09/28 06:56:55 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/bio2jack/ChangeLog,v 1.5 2004/09/28 18:16:55 eradicator Exp $
+
+ 28 Sep 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ bio2jack-0.3-r1.ebuild:
+ Added static USE flag support.
*bio2jack-0.3-r1 (27 Sep 2004)
diff --git a/media-libs/bio2jack/bio2jack-0.3-r1.ebuild b/media-libs/bio2jack/bio2jack-0.3-r1.ebuild
index a3106e3c97bb..875b924b2169 100644
--- a/media-libs/bio2jack/bio2jack-0.3-r1.ebuild
+++ b/media-libs/bio2jack/bio2jack-0.3-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/bio2jack/bio2jack-0.3-r1.ebuild,v 1.2 2004/09/28 06:56:55 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/bio2jack/bio2jack-0.3-r1.ebuild,v 1.3 2004/09/28 18:16:55 eradicator Exp $
+
+IUSE="static"
inherit libtool
@@ -11,7 +13,6 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
-IUSE=""
RDEPEND=">=media-sound/jack-audio-connection-kit-0.80"
DEPEND="${RDEPEND}
@@ -30,6 +31,11 @@ src_unpack() {
elibtoolize || die
}
+src_compile() {
+ econf `use_enable static` || die
+ emake || die
+}
+
src_install() {
make DESTDIR="${D}" install || die
dobin bio2jack-config