summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-11 18:34:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-11 18:34:09 +0000
commit6a10dd6fece02a7f61aebb47dc3cae81a680eca1 (patch)
tree8bebd370d85da68966a3c0f5c3a3e33215c911f5 /media-libs/celt
parentMove symlinking udevadm and renaming of udevd from multilib_src_install_all()... (diff)
downloadgentoo-2-6a10dd6fece02a7f61aebb47dc3cae81a680eca1.tar.gz
gentoo-2-6a10dd6fece02a7f61aebb47dc3cae81a680eca1.tar.bz2
gentoo-2-6a10dd6fece02a7f61aebb47dc3cae81a680eca1.zip
Convert to multilib
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/celt')
-rw-r--r--media-libs/celt/ChangeLog7
-rw-r--r--media-libs/celt/celt-0.11.1-r1.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/media-libs/celt/ChangeLog b/media-libs/celt/ChangeLog
index d31c56f7ee7d..6d13f34952e1 100644
--- a/media-libs/celt/ChangeLog
+++ b/media-libs/celt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/celt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/celt/ChangeLog,v 1.25 2013/02/02 22:45:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/celt/ChangeLog,v 1.26 2013/08/11 18:34:09 aballier Exp $
+
+*celt-0.11.1-r1 (11 Aug 2013)
+
+ 11 Aug 2013; Alexis Ballier <aballier@gentoo.org> +celt-0.11.1-r1.ebuild:
+ Convert to multilib
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> celt-0.11.1.ebuild,
celt-0.5.1.3.ebuild, celt-0.7.1.ebuild:
diff --git a/media-libs/celt/celt-0.11.1-r1.ebuild b/media-libs/celt/celt-0.11.1-r1.ebuild
new file mode 100644
index 000000000000..8e5b92c272c3
--- /dev/null
+++ b/media-libs/celt/celt-0.11.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/celt/celt-0.11.1-r1.ebuild,v 1.1 2013/08/11 18:34:09 aballier Exp $
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="CELT is a very low delay audio codec designed for high-quality communications."
+HOMEPAGE="http://www.celt-codec.org/"
+SRC_URI="http://downloads.us.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ogg static-libs"
+
+DEPEND="ogg? ( media-libs/libogg )"
+RDEPEND="${DEPEND}"
+DOCS=( README TODO )
+
+multilib_src_configure() {
+ # ogg is for the binaries
+ local myconf="--without-ogg"
+ multilib_is_native_abi && myconf="$(use_with ogg ogg /usr)"
+
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+}