summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2005-01-26 12:32:20 +0000
committerAkinori Hattori <hattya@gentoo.org>2005-01-26 12:32:20 +0000
commit3bca488a165a62e8ace3296dcfecab65f5ab1869 (patch)
tree2ba299cbf0c2735a38a3e41b76a05167db6d3765 /media-libs/compface/compface-1.5.1.ebuild
parentversion bump. added -fPIC for amd64 systems (bug #45755). enabled gpilot plug... (diff)
downloadgentoo-2-3bca488a165a62e8ace3296dcfecab65f5ab1869.tar.gz
gentoo-2-3bca488a165a62e8ace3296dcfecab65f5ab1869.tar.bz2
gentoo-2-3bca488a165a62e8ace3296dcfecab65f5ab1869.zip
new upstream release. fixes bug #79035.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'media-libs/compface/compface-1.5.1.ebuild')
-rw-r--r--media-libs/compface/compface-1.5.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/compface/compface-1.5.1.ebuild b/media-libs/compface/compface-1.5.1.ebuild
new file mode 100644
index 000000000000..e61cf623fd3e
--- /dev/null
+++ b/media-libs/compface/compface-1.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/compface/compface-1.5.1.ebuild,v 1.1 2005/01/26 12:32:20 hattya Exp $
+
+IUSE=""
+
+inherit eutils
+
+DESCRIPTION="Utilities and library to convert to/from X-Face format"
+HOMEPAGE="http://www.xemacs.org/Download/optLibs.html"
+SRC_URI="http://ftp.xemacs.org/pub/xemacs/aux/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ sed -i -e "s:\r::" Makefile.in
+ epatch ${FILESDIR}/${P}-destdir.diff
+ WANT_AUTOCONF=2.5 autoconf
+
+}
+
+src_install() {
+
+ dodir /usr/share/man/man{1,3} /usr/{bin,include,$(get_libdir)}
+ make DESTDIR="${D}" install || die
+
+ newbin xbm2xface{.pl,}
+ dodoc README ChangeLog
+
+}