summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 17:25:02 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 17:25:02 +0000
commit817c68a825ed3d25e95b443b633d331d91111d6a (patch)
tree05e74b5c714945277014cfd208b06aabfc56c4e5 /media-libs/flac/flac-1.1.1.ebuild
parentRemove old versions. (diff)
downloadgentoo-2-817c68a825ed3d25e95b443b633d331d91111d6a.tar.gz
gentoo-2-817c68a825ed3d25e95b443b633d331d91111d6a.tar.bz2
gentoo-2-817c68a825ed3d25e95b443b633d331d91111d6a.zip
Remove old versions.
(Portage version: 2.1.2_pre3-r5) (Signed Manifest commit)
Diffstat (limited to 'media-libs/flac/flac-1.1.1.ebuild')
-rw-r--r--media-libs/flac/flac-1.1.1.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/media-libs/flac/flac-1.1.1.ebuild b/media-libs/flac/flac-1.1.1.ebuild
deleted file mode 100644
index 5216646ea874..000000000000
--- a/media-libs/flac/flac-1.1.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.1.1.ebuild,v 1.23 2006/01/29 15:47:50 blubb Exp $
-
-inherit libtool eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="free lossless audio encoder which includes an XMMS plugin"
-HOMEPAGE="http://flac.sourceforge.net/"
-SRC_URI="mirror://sourceforge/flac/${P}.tar.gz
- mirror://gentoo/${P}-altivec.patch.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 sh sparc x86"
-IUSE="sse xmms"
-
-RDEPEND=">=media-libs/libogg-1.0_rc2
- xmms? ( media-sound/xmms )"
-DEPEND="${RDEPEND}
- x86? ( dev-lang/nasm )
- sys-apps/gawk"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- if ! use xmms
- then
- sed -i -e '/^@FLaC__HAS_XMMS_TRUE/d' src/Makefile.in || die
- fi
-
- epatch ${FILESDIR}/${P}-m4.patch
- epatch ${FILESDIR}/${P}-libtool.patch
- epatch ${WORKDIR}/${P}-altivec.patch
-
- elibtoolize --reverse-deps
-}
-
-src_compile() {
- use hppa && [ "`gcc-fullversion`" == "3.4.0" ] && replace-cpu-flags 2.0 1.0
-
- econf \
- --with-pic \
- `use_enable sse` \
- || die
-
- # the man page ebuild requires docbook2man... yick!
- sed -i -e 's:include man:include:g' Makefile
-
- # emake seems to mess up the building of the xmms input plugin
- make || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS README
-
- # Keep around old lib
- preserve_old_lib /usr/$(get_libdir)/libFLAC.so.4
- preserve_old_lib /usr/$(get_libdir)/libFLAC++.so.2
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /usr/$(get_libdir)/libFLAC.so.4
- preserve_old_lib_notify /usr/$(get_libdir)/libFLAC++.so.2
-}
-
-# see #59482
-src_test() { :; }