summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-04-11 01:00:59 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-04-11 01:00:59 +0000
commit76e50f847e3f72122e44fa7a4fd8aa13a797bc70 (patch)
tree266b46744fa7b3d5ca66a80dcfb511e25fd927fd /media-libs/fontconfig/fontconfig-2.5.0-r1.ebuild
parentVersion bump (diff)
downloadgentoo-2-76e50f847e3f72122e44fa7a4fd8aa13a797bc70.tar.gz
gentoo-2-76e50f847e3f72122e44fa7a4fd8aa13a797bc70.tar.bz2
gentoo-2-76e50f847e3f72122e44fa7a4fd8aa13a797bc70.zip
Disable doc regeneration with USE="-doc" (bug #310157). Drop epunt_cxx
call that hasn't been applying for a while now. Remove old. (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/fontconfig/fontconfig-2.5.0-r1.ebuild')
-rw-r--r--media-libs/fontconfig/fontconfig-2.5.0-r1.ebuild91
1 files changed, 0 insertions, 91 deletions
diff --git a/media-libs/fontconfig/fontconfig-2.5.0-r1.ebuild b/media-libs/fontconfig/fontconfig-2.5.0-r1.ebuild
deleted file mode 100644
index e331b7df4ded..000000000000
--- a/media-libs/fontconfig/fontconfig-2.5.0-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.5.0-r1.ebuild,v 1.11 2009/12/14 10:02:29 remi Exp $
-
-inherit eutils libtool autotools
-
-DESCRIPTION="A library for configuring and customizing font access"
-HOMEPAGE="http://fontconfig.org/"
-SRC_URI="http://fontconfig.org/release/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="1.0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="doc xml"
-
-RDEPEND=">=media-libs/freetype-2.1.4
- !xml? ( >=dev-libs/expat-1.95.3 )
- xml? ( >=dev-libs/libxml2-2.6 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? ( app-text/docbook-sgml-utils )"
-PDEPEND="app-admin/eselect-fontconfig"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- # add docbook switch so we can disable it
- epatch "${FILESDIR}"/${PN}-2.3.2-docbook.patch
- epatch "${FILESDIR}"/${P}-libtool-2.2.patch #213831 Fix libtool-2.2 brekage
-
- eautoreconf
- epunt_cxx #74077
-}
-
-src_compile() {
- # I'm thinking this should be removed
- [[ ${ARCH} == alpha && ${CC} == ccc ]] && \
- die "Dont compile fontconfig with ccc, it doesnt work very well"
-
- # disable docs only disables local docs generation, they come with the tarball
- econf $(use_enable doc docs) \
- $(use_enable doc docbook) \
- --localstatedir=/var \
- --with-docdir=/usr/share/doc/${PF} \
- --with-default-fonts=/usr/share/fonts \
- --with-add-fonts=/usr/local/share/fonts \
- $(use_enable xml libxml2) \
- || die
-
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- insinto /etc/fonts
- doins "${S}"/fonts.conf
-
- newman doc/fonts-conf.5 fonts.conf.5
- dohtml doc/fontconfig-user.html
- dodoc doc/fontconfig-user.{txt,pdf}
-
- if use doc; then
- doman doc/Fc*.3
- dohtml doc/fontconfig-devel.html doc
- dohtml -r doc/fontconfig-devel
- dodoc doc/fontconfig-devel.{txt,pdf}
- fi
-
- dodoc AUTHORS ChangeLog NEWS README
-
- # Changes should be made to /etc/fonts/local.conf, and as we had
- # too much problems with broken fonts.conf, we force update it ...
- # <azarah@gentoo.org> (11 Dec 2002)
- echo 'CONFIG_PROTECT_MASK="/etc/fonts/fonts.conf"' > "${T}"/37fontconfig
- doenvd "${T}"/37fontconfig
-}
-
-pkg_postinst() {
- echo
- ewarn "Please make fontconfig configuration changes in /etc/fonts/conf.d/"
- ewarn "and NOT to /etc/fonts/fonts.conf, as it will be replaced!"
- echo
-
- if [[ ${ROOT} = / ]]; then
- ebegin "Creating global font cache..."
- /usr/bin/fc-cache -sr
- eend $?
- fi
-}