summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-11-02 07:32:59 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-11-02 07:32:59 +0000
commit57a74669c588d3d40ae140818e2f9eb0738765e2 (patch)
tree083420f19a3fc9c26b5bc37be97bc00f834e5daa /media-libs/fontconfig
parentTypo fix. (diff)
downloadgentoo-2-57a74669c588d3d40ae140818e2f9eb0738765e2.tar.gz
gentoo-2-57a74669c588d3d40ae140818e2f9eb0738765e2.tar.bz2
gentoo-2-57a74669c588d3d40ae140818e2f9eb0738765e2.zip
bugfix
Diffstat (limited to 'media-libs/fontconfig')
-rw-r--r--media-libs/fontconfig/ChangeLog7
-rw-r--r--media-libs/fontconfig/files/digest-fontconfig-2.0-r31
-rw-r--r--media-libs/fontconfig/files/patch/fontconfig-2.0-font-matrix.patch14
-rw-r--r--media-libs/fontconfig/fontconfig-2.0-r3.ebuild73
4 files changed, 94 insertions, 1 deletions
diff --git a/media-libs/fontconfig/ChangeLog b/media-libs/fontconfig/ChangeLog
index 6b1b86e86097..b15fd98bf884 100644
--- a/media-libs/fontconfig/ChangeLog
+++ b/media-libs/fontconfig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/fontconfig
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.6 2002/10/29 21:13:38 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.7 2002/11/02 07:32:59 azarah Exp $
+
+*fontconfig-2.0-r3 (31 Oct 2002)
+
+ 31 Oct 2002; Martin Schlemmer <azarah@gentoo.org> fontconfig-2.0-r3.ebuild :
+ Add patch to close bug #10028.
*fontconfig-2.0-r2 (29 Oct 2002)
diff --git a/media-libs/fontconfig/files/digest-fontconfig-2.0-r3 b/media-libs/fontconfig/files/digest-fontconfig-2.0-r3
new file mode 100644
index 000000000000..05efa21a9a47
--- /dev/null
+++ b/media-libs/fontconfig/files/digest-fontconfig-2.0-r3
@@ -0,0 +1 @@
+MD5 5ef5c58e501b0cb873ee2b2a04ed74e3 fcpackage.2_0.tar.gz 538159
diff --git a/media-libs/fontconfig/files/patch/fontconfig-2.0-font-matrix.patch b/media-libs/fontconfig/files/patch/fontconfig-2.0-font-matrix.patch
new file mode 100644
index 000000000000..45d00dd069e0
--- /dev/null
+++ b/media-libs/fontconfig/files/patch/fontconfig-2.0-font-matrix.patch
@@ -0,0 +1,14 @@
+diff -ur fcpackage.2_0/fontconfig/fonts.conf.in fcpackage.2_0-new/fontconfig/fonts.conf.in
+--- fcpackage.2_0/fontconfig/fonts.conf.in 2002-10-31 15:08:28.000000000 -0500
++++ fcpackage.2_0-new/fontconfig/fonts.conf.in 2002-10-31 15:06:46.000000000 -0500
+@@ -225,8 +225,8 @@
+ <edit name="matrix" mode="assign">
+ <times>
+ <name>matrix</name>
+- <matrix><double>1</double><double>.2</double>
+- <double>0</double><double>1</double>
++ <matrix><double>1</double><double>0</double>
++ <double>.2</double><double>1</double>
+ </matrix>
+ </times>
+ </edit>
diff --git a/media-libs/fontconfig/fontconfig-2.0-r3.ebuild b/media-libs/fontconfig/fontconfig-2.0-r3.ebuild
new file mode 100644
index 000000000000..2bc30e349961
--- /dev/null
+++ b/media-libs/fontconfig/fontconfig-2.0-r3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.0-r3.ebuild,v 1.1 2002/11/02 07:32:59 azarah Exp $
+
+S="${WORKDIR}/fcpackage.${PV/\./_}/fontconfig"
+DESCRIPTION="A library for configuring and customizing font access."
+SRC_URI="http://fontconfig.org/release/fcpackage.${PV/\./_}.tar.gz"
+HOMEPAGE="http://fontconfig.org/"
+
+LICENSE="fontconfig"
+SLOT="1.0"
+KEYWORDS="x86 alpha ppc sparc sparc64"
+
+DEPEND=">=media-libs/freetype-2.0.9
+ >=dev-libs/expat-1.95.3
+ >=sys-apps/ed-0.2"
+
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ local PPREFIX="${FILESDIR}/patch/${PN}"
+ einfo "Applying patches..."
+ # Some patches from Redhat
+ patch -p1 < ${PPREFIX}-2.0-defaultconfig.patch &> /dev/null || die
+ patch -p1 < ${PPREFIX}-0.0.1.020811.1151-slighthint.patch &> /dev/null || die
+ # Blacklist certain fonts that freetype can't handle
+ patch -p1 < ${PPREFIX}-0.0.1.020826.1330-blacklist.patch &> /dev/null || die
+ # Patch from Keith Packard to fix problem where
+ # subdirectories could get lost from ~/.fonts.cache
+ patch -p1 < ${PPREFIX}-2.0-subdir.patch &> /dev/null || die
+ # Remove stupid date, as a lot of users do not seem to know
+ # how to use 'zic' ...
+ patch -p2 < ${PPREFIX}-2.0-remove-stupid-date.patch &> /dev/null || die
+ # Fix problem with italic fonts if no map file present
+ patch -p2 < ${PPREFIX}-2.0-font-matrix.patch &> /dev/null || die
+}
+
+src_compile() {
+ econf || die
+
+ emake || die
+}
+
+src_install() {
+ einstall confdir=${D}/etc/fonts \
+ datadir=${D}/usr/share || die
+
+ insinto /etc/fonts
+ doins ${S}/fonts.conf
+
+ cd ${S}
+
+ mv fc-cache/fc-cache.man fc-cache/fc-cache.1
+ mv fc-list/fc-list.man fc-list/fc-list.1
+ mv src/fontconfig.man src/fontconfig.3
+ for x in fc-cache/fc-cache.1 fc-list/fc-list.1 src/fontconfig.3
+ do
+ doman ${x}
+ done
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]
+ then
+ einfo "Creating font cache..."
+ /usr/bin/fc-cache
+ fi
+}
+