summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-01 19:48:01 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-01 19:48:01 +0000
commitb039cc7786a132910ad8382e72167876adab514f (patch)
treec0e345b712b65c09b90004915bd38d1beff2924b /media-libs/fontconfig
parentInitial commit. (diff)
downloadgentoo-2-b039cc7786a132910ad8382e72167876adab514f.tar.gz
gentoo-2-b039cc7786a132910ad8382e72167876adab514f.tar.bz2
gentoo-2-b039cc7786a132910ad8382e72167876adab514f.zip
Install fc-lang directory, needed to test font language coverage.
(Portage version: 2.1.5.2)
Diffstat (limited to 'media-libs/fontconfig')
-rw-r--r--media-libs/fontconfig/ChangeLog8
-rw-r--r--media-libs/fontconfig/fontconfig-2.5.93-r1.ebuild88
2 files changed, 95 insertions, 1 deletions
diff --git a/media-libs/fontconfig/ChangeLog b/media-libs/fontconfig/ChangeLog
index c37e2ea23140..87316e5af747 100644
--- a/media-libs/fontconfig/ChangeLog
+++ b/media-libs/fontconfig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/fontconfig
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.113 2008/05/30 18:53:46 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.114 2008/06/01 19:48:01 loki_val Exp $
+
+*fontconfig-2.5.93-r1 (01 Jun 2008)
+
+ 01 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +fontconfig-2.5.93-r1.ebuild:
+ Install fc-lang directory, needed to test font language coverage.
30 May 2008; Alexis Ballier <aballier@gentoo.org>
fontconfig-2.5.93.ebuild:
diff --git a/media-libs/fontconfig/fontconfig-2.5.93-r1.ebuild b/media-libs/fontconfig/fontconfig-2.5.93-r1.ebuild
new file mode 100644
index 000000000000..96634430bfb7
--- /dev/null
+++ b/media-libs/fontconfig/fontconfig-2.5.93-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.5.93-r1.ebuild,v 1.1 2008/06/01 19:48:01 loki_val Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="A library for configuring and customizing font access"
+HOMEPAGE="http://fontconfig.org/"
+SRC_URI="http://fontconfig.org/release/${P}.tar.gz"
+
+LICENSE="fontconfig"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="doc xml"
+
+RDEPEND=">=media-libs/freetype-2.1.4
+ !xml? ( >=dev-libs/expat-1.95.3 )
+ xml? ( >=dev-libs/libxml2-2.6 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-text/docbook-sgml-utils )"
+PDEPEND="app-admin/eselect-fontconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epunt_cxx #74077
+ # Neeeded to get a sane .so versionning on fbsd, please dont drop
+ # If you have to run eautoreconf, you can also leave the elibtoolize call as
+ # it will be a no-op.
+ elibtoolize
+}
+
+src_compile() {
+ econf $(use_enable doc docs) \
+ --localstatedir=/var \
+ --with-docdir=/usr/share/doc/${PF} \
+ --with-default-fonts=/usr/share/fonts \
+ --with-add-fonts=/usr/local/share/fonts \
+ $(use_enable xml libxml2) \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ #fc-lang directory contains language coverage datafiles
+ #which are needed to test the coverage of fonts.
+ insinto /usr/share/fc-lang
+ doins fc-lang/*.orth
+
+ insinto /etc/fonts
+ doins "${S}"/fonts.conf
+
+ doman $(find "${S}" -type f -name *.1 -print)
+ newman doc/fonts-conf.5 fonts.conf.5
+ dodoc doc/fontconfig-user.{txt,pdf}
+
+ if use doc; then
+ doman doc/Fc*.3
+ dohtml doc/fontconfig-devel.html doc
+ dodoc doc/fontconfig-devel.{txt,pdf}
+ fi
+
+ dodoc AUTHORS ChangeLog README
+
+ # Changes should be made to /etc/fonts/local.conf, and as we had
+ # too much problems with broken fonts.conf, we force update it ...
+ # <azarah@gentoo.org> (11 Dec 2002)
+ echo 'CONFIG_PROTECT_MASK="/etc/fonts/fonts.conf"' > "${T}"/37fontconfig
+ doenvd "${T}"/37fontconfig
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Please make fontconfig configuration changes in /etc/fonts/conf.d/"
+ ewarn "and NOT to /etc/fonts/fonts.conf, as it will be replaced!"
+ echo
+
+ if [[ ${ROOT} = / ]]; then
+ ebegin "Creating global font cache..."
+ /usr/bin/fc-cache -sr
+ eend $?
+ fi
+}