summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-22 16:44:19 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-22 16:44:19 +0000
commitbc3992637d85b75960d4bff86f5fd9b22b7f83b9 (patch)
tree8a6efa6d978382d60e589d65b401d93102a64e48 /media-libs/freetype
parent*** empty log message *** (diff)
downloadgentoo-2-bc3992637d85b75960d4bff86f5fd9b22b7f83b9.tar.gz
gentoo-2-bc3992637d85b75960d4bff86f5fd9b22b7f83b9.tar.bz2
gentoo-2-bc3992637d85b75960d4bff86f5fd9b22b7f83b9.zip
Added some missing files
Diffstat (limited to 'media-libs/freetype')
-rw-r--r--media-libs/freetype/files/config.mk49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/freetype/files/config.mk b/media-libs/freetype/files/config.mk
new file mode 100644
index 000000000000..027f3c96b257
--- /dev/null
+++ b/media-libs/freetype/files/config.mk
@@ -0,0 +1,49 @@
+#
+# FreeType 2 configuration rules for UNIX platforms
+#
+
+
+# Copyright 1996-2000 by
+# David Turner, Robert Wilhelm, and Werner Lemberg.
+#
+# This file is part of the FreeType project, and may only be used, modified,
+# and distributed under the terms of the FreeType project license,
+# LICENSE.TXT. By continuing to use, modify, or distribute this file you
+# indicate that you have read the license and understand and accept it
+# fully.
+
+
+include $(TOP)/builds/unix/unix-def.mk
+include $(TOP)/builds/unix/unix-cc.mk
+
+ifdef BUILD_PROJECT
+
+ # Now include the main sub-makefile. It contains all the rules used to
+ # build the library with the previous variables defined.
+ #
+ include $(TOP)/builds/$(PROJECT).mk
+
+
+ # The cleanup targets.
+ #
+ clean_project: clean_project_unix
+ distclean_project: distclean_project_unix
+
+
+ # This final rule is used to link all object files into a single library.
+ # It is part of the system-specific sub-Makefile because not all
+ # librarians accept a simple syntax like
+ #
+ # librarian library_file {list of object files}
+ #
+ $(PROJECT_LIBRARY): $(OBJECTS_LIST)
+ifdef CLEAN_LIBRARY
+ -$(CLEAN_LIBRARY) $(NO_OUTPUT)
+endif
+ $(LINK_LIBRARY)
+
+endif
+
+include $(TOP)/builds/unix/install.mk
+
+# EOF