summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-19 12:06:37 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-19 12:06:37 +0000
commita2aceba7f6fa68a26e288a655e9851bdc1f66c96 (patch)
tree68f0b4fecc8743c8b43cd7d7331bf3242b150581 /media-libs/gexiv2
parentRestore stable keywords which were accidentally dropped when syncing (diff)
downloadgentoo-2-a2aceba7f6fa68a26e288a655e9851bdc1f66c96.tar.gz
gentoo-2-a2aceba7f6fa68a26e288a655e9851bdc1f66c96.tar.bz2
gentoo-2-a2aceba7f6fa68a26e288a655e9851bdc1f66c96.zip
media-libs/gexiv2: Version Bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'media-libs/gexiv2')
-rw-r--r--media-libs/gexiv2/ChangeLog8
-rw-r--r--media-libs/gexiv2/gexiv2-0.6.0.ebuild50
-rw-r--r--media-libs/gexiv2/metadata.xml2
3 files changed, 58 insertions, 2 deletions
diff --git a/media-libs/gexiv2/ChangeLog b/media-libs/gexiv2/ChangeLog
index ca715bdc4302..3035f553e6b3 100644
--- a/media-libs/gexiv2/ChangeLog
+++ b/media-libs/gexiv2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gexiv2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/ChangeLog,v 1.15 2013/02/02 22:47:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/ChangeLog,v 1.16 2013/03/19 12:06:37 jlec Exp $
+
+*gexiv2-0.6.0 (19 Mar 2013)
+
+ 19 Mar 2013; Justin Lecher <jlec@gentoo.org> +gexiv2-0.6.0.ebuild,
+ metadata.xml:
+ Version Bump
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> gexiv2-0.4.1.ebuild:
Add ~arm, wrt bug #449220
diff --git a/media-libs/gexiv2/gexiv2-0.6.0.ebuild b/media-libs/gexiv2/gexiv2-0.6.0.ebuild
new file mode 100644
index 000000000000..31208781fe4a
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/gexiv2-0.6.0.ebuild,v 1.1 2013/03/19 12:06:37 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit eutils multilib python-r1 toolchain-funcs versionator
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library."
+HOMEPAGE="http://trac.yorba.org/wiki/gexiv2/"
+SRC_URI="http://www.yorba.org/download/${PN}/${MY_PV}/lib${PN}_${PV}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="introspection static-libs"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=media-gfx/exiv2-0.21"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/lib${P}
+
+src_prepare() {
+ tc-export CXX
+ sed -e 's:CFLAGS:CXXFLAGS:g' -i Makefile || die
+}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ $(use_enable introspection) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIB="$(get_libdir)" install
+ dodoc AUTHORS NEWS README THANKS
+
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+
+ use static-libs || find "${D}" \( -name '*.a' -or -name '*.la' \) -delete
+}
diff --git a/media-libs/gexiv2/metadata.xml b/media-libs/gexiv2/metadata.xml
index a083c07fab9e..9be90a258970 100644
--- a/media-libs/gexiv2/metadata.xml
+++ b/media-libs/gexiv2/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>graphics</herd>
+ <herd>graphics</herd>
</pkgmetadata>