summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-06-24 17:13:48 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-06-24 17:13:48 +0000
commit8eeee40951b03de5b543d15fbf0f419f1a7aff2f (patch)
treeab78da00ab148f37404f3ae14cc3ec071a75e0b9 /media-libs/gluon
parentUpdate USE descriptions. (diff)
downloadgentoo-2-8eeee40951b03de5b543d15fbf0f419f1a7aff2f.tar.gz
gentoo-2-8eeee40951b03de5b543d15fbf0f419f1a7aff2f.tar.bz2
gentoo-2-8eeee40951b03de5b543d15fbf0f419f1a7aff2f.zip
Version bump. Add a patch from upstream to fix build with GCC 4.7, wrt bug #423337.
(Portage version: 2.1.11.1/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gluon')
-rw-r--r--media-libs/gluon/ChangeLog12
-rw-r--r--media-libs/gluon/files/gluon-0.71.0-gcc-4.7.patch30
-rw-r--r--media-libs/gluon/gluon-0.71.0.ebuild37
3 files changed, 76 insertions, 3 deletions
diff --git a/media-libs/gluon/ChangeLog b/media-libs/gluon/ChangeLog
index 3457068b1c30..52ea17535857 100644
--- a/media-libs/gluon/ChangeLog
+++ b/media-libs/gluon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/gluon
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gluon/ChangeLog,v 1.3 2011/10/28 23:53:45 abcd Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gluon/ChangeLog,v 1.4 2012/06/24 17:13:48 kensington Exp $
+
+*gluon-0.71.0 (24 Jun 2012)
+
+ 24 Jun 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/gluon-0.71.0-gcc-4.7.patch, +gluon-0.71.0.ebuild:
+ Version bump. Add a patch from upstream to fix build with GCC 4.7, wrt bug
+ #423337.
28 Oct 2011; Jonathan Callen <abcd@gentoo.org> gluon-0.70.0.ebuild:
Bump to EAPI=4
@@ -13,4 +20,3 @@
06 Jun 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+gluon-0.70.0.ebuild, +metadata.xml:
[media-libs/gluon] Initial import to the tree of the first alpha release.
-
diff --git a/media-libs/gluon/files/gluon-0.71.0-gcc-4.7.patch b/media-libs/gluon/files/gluon-0.71.0-gcc-4.7.patch
new file mode 100644
index 000000000000..5f54687f3527
--- /dev/null
+++ b/media-libs/gluon/files/gluon-0.71.0-gcc-4.7.patch
@@ -0,0 +1,30 @@
+commit bccbda88a6bc53ac20091bb6aefd2f1b501ba31a
+Author: Christoph Feck <christoph@maxiom.de>
+Date: Fri Mar 23 23:35:09 2012 +0100
+
+ Fix includes
+
+diff --git a/input/linux/detectlinux.cpp b/input/linux/detectlinux.cpp
+index 632249a..6ae85a4 100644
+--- a/input/linux/detectlinux.cpp
++++ b/input/linux/detectlinux.cpp
+@@ -26,6 +26,7 @@
+
+ #include <QtCore/QDir>
+
++#include <unistd.h>
+ // #include <libudev.h>
+
+ using namespace GluonInput;
+diff --git a/input/linux/inputthread.cpp b/input/linux/inputthread.cpp
+index f92b104..202745e 100644
+--- a/input/linux/inputthread.cpp
++++ b/input/linux/inputthread.cpp
+@@ -30,6 +30,7 @@
+ // #include <QtCore/QStringList>
+
+ #include <fcntl.h>
++#include <unistd.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <linux/input.h>
diff --git a/media-libs/gluon/gluon-0.71.0.ebuild b/media-libs/gluon/gluon-0.71.0.ebuild
new file mode 100644
index 000000000000..a706dc4b27de
--- /dev/null
+++ b/media-libs/gluon/gluon-0.71.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gluon/gluon-0.71.0.ebuild,v 1.1 2012/06/24 17:13:48 kensington Exp $
+
+EAPI=4
+
+OPENGL_REQUIRED="always"
+inherit kde4-base versionator
+
+DESCRIPTION="Gluon is a Free and Open Source framework for creating and distributing games."
+HOMEPAGE="http://gluon.tuxfamily.org/"
+SRC_URI="mirror://kde/unstable/${PN}/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64"
+SLOT="4"
+IUSE="debug examples"
+
+DEPEND="
+ media-libs/alure
+ media-libs/libsndfile
+ media-libs/openal
+ virtual/glu
+ virtual/opengl
+ x11-libs/qt-declarative:4
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-gcc-4.7.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use examples INSTALL_EXAMPLES)
+ )
+
+ kde4-base_src_configure
+}